summaryrefslogtreecommitdiff
path: root/sys-apps/arch-chroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 21:49:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 21:49:24 +0000
commita1c55a7e2f400a6170fd3df167bfdc299c05e2db (patch)
tree63add7e7943810930ca6e296397ef4bdea18eb6b /sys-apps/arch-chroot
parentc18398e8c10c222f0daed55f7d69339e3c7885bd (diff)
gentoo auto-resync : 24:02:2023 - 21:49:24
Diffstat (limited to 'sys-apps/arch-chroot')
-rw-r--r--sys-apps/arch-chroot/Manifest3
-rw-r--r--sys-apps/arch-chroot/arch-chroot-28.ebuild32
-rw-r--r--sys-apps/arch-chroot/metadata.xml19
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/arch-chroot/Manifest b/sys-apps/arch-chroot/Manifest
new file mode 100644
index 000000000000..3d1f197d432e
--- /dev/null
+++ b/sys-apps/arch-chroot/Manifest
@@ -0,0 +1,3 @@
+DIST arch-install-scripts-v28.tar.gz 19730 BLAKE2B 0ff5ba79b200ad642e049ec19217cc5c0794d627a28f42e03c0df2444fef4d8488a6ee011d26fb8fe958c1a1a2fa0a13920567e394b2389c772f516b1fe8f388 SHA512 09a027b04b70e01ccd1fd82e3a443c876bdf978b94a922de9dea4dbc187360460ea35720816724b72fc31b02338b11bf39b47ec9156518a8a3ade000530bf1df
+EBUILD arch-chroot-28.ebuild 806 BLAKE2B ab67004cad22d53edfa9c9c4cb49217bdb0dd8a5e67eac7c118de222914c645c4e0bf2001a08765a1a721f619723ff7a5d7a8e7d2c83226bd47ed48b652efee0 SHA512 36d12e66e823f95856ef3b1f86b47890460578a731ed851a6013f9f8b13423e0639b740d10d1f48a0664fb7e3d5daa63571f55061bad17b024a95ce9254baf0f
+MISC metadata.xml 660 BLAKE2B 563818fc11864a0cc992d1ae36b2da1d7419dbed8fc5c63428b64c073af630139c1154a4e818b4dacb2e9d56923338483d4c290ef943745401d5ee905276d518 SHA512 885e4cc9b4f1795445a394dc401270263da33c030a8233c6a8efb2d1ec034cf915fe40d94e93122dfe4db91205593eaef2e69439197d77208194bdeea0ba75c6
diff --git a/sys-apps/arch-chroot/arch-chroot-28.ebuild b/sys-apps/arch-chroot/arch-chroot-28.ebuild
new file mode 100644
index 000000000000..78f61c92ae6f
--- /dev/null
+++ b/sys-apps/arch-chroot/arch-chroot-28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Wraps the chroot command while ensuring that important filesystems are mounted"
+HOMEPAGE="https://github.com/archlinux/arch-install-scripts"
+SRC_URI="https://github.com/archlinux/arch-install-scripts/archive/refs/tags/v${PV}.tar.gz -> arch-install-scripts-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+
+BDEPEND="app-text/asciidoc"
+
+S="${WORKDIR}/arch-install-scripts-${PV}"
+
+src_compile() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot"
+}
+
+src_test() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot" check
+}
+
+src_install() {
+ dobin arch-chroot
+ doman doc/arch-chroot.8
+ newbashcomp "completion/arch-chroot.bash" "arch-chroot"
+}
diff --git a/sys-apps/arch-chroot/metadata.xml b/sys-apps/arch-chroot/metadata.xml
new file mode 100644
index 000000000000..7350009d97ca
--- /dev/null
+++ b/sys-apps/arch-chroot/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>cat@catcream.org</email>
+ <name>Alfred Persson</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>peeweep@0x0.ee</email>
+ <name>jinqiang zhang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">archlinux/arch-install-scripts</remote-id>
+ </upstream>
+</pkgmetadata>