summaryrefslogtreecommitdiff
path: root/sys-apps/adjtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/adjtime
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/adjtime')
-rw-r--r--sys-apps/adjtime/Manifest5
-rw-r--r--sys-apps/adjtime/adjtime-0.4-r2.ebuild42
-rw-r--r--sys-apps/adjtime/metadata.xml12
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/adjtime/Manifest b/sys-apps/adjtime/Manifest
new file mode 100644
index 000000000000..f57d5ad7bf27
--- /dev/null
+++ b/sys-apps/adjtime/Manifest
@@ -0,0 +1,5 @@
+DIST adjtime.zip 2805 SHA256 64d0ffe0510ce727c3ead8bbc1e3c923a463253b375579b31040815cb6014800 SHA512 cc0f16ca19fea240300f9e0a9eddcefa07cb21f59fe4da8e7132dc75ec26ecaf7036ee6d282f8a488005b40077931e1cadc5634095aa0ff402f375bc0e83a1c0 WHIRLPOOL be5bec263c81fbbf97fb90dbe2df8351181a3c42dba00759700d71798dea93327731cc0647049781cdc0177bb943ae6b457299fe9cf32d4b77d6c88776216e16
+EBUILD adjtime-0.4-r2.ebuild 1241 SHA256 e5547f39b75059656dfc6b67034309ead95b3426ea4f78ea98ea6e7c310f61c7 SHA512 7a98a10acfbb9f2a30d5c6e519e07296d4ea114c08474333cf3cb6d240c8dd4b0ee1fdf450a6cc639213e3996c27926bfe9aa6ecaf68c7b763e906ddc31e939a WHIRLPOOL 8d0870d833b1f14c3d18253fb8f5310f3bc279920a9538465125b909f87c3ac2c724a0897b0965beeb64085a9c6a9d0ed2741a78fc90bb0082728779f99a7a8e
+MISC ChangeLog 2429 SHA256 0ff78a70c2dae6c1297d65a14d22673299bfe75b9f9c0b0428bf940ec519e527 SHA512 3b23f2ca69531e12e99593b21162bf6b8d2a624c66356c1d12aefbce0b9e2d233f9a0e5166bc39d81d6a79e1530160f141cc1051074f6616e0d550ed454fa9e9 WHIRLPOOL a290d7f3200b7bbcd21641daa766395bf923a2bc2ac0e8a40f0978a1c4a185e7063294e0183466ffbdb49993875e60fa1161ebf8284df06ddd0c57f58056bef1
+MISC ChangeLog-2015 1644 SHA256 41c67a870a96e8cbadeade3ba04137098b00785da893876d342924e44ac2266d SHA512 6c7a37c9f7bfa109058a876b128f480024ab7961142d49996e122adcadacb6f1e11287f5601ce1cd931a77c1c4a4cd1e27f8495387f7505a511a05785e76e1ed WHIRLPOOL 56c07b5a34462f73bd735d60d1d98a6c6efdaecbe0a4bc983f9bb732c3278ceda4fd91aed9a71994d3df563b87a33c0bc8f73428adb7803b13b0decbf04ef8cb
+MISC metadata.xml 455 SHA256 0f482d17bdf5da7ed98f6c8154a4bf959e2d3bb838660d16330cd86be150401a SHA512 56fbcfffe514b2ec0cf553fc2ed76ad73b4cbabad137b2d746c55b7ec4504cabdda1dfb4985ea434ee9d100d18cbf9f9ac795472380189d3386d9c2eea863221 WHIRLPOOL d3011fd79024b2fbb7aa5f81e0eb785b5e2bc70e2b135cc3d72d47ad0f6d04cb94e181fde02789a6c35f19322d3fb8f4d67411756e315b1ca2bcb4e28081a720
diff --git a/sys-apps/adjtime/adjtime-0.4-r2.ebuild b/sys-apps/adjtime/adjtime-0.4-r2.ebuild
new file mode 100644
index 000000000000..cae97c111c48
--- /dev/null
+++ b/sys-apps/adjtime/adjtime-0.4-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A perl script to adjust the clock tick of the hardware clock on the system board"
+HOMEPAGE="https://groups.yahoo.com/neo/groups/LinkStation_General/info"
+SRC_URI="http://www.gentoogeek.org/files/${PN}.zip"
+
+LICENSE="all-rights-reserved" #441922
+SLOT="0"
+KEYWORDS="ppc"
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/perl
+ >=net-misc/ntp-4.2"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i -e 's:/usr/sbin/tickadj:/usr/bin/tickadj:' adjtime.pl || die
+}
+
+src_install() {
+ dosbin adjtime.pl
+}
+
+pkg_postinst() {
+ ewarn "There have been issues with running adjtime as an init script"
+ ewarn "(the shell environment for perl is dorked up). The suggested"
+ ewarn "method is to use ntp-date rather than ntpd at startup, and"
+ ewarn "add the following two lines to local.start instead:"
+ ewarn
+ ewarn "/usr/bin/perl /usr/sbin/adjtime.pl -v -s ntp_host -i 60"
+ ewarn
+ ewarn "/etc/init.d/ntpd start"
+ ewarn
+ ewarn "replacing ntp_host with your preferred ntp server. Remember,"
+ ewarn "since adjtime uses ntp-date, ntpd must be stopped (or not yet"
+ ewarn "started) prior to running the adjtime script."
+}
diff --git a/sys-apps/adjtime/metadata.xml b/sys-apps/adjtime/metadata.xml
new file mode 100644
index 000000000000..f1525a5b549b
--- /dev/null
+++ b/sys-apps/adjtime/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ppc@gentoo.org</email>
+ <name>Gentoo Linux PowerPC Development</name>
+</maintainer>
+<longdescription>A perl script to adjust the tick on the Kurobox and
+ LinkStation hardware clock (required to keep an accurate clock).
+ Should work on most hardware platforms.
+</longdescription>
+</pkgmetadata>