summaryrefslogtreecommitdiff
path: root/sys-apps/acl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-apps/acl
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/Manifest3
-rw-r--r--sys-apps/acl/acl-2.2.53-r1.ebuild8
-rw-r--r--sys-apps/acl/acl-2.2.53.ebuild55
3 files changed, 8 insertions, 58 deletions
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index add13f344a9d..db65b57bc180 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -1,4 +1,3 @@
DIST acl-2.2.53.tar.gz 524300 BLAKE2B a4c602b18ab1a7932dce38c8dacf3a3026a3100a8a7e61f0740886ec7154a7738ca641953dc1253b5574580815d7f547a99bdd0cc0ee87238a1995abe97eb9d8 SHA512 176b7957fe0e7618e0b7bf2ac5071f7fa29417df718cce977661a576fa184e4af9d303b591c9d556b6ba8923e799457343afa401f5a9f7ecd9022185a4e06716
-EBUILD acl-2.2.53-r1.ebuild 1237 BLAKE2B 39f5f0317821aa2e09fb82a6f4e73a873ca325d26739dc12a588c118462a9c39e71c3e4d1ff62c835ab7fa30f770583de26ca688543b3db66f3feb1b2d8bc98d SHA512 ad373842f2ad07fa2ef5c180f483e99fc1594e28855316e2c3bf7f3ea5632fb40a8a880ec2cf60bb59080aa8451b00cf2d9292d1036b89cad55e82324641fc0e
-EBUILD acl-2.2.53.ebuild 1230 BLAKE2B 48c9e7a881e0d12f57c44a6ba93d4082d48152aa613c732102f5bf4cea4c88e6ee4c7ab1d1dfed8e60e233c66b8b3777fdc4dfb8a107e79d0c1a0053377ea1fb SHA512 b5d5a459509e116a3decc93ae6d49abf12f7b74b9f23176db8eeefb4a244cbb266ff6470c8af6cc65af2e553a49d25556fd027667f2c449ff5fc4f62fc647c17
+EBUILD acl-2.2.53-r1.ebuild 1388 BLAKE2B bb54a8d13adcdbc8c349501a314f08dcbbcc88ba35c511ed9d000f34495652474fa021e4eecbae1dd77a5b7ac6a04fbdc008aa07207dc79a216ab1518fb240e5 SHA512 ef48ffdf0891f550ae6b86d5b81cc00436ca791fb5583d976e6bad502e6a410498f468526fddf69ff1ec58db3c8c32e1803fe9d2ab2333dc983e6eec70cc0e53
MISC metadata.xml 293 BLAKE2B 2b8092a768f4f905c414e9bde92180e659085a60fd6ec13cecb29b6a88471941e7c8e2ad86f2864f44fa4f74589b20433ce64c3e89c3e210838b9d997deda136 SHA512 1e61b3f2d76e95eca037de073678326400b069526c8a308ca4169ce67d3e47c8cd199cca59f83fa245bb5fcbaa9efe7f31e34cf8588d69383ed0da78ab54cfaa
diff --git a/sys-apps/acl/acl-2.2.53-r1.ebuild b/sys-apps/acl/acl-2.2.53-r1.ebuild
index 261639dbb408..36ef9c8cb34a 100644
--- a/sys-apps/acl/acl-2.2.53-r1.ebuild
+++ b/sys-apps/acl/acl-2.2.53-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,12 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
+multilib_src_test() {
+ # Tests call native binaries with an LD_PRELOAD wrapper
+ # https://bugs.gentoo.org/772356
+ multilib_is_native_abi && default
+}
+
multilib_src_install() {
default
diff --git a/sys-apps/acl/acl-2.2.53.ebuild b/sys-apps/acl/acl-2.2.53.ebuild
deleted file mode 100644
index bb450925ad94..000000000000
--- a/sys-apps/acl/acl-2.2.53.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="access control list utilities, libraries and headers"
-HOMEPAGE="https://savannah.nongnu.org/projects/acl"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="nls static-libs"
-
-RDEPEND="
- >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # filter out -flto flags as they break getfacl/setfacl binaries
- # (bug #667372)
- filter-flags -flto*
-}
-
-src_prepare() {
- default
- elibtoolize #580792
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- $(use_enable static-libs static)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- $(use_enable nls)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- default
-
- # move shared libs to /
- gen_usr_ldscript -a acl
-}
-
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}" -type f -name "*.la" -delete || die
- fi
-}