summaryrefslogtreecommitdiff
path: root/sys-apps/acl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /sys-apps/acl
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/Manifest2
-rw-r--r--sys-apps/acl/acl-2.2.52-r2.ebuild65
-rw-r--r--sys-apps/acl/files/acl-2.2.52-xattr_header.patch201
3 files changed, 268 insertions, 0 deletions
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index c5d829b4a7f2..50e72bfed156 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -1,3 +1,5 @@
+AUX acl-2.2.52-xattr_header.patch 4777 BLAKE2B 8903fa3bcee96d43f9e142d70ee78fa59b9a6dc3618fb853352caff263afd05a83afa77f4ed70ecb010b32d113597a8c40ea711aeda14ac7bf387a0b407fb8ed SHA512 356eaedccba561d92f5a518dc1cba27c5e525bd9063ea852ed1f0597bb379996d7c56ae97c4a19e20e569dfe5cb2406b32453866f40466680e6fdc63e5a75906
DIST acl-2.2.52.src.tar.gz 386604 BLAKE2B e8b7b555cec93f84579aac846ce64235e356d73770844e88898564d1742fcf3d7c314511f0321aefbad33bdd85800406102178e8ab6414bc9c883891442d3188 SHA512 59973199d371cd0b2368e95bc829a1b47f04e808a174fefba4c6854e766158bd19a71d9dbcc8d6fdc1573a1f971cdda39c453f7fa243bce02c1ab97c6e7c72e7
EBUILD acl-2.2.52-r1.ebuild 1533 BLAKE2B 73da94f2dcc30de766614cd45dae855f5c2c79899061d104e61d25d9cf09c6345be3c6dc062410ba8da60cfe95f88f52451ffd000f82cb11a5b30ebb52b7f20c SHA512 ecd38a5958715e40c23390f7d38f29aa604fd4219a56293e87b2dabfab83462fa803a909dbc6d9105541535db6c63f5331d757a06d92874f59b4c044881dd81c
+EBUILD acl-2.2.52-r2.ebuild 1523 BLAKE2B 993d5d0790231e9afb2777812000c916519c307a8d1b9490e7d0b2d96c7d44ccc55d7a5247690c58510554bc948483e9de86f96881c1bb3bf4da81f8bfdab6f4 SHA512 d4ae75c33c5f93ead215360d69d7458ff1f6ea85aedb444a1ecd513c433da6f7826ddfc4942d8dbc2dcaecc2055b080cf6c257e7a7979c6771ac775a883e3f3a
MISC metadata.xml 293 BLAKE2B 2b8092a768f4f905c414e9bde92180e659085a60fd6ec13cecb29b6a88471941e7c8e2ad86f2864f44fa4f74589b20433ce64c3e89c3e210838b9d997deda136 SHA512 1e61b3f2d76e95eca037de073678326400b069526c8a308ca4169ce67d3e47c8cd199cca59f83fa245bb5fcbaa9efe7f31e34cf8588d69383ed0da78ab54cfaa
diff --git a/sys-apps/acl/acl-2.2.52-r2.ebuild b/sys-apps/acl/acl-2.2.52-r2.ebuild
new file mode 100644
index 000000000000..4bc0d2945f1c
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.52-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils libtool ltprune toolchain-funcs multilib-minimal
+
+DESCRIPTION="access control list utilities, libraries and headers"
+HOMEPAGE="https://savannah.nongnu.org/projects/acl"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="
+ >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-xattr_header.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die
+ strip-linguas po
+ elibtoolize #580792
+
+ # same as https://savannah.nongnu.org/bugs/index.php?39736
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-shared $(use_enable static-libs static)
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable nls gettext)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DIST_ROOT="${D}" install install-dev install-lib
+
+ # move shared libs to /
+ gen_usr_ldscript -a acl
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sys-apps/acl/files/acl-2.2.52-xattr_header.patch b/sys-apps/acl/files/acl-2.2.52-xattr_header.patch
new file mode 100644
index 000000000000..052941f92c82
--- /dev/null
+++ b/sys-apps/acl/files/acl-2.2.52-xattr_header.patch
@@ -0,0 +1,201 @@
+Backported from:
+http://git.savannah.nongnu.org/cgit/acl.git/commit/?id=79f563779b9b9ba89cc2352d70e3cdf27acff513
+
+--- acl-2.2.52/libacl/acl_delete_def_file.c
++++ acl-2.2.52/libacl/acl_delete_def_file.c
+@@ -20,11 +20,11 @@
+ */
+
+ #include <sys/types.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "byteorder.h"
+ #include "acl_ea.h"
+ #include "config.h"
+-
++#include "libacl.h"
+
+ /* 23.4.8 */
+ int
+--- acl-2.2.52/libacl/acl_extended_fd.c
++++ acl-2.2.52/libacl/acl_extended_fd.c
+@@ -20,13 +20,12 @@
+ */
+
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+
+ #include "byteorder.h"
+ #include "acl_ea.h"
+
+-
+ int
+ acl_extended_fd(int fd)
+ {
+--- acl-2.2.52/libacl/__acl_extended_file.c
++++ acl-2.2.52/libacl/__acl_extended_file.c
+@@ -20,14 +20,13 @@
+ */
+
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+
+ #include "byteorder.h"
+ #include "acl_ea.h"
+ #include "__acl_extended_file.h"
+
+-
+ int
+ __acl_extended_file(const char *path_p,
+ ssize_t (*fun)(const char *, const char *,
+--- acl-2.2.52/libacl/acl_extended_file.c
++++ acl-2.2.52/libacl/acl_extended_file.c
+@@ -20,7 +20,7 @@
+ */
+
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+
+ #include "__acl_extended_file.h"
+--- acl-2.2.52/libacl/acl_extended_file_nofollow.c
++++ acl-2.2.52/libacl/acl_extended_file_nofollow.c
+@@ -20,7 +20,7 @@
+ */
+
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+
+ #include "__acl_extended_file.h"
+--- acl-2.2.52/libacl/acl_get_fd.c
++++ acl-2.2.52/libacl/acl_get_fd.c
+@@ -23,7 +23,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <stdio.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <acl/libacl.h>
+ #include "libacl.h"
+ #include "__acl_from_xattr.h"
+@@ -31,7 +31,6 @@
+ #include "byteorder.h"
+ #include "acl_ea.h"
+
+-
+ /* 23.4.15 */
+ acl_t
+ acl_get_fd(int fd)
+--- acl-2.2.52/libacl/acl_get_file.c
++++ acl-2.2.52/libacl/acl_get_file.c
+@@ -23,7 +23,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <stdio.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <acl/libacl.h>
+ #include "libacl.h"
+ #include "__acl_from_xattr.h"
+@@ -31,7 +31,6 @@
+ #include "byteorder.h"
+ #include "acl_ea.h"
+
+-
+ /* 23.4.16 */
+ acl_t
+ acl_get_file(const char *path_p, acl_type_t type)
+--- acl-2.2.52/libacl/acl_set_fd.c
++++ acl-2.2.52/libacl/acl_set_fd.c
+@@ -20,7 +20,7 @@
+ */
+
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+ #include "__acl_to_xattr.h"
+
+--- acl-2.2.52/libacl/acl_set_file.c
++++ acl-2.2.52/libacl/acl_set_file.c
+@@ -22,7 +22,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "libacl.h"
+ #include "__acl_to_xattr.h"
+
+--- acl-2.2.52/libacl/libacl.h
++++ acl-2.2.52/libacl/libacl.h
+@@ -17,8 +17,13 @@
+
+ #include <errno.h>
+ #include <sys/acl.h>
++#include <errno.h>
+ #include "libobj.h"
+
++#ifndef ENOATTR
++# define ENOATTR ENODATA
++#endif
++
+ typedef unsigned int permset_t;
+
+ #define ACL_PERM_NONE (0x0000)
+--- acl-2.2.52/m4/package_attrdev.m4
++++ acl-2.2.52/m4/package_attrdev.m4
+@@ -12,17 +12,6 @@
+ dnl
+ dnl You should have received a copy of the GNU General Public License
+ dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
+-AC_DEFUN([AC_PACKAGE_NEED_ATTR_XATTR_H],
+- [ AC_CHECK_HEADERS([attr/xattr.h])
+- if test "$ac_cv_header_attr_xattr_h" != "yes"; then
+- echo
+- echo 'FATAL ERROR: attr/xattr.h does not exist.'
+- echo 'Install the extended attributes (attr) development package.'
+- echo 'Alternatively, run "make install-dev" from the attr source.'
+- exit 1
+- fi
+- ])
+-
+ AC_DEFUN([AC_PACKAGE_NEED_ATTR_ERROR_H],
+ [ AC_CHECK_HEADERS([attr/error_context.h])
+ if test "$ac_cv_header_attr_error_context_h" != "yes"; then
+--- acl-2.2.52/configure
++++ acl-2.2.52/configure
+@@ -12416,26 +12416,6 @@
+ fi
+
+
+- for ac_header in attr/xattr.h
+-do :
+- ac_fn_c_check_header_mongrel "$LINENO" "attr/xattr.h" "ac_cv_header_attr_xattr_h" "$ac_includes_default"
+-if test "x$ac_cv_header_attr_xattr_h" = xyes; then :
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_ATTR_XATTR_H 1
+-_ACEOF
+-
+-fi
+-
+-done
+-
+- if test "$ac_cv_header_attr_xattr_h" != "yes"; then
+- echo
+- echo 'FATAL ERROR: attr/xattr.h does not exist.'
+- echo 'Install the extended attributes (attr) development package.'
+- echo 'Alternatively, run "make install-dev" from the attr source.'
+- exit 1
+- fi
+-
+ for ac_header in attr/error_context.h
+ do :
+ ac_fn_c_check_header_mongrel "$LINENO" "attr/error_context.h" "ac_cv_header_attr_error_context_h" "$ac_includes_default"