summaryrefslogtreecommitdiff
path: root/sys-apps/acl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/acl
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/Manifest1
-rw-r--r--sys-apps/acl/acl-2.3.1-r1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index 1c59e0873323..2edc0b6e5d4a 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -1,3 +1,4 @@
DIST acl-2.3.1.tar.xz 355676 BLAKE2B 15e81e8159ddb21ef0c262bef3101c0b6fa546738a2ab74c01ccc21fd1c3dc8ab6aaf84a06dee6da22291f3ca4feeffa60c7d11bfac1ab770a6ec28e1f1655e0 SHA512 7d02f05d17305f8587ab485395b00c7fdb8e44c1906d0d04b70a43a3020803e8b2b8c707abb6147f794867dfa87bd51769c2d3e11a3db55ecbd2006a6e6231dc
+EBUILD acl-2.3.1-r1.ebuild 1988 BLAKE2B 54179711692fb5dde1125308338cc597143742eed53de52e818444b2bd34de8351cc65faec46bbd78778303019a1a16229c9a7573e7741b6fae33ace7cf7e1f2 SHA512 332c5221f81b6cadad66dbacf2320df2e8b61e4d354e94c332f5f615373743ac01a381837eaf5297b936d8932e823ce8d9ab9bafc9a1a24b4f1ff1a0d8bab9dd
EBUILD acl-2.3.1.ebuild 1353 BLAKE2B afbfd054f1c164665618ee2e1a7373c5158751262b3a7614799b9aaa866d9e214e8fe187f661f98d3699f670664beed2887e9689d7a4f060ddbeaa4a70ce2a74 SHA512 18575c9bcf34335fd3441d4ad9f58cfd4423d625206a40e337cadf9baf4322e953703e9fce3fc30d614f72c7d4a27072267e8af113d43caec789bb49cf4a0a2d
MISC metadata.xml 294 BLAKE2B f6827801a85f1509d29af1d248c5fa42bed4b445e4af08506afc8851a9777645ced2d5e6960257a421d793dc2c0e92b0cf485c2a855b83789c57e3b5eff0ee1b SHA512 b5a85ca1e4d407937d73ccbe5415e7ae9828ad67ce33455b1ad71e76aabaf9f51807967709c4f4b3b5b51c05181568bc26f9c00f34afa22d749a327f63077a56
diff --git a/sys-apps/acl/acl-2.3.1-r1.ebuild b/sys-apps/acl/acl-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..acc9d09b23fd
--- /dev/null
+++ b/sys-apps/acl/acl-2.3.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic libtool multilib-minimal usr-ldscript
+
+DESCRIPTION="Access control list utilities, libraries, and headers"
+HOMEPAGE="https://savannah.nongnu.org/projects/acl"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="
+ >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ # bug #580792
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Filter out -flto flags as they break getfacl/setfacl binaries
+ # bug #667372
+ filter-flags -flto*
+
+ # Broken with FORTIFY_SOURCE=3
+ # Our toolchain sets F_S=2 by default w/ >= -O2, so we need
+ # to unset F_S first, then explicitly set 2, to negate any default
+ # and anything set by the user if they're choosing 3 (or if they've
+ # modified GCC to set 3).
+ #
+ # Refs:
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104964
+ # https://savannah.nongnu.org/bugs/index.php?62519
+ # bug #847280
+ if is-flagq '-O[23]' || is-flagq '-Ofast' ; then
+ # We can't unconditionally do this b/c we fortify needs
+ # some level of optimisation.
+ filter-flags -D_FORTIFY_SOURCE=3
+ append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ fi
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ $(use_enable static-libs static)
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable nls)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ # Tests call native binaries with an LD_PRELOAD wrapper
+ # bug #772356
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ default
+
+ # Move shared libs to /
+ gen_usr_ldscript -a acl
+}
+
+multilib_src_install_all() {
+ if ! use static-libs ; then
+ find "${ED}" -type f -name "*.la" -delete || die
+ fi
+}