summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild')
-rw-r--r--sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild b/sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild
new file mode 100644
index 000000000000..910a29d35e23
--- /dev/null
+++ b/sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210107.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used to sign Openwall software releases"
+HOMEPAGE="https://www.openwall.com/signatures/"
+SRC_URI="
+ https://www.openwall.com/signatures/openwall-offline-signatures.asc ->
+ 297AD21CF86C948081520C1805C027FD4BDC136E.asc"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - openwall.asc < <(cat "${files[@]/#/${DISTDIR}/}")
+}