summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
commitcf5d856691cbc347f5816a181e5bf767792afa55 (patch)
tree239945541c80dfa78133d5e9ab5c52c25a222b09 /sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild
parentbb007f0b04c719fd2b846d177c3c4739fdb7c318 (diff)
gentoo auto-resync : 15:03:2023 - 12:21:13
Diffstat (limited to 'sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild')
-rw-r--r--sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild b/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild
new file mode 100644
index 000000000000..2beadb837215
--- /dev/null
+++ b/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20230315.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by Brian C. Lane"
+HOMEPAGE="https://www.brianlane.com/about-brian-c-lane/"
+SRC_URI="
+ https://keys.openpgp.org/vks/v1/by-fingerprint/B4C6B451E4FA8B4232CA191E117E8C168EFE3A7F
+ -> B4C6B451E4FA8B4232CA191E117E8C168EFE3A7F.asc
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+S=${WORKDIR}
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - bcl.asc < <(cat "${files[@]/#/${DISTDIR}/}")
+}