summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sci-visualization
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin5028 -> 5031 bytes
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.2.1-r1.ebuild63
3 files changed, 64 insertions, 0 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 63a2dd0b7dc5..152dbbdc3107 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 63683db134a3..11abb17c0262 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,5 +1,6 @@
DIST tensorboard-2.1.0.zip 3835182 BLAKE2B c2c7dbc1ba4b85c52df6e693e1bd425bd76fe6db7ca25582b57d9c65c68b191dcdba2623ab0560139f1cac1bdf5c7a47261daaaf51fca46f2c5bf441f832a6fd SHA512 7463ace0863b90312a62a7fa96f4eca0147e85cf46ff21729f8996a794d54e14d876d3abe083d6aa4efd8e4e1582f7d5029de367f199981a34d4057b558bc51c
DIST tensorboard-2.2.1.zip 2950617 BLAKE2B 487ad01981f994b23cb5fca8b60d9ed5f13ba13735d2613d1f3154eec9791b4b3068fb9fd50e75e16682e09ceb8a9ed8533ca2c43b6dea73db3adaeef15a889b SHA512 e96f8853d282dc19911cf2210ece0a4d7239f37dcba82e91697c80881fbcc21f12e4ba3e7d2eea7a84c9bb5b6521bf488d93d2312e55af9ec2d2c20f135d94fa
EBUILD tensorboard-2.1.0-r1.ebuild 1838 BLAKE2B 777ceecaa2c901ee2c834b34b774d0c193b733e9ec3becfa6c07ee8b96bfe8a93abd5c1826a5ed38179a8bfcbfca2054a863e5f10d31822c0d7056669a5c4faa SHA512 1fcba112f887cfcb50adb7c396533da455f47413f037563ea6692227bcfc70767900219856a6574cec8e9c1efe6b04d84aef0aeee8c77113ee7424303ada7e0d
+EBUILD tensorboard-2.2.1-r1.ebuild 1946 BLAKE2B e67025a996ecbe523410775da621b4f741fc5b514474cd24dfea0ab7428411550f56c39b42c7f5b2e25adc466008bd664ed84519e1ea069dbcd4f2731e90f3ac SHA512 6a9c8f80e9a34adcc5ccbbb4535c9855e2818cc1fc46a04d6f801ef99241d856d81f77bf4c83c0e807653854ba218d33df7d67718d8c3e25f0b9d569856ed78b
EBUILD tensorboard-2.2.1.ebuild 1944 BLAKE2B e0503f8c67624893eb16d97cfd36f0734f1db44526391cba62b7a664f1d4e4189519547904f706d8d03024ed47c45d5d0183b82f56df589cb43347c335f03db9 SHA512 29cd974fe3c4d0fe767838b60e198ef5cb553d3596f6f02afcea4eb56ee4a6a37d91e6f3f73cf77b1a4059037ec709cbf9917b0202794dd8dc7b200f9c61fe56
MISC metadata.xml 494 BLAKE2B 367959e934fdf8e447da9632a05ea0ada6116a7c39cf42096a3b24f0dcf0c0bfbd3263e6f3913611c27e76f629b77d1e5022fa124d7e79f03a224bd3627bb538 SHA512 b59bedcac4e07ddbb62e90df57670116ba51c3d8c6294679ba5d8f17d7adbf3644f3d203c1d1ef4fa06d7e50640148ee259a081afb807477784350b98c52da11
diff --git a/sci-visualization/tensorboard/tensorboard-2.2.1-r1.ebuild b/sci-visualization/tensorboard/tensorboard-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..9d1a93563347
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.2.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}