summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 07:01:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 07:01:35 +0000
commite5558bb40ba46b03d0c8e82ae60dce9a32933989 (patch)
tree85455876dea191e90114ff262f0d971533de9cd0 /sci-visualization
parent0b8b325c6d134a9f66de2ba751280e6480e609af (diff)
gentoo auto-resync : 27:03:2024 - 07:01:35
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin4691 -> 4695 bytes
-rw-r--r--sci-visualization/kst/Manifest2
-rw-r--r--sci-visualization/kst/kst-2.0.8-r2.ebuild9
3 files changed, 8 insertions, 3 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 56cf91827ebc..b3c12d5a9f19 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/kst/Manifest b/sci-visualization/kst/Manifest
index 1741acddc6d9..0535adec520a 100644
--- a/sci-visualization/kst/Manifest
+++ b/sci-visualization/kst/Manifest
@@ -5,5 +5,5 @@ AUX kst-2.0.8-includes.patch 581 BLAKE2B f0c631be82fbad4a816938311accdfe8474e0b8
AUX kst-2.0.8-qt-5.11.patch 1389 BLAKE2B 99a879ddecec135d1f1bf6da52a8410127e9a6f590f5fb6aac135258c58f3091618b928de0773fd5899d833a8d9d11ee971a3b3b1b5d85c204234fb61b31e6de SHA512 b5a38b941d40df6c5327125883a1cad27e545cf9df375d09fe4ad542e5dd104fb42859f479485df1b1bff2b6dcd6765699bd7c665d475769aea39e9e85aa1040
AUX kst-2.0.8-qt-5.15.patch 280 BLAKE2B 433312008cab3ce87f10ae9625431d4834532b4ef930ea5724b5cae9356f41a285bef339baf349bf37c94258029ac0de31a5d1a31bea4594c938ffaaeb8d7131 SHA512 570713f6b25343e2a06176a78e3677c3a21aaf357f4262a1c47469fa973265e1f159b4ac1ae6cbe6fbe1f23624a4f8eaaa694fa451fd778f84bbef6291f5be26
DIST Kst-2.0.8.tar.gz 14527129 BLAKE2B 5330dc97bc56bf8c6120a461e078ed1bdf87c4ec41b6f6ddc13d7500fde0d1b973b42da8f38c738d133559696d89ad579c288206c7ba07bbfd22dbc2bf6f2064 SHA512 81be1e9ef189dbf087c5626b984297d4c8f84f22fce50c4933ea467a65f8595c0254af78d55f2b2e324934346f0758b7a0cf48d06d1108026b60b7ffba1221fb
-EBUILD kst-2.0.8-r2.ebuild 1478 BLAKE2B ec03788f7076b48ae73547a3836b022ff646ceed00532ab3b55d685f1eabe33a28b4fd0f0a3614b414c4f3fa150f9dd5f0bcced073feae9b56fac9fca9cdf817 SHA512 1b274ec4eff240102ec174d52f62970087ba3391277a7ddc2b9c9a63e3a8994c26950be592468e9fbf529d5a5ead5ae352b4fac41c6a3a05aeb7efdf59a8e1dd
+EBUILD kst-2.0.8-r2.ebuild 1628 BLAKE2B 6866ef50069f23d48a052af374ae8f4d51a8650691be9f0c5867611c4392000e797e469c1406d1b7fa2e79fe47d9729279653688671a4492a352c5f0443c964a SHA512 a573db873602854786e23f4186e1d8e802e8f49a061fdd59ad23303a92ede42da5a3610644a0e0b195fb8df6b5eb5e94189768d7ae6e14e79d044015110a4b7a
MISC metadata.xml 364 BLAKE2B fa4d766938ee4b7777440729fca12052fad0c802cdfb4839b1ab7bcc82306cdb556d91b53df644d1267bb47ea16365b89dcd5e1f5ac44f883630793f0ccf297b SHA512 b7178ea1d76bf5398aa3ce33e3290401ec1328a5bde9d71a3238af04babc0a5da2c23d197aefb51a3addcc23b6787247e4a4a126ae97cf04efd3a334ffc179b3
diff --git a/sci-visualization/kst/kst-2.0.8-r2.ebuild b/sci-visualization/kst/kst-2.0.8-r2.ebuild
index d98d0d65c25d..6eea2097dbb3 100644
--- a/sci-visualization/kst/kst-2.0.8-r2.ebuild
+++ b/sci-visualization/kst/kst-2.0.8-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_P=Kst-${PV}
-inherit cmake xdg-utils
+inherit cmake flag-o-matic xdg-utils
DESCRIPTION="Fast real-time large-dataset viewing and plotting tool"
HOMEPAGE="https://kst-plot.kde.org/ https://invent.kde.org/graphics/kst-plot"
@@ -50,6 +50,11 @@ PATCHES=(
)
src_configure() {
+ # -Werror=odr, -Werror=lto-type=-mismatch
+ # https://bugs.gentoo.org/863296
+ # https://bugs.kde.org/show_bug.cgi?id=484572
+ filter-lto
+
local mycmakeargs=(
-Dkst_install_libdir="$(get_libdir)"
-Dkst_pch=OFF