summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /sci-visualization
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin5869 -> 5860 bytes
-rw-r--r--sci-visualization/dash-core-components/Manifest2
-rw-r--r--sci-visualization/dash-core-components/dash-core-components-1.17.1.ebuild23
-rw-r--r--sci-visualization/dash-html-components/Manifest2
-rw-r--r--sci-visualization/dash-html-components/dash-html-components-1.1.4.ebuild23
-rw-r--r--sci-visualization/dash-table/Manifest2
-rw-r--r--sci-visualization/dash-table/dash-table-4.12.1.ebuild32
-rw-r--r--sci-visualization/dash/Manifest2
-rw-r--r--sci-visualization/dash/dash-1.21.0.ebuild34
-rw-r--r--sci-visualization/paraview/Manifest7
-rw-r--r--sci-visualization/paraview/files/paraview-5.3.0-fix_buildsystem.patch24
-rw-r--r--sci-visualization/paraview/files/paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch37
-rw-r--r--sci-visualization/paraview/files/paraview-5.8.1-find-xmlpatterns.patch38
-rw-r--r--sci-visualization/paraview/metadata.xml2
-rw-r--r--sci-visualization/paraview/paraview-5.8.1.ebuild250
15 files changed, 121 insertions, 357 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 38f8d73705e7..cff720240adc 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/dash-core-components/Manifest b/sci-visualization/dash-core-components/Manifest
index 6f336471b146..efafa480fd20 100644
--- a/sci-visualization/dash-core-components/Manifest
+++ b/sci-visualization/dash-core-components/Manifest
@@ -1,3 +1,5 @@
DIST dash-core-components-1.16.0.tar.gz 13922229 BLAKE2B 7ca8dd411e3a8714902266b11a9f39420c7455601cdcbde81ad86690846bbf574fd0c65019f69fcb0ea86f511802eee080d1e4fca1cd88b82c9898aeb5055ceb SHA512 f2648fa8331296db812e897e2976aab1ca357f81b547dda57710773b4e0ef98019f928d5a0a6add426693550fb483c04ec7e0311318cab113f10fc5dca19e197
+DIST dash-core-components-1.17.1.tar.gz 14597459 BLAKE2B ed2931e34c5c92f4cbef72df929162496e35080e4460fb470532c2f1d54fb0c1ed71ef1173f48b88eb6aca0d8d81e4b15bf2bd62ed876c9597464aab0513f768 SHA512 d3b76c9deb7ec7cd09e70b5cd7e89b02b800667cf2807f9f119f5d45fd162e256389fd66b3e55e220302b6913d8bcffe845a4c25c62f46ee76c4b34de231f746
EBUILD dash-core-components-1.16.0.ebuild 546 BLAKE2B 6490f5c01911c2a1646a3243af55b8d43b95c62b3e83a7843c9b9c7a358c03fc591ce4bdb2273e445283a83de5b92abe7c350a667f0ed8282c34e2dd9a503091 SHA512 87c44346e605114643d9373b008a004c6859f3bd93caf3bc222b2a66509d2e0dda3e535e134105f3cd20ca6fa0f4de64b794ed232ab9913af90d306435e76888
+EBUILD dash-core-components-1.17.1.ebuild 546 BLAKE2B 6490f5c01911c2a1646a3243af55b8d43b95c62b3e83a7843c9b9c7a358c03fc591ce4bdb2273e445283a83de5b92abe7c350a667f0ed8282c34e2dd9a503091 SHA512 87c44346e605114643d9373b008a004c6859f3bd93caf3bc222b2a66509d2e0dda3e535e134105f3cd20ca6fa0f4de64b794ed232ab9913af90d306435e76888
MISC metadata.xml 585 BLAKE2B 3feb2e1cd13bdf259177f52e2b99ef0aacda8cbe1de791d94434450b4ee723b2cfee9ffb10b7a28ca3b1e6026e847aae3ea258cf57ea3bdcb91ccca48b8c3563 SHA512 75c3252131b7c6403ed2eda58019e239563f773519d7e46eaf7bc5eea4f0a0a308ea951d15badce5a22ab77e17f0d5ce2a87ef7449af337466742fc7917acbf4
diff --git a/sci-visualization/dash-core-components/dash-core-components-1.17.1.ebuild b/sci-visualization/dash-core-components/dash-core-components-1.17.1.ebuild
new file mode 100644
index 000000000000..8c8eac37c2de
--- /dev/null
+++ b/sci-visualization/dash-core-components/dash-core-components-1.17.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Core components suite for Dash"
+HOMEPAGE="https://plot.ly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Test execution depends on sci-visualization/dash being installed
+# but sci-visualization/dash depends on this
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
diff --git a/sci-visualization/dash-html-components/Manifest b/sci-visualization/dash-html-components/Manifest
index d80b725e5a34..d47ecca99ba4 100644
--- a/sci-visualization/dash-html-components/Manifest
+++ b/sci-visualization/dash-html-components/Manifest
@@ -1,3 +1,5 @@
DIST dash-html-components-1.1.3.tar.gz 375680 BLAKE2B e489d8d5fe3c832ae8be82ea1eac83b8a8c8df8b6ac9ce1d122178f63c4ce355c39195bd828e503c51605ed5e774eaff38cf16da9a1c486fd0eff404cd85694f SHA512 dfcc41ef7a52f0d5cc97db9e94b00eb7707cea7c5f95e89832d1b74a1554d9d9f9c3b5df57509fe959b06c53f2a281b7070adde45d3c19003c13983a10ca2509
+DIST dash-html-components-1.1.4.tar.gz 621324 BLAKE2B 030ef398241562b222389a44a53eaa86b07d400d680884daa8c42a7dabf7f6c25f168d84aca454116da91f1a86bd4d08a92fff464bde9c70be3cd91c2fc0f3e5 SHA512 bffe3f0be65914c5627f3a22fb61a07579f3bf37908ff541e6bcc80477b08249ff7fb8c9cbfdeec3453f2c6682ecadea00dc12950ad51067f11073040b61ffc8
EBUILD dash-html-components-1.1.3.ebuild 548 BLAKE2B f778dde94a78e122ae7f116604e280a63288d779d2848eb1469a419c58fa5aa2df22e07532e5d0eb172a2ef497cde7dfd92ad41c49f341ee29408d56921411b9 SHA512 2e159c0c46a2b741f6501be522ca5c08463bcd63064cccce8c534adec6716e3ff310d4d4aa407e8d603251aafe9ca42d6fef4c92d63469ebd34696e65b336eb1
+EBUILD dash-html-components-1.1.4.ebuild 548 BLAKE2B f778dde94a78e122ae7f116604e280a63288d779d2848eb1469a419c58fa5aa2df22e07532e5d0eb172a2ef497cde7dfd92ad41c49f341ee29408d56921411b9 SHA512 2e159c0c46a2b741f6501be522ca5c08463bcd63064cccce8c534adec6716e3ff310d4d4aa407e8d603251aafe9ca42d6fef4c92d63469ebd34696e65b336eb1
MISC metadata.xml 542 BLAKE2B e34bc321729ff15a65a4fa9d13d4cf2fd158fdd273be266e9addf1675fec22f649e47e5fda37975ec76453d527b8cc2a086ce08643f2de7193fdcd8c9f66ebe8 SHA512 11e452214a91a8590e2d5d0e61a56e91f9d1a3ed8aa713dd4aba5d981b726f4d338ae64cae44e3e6847dc73123788c31bd185589b1b93c828fb00c70cfb4603e
diff --git a/sci-visualization/dash-html-components/dash-html-components-1.1.4.ebuild b/sci-visualization/dash-html-components/dash-html-components-1.1.4.ebuild
new file mode 100644
index 000000000000..68536c49b1a1
--- /dev/null
+++ b/sci-visualization/dash-html-components/dash-html-components-1.1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Vanilla HTML components for Dash"
+HOMEPAGE="https://plot.ly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Test execution depends on sci-visualization/dash being installed
+# but sci-visualization/dash depends on this
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
diff --git a/sci-visualization/dash-table/Manifest b/sci-visualization/dash-table/Manifest
index 7f37adea34c3..906c222a1d6e 100644
--- a/sci-visualization/dash-table/Manifest
+++ b/sci-visualization/dash-table/Manifest
@@ -1,3 +1,5 @@
DIST dash-table-4.11.3.tar.gz 9504642 BLAKE2B d48e1448caf19f555d8e8436de295d6999dc4caabd4e80d188ec9921278dc4e48b6631dbf4a572cd190210bb83f0a73986c0c93c269b931aeff1fd52e152e248 SHA512 580de0b92ae114cd65e5a2a85aa96a78cbf3364173135ddb29ac3d2edd3ad2aa7b526d447481f78379da2c2420ed9cc8d6a83836565ccac31249ecc4a94a3db5
+DIST dash-table-4.12.1.tar.gz 9773683 BLAKE2B 97f00d2d6e9619bdd794f2e478dd4ab2eeaa521b170cef3a546a86e53632099e917e38f99d7ddc91cc4eebcf6199c301128916e29a7afecb2138da667bf38d32 SHA512 f521204b571fb20951202713721fd9fdd790d72a8a2f8461f77244bf8dcd2fb88b88626b590a63f1d28938b30ec4610112c9d2d1b5089d59cdc5219c3e16b5aa
EBUILD dash-table-4.11.3.ebuild 709 BLAKE2B 317c7048333d77cec721470512bc241d543b58215d417d011b29c348ecdb14f8da8fedfca98acf53e8f98c76f5d8895808d19b7efa3aebdf73b88d3d6cfa23a6 SHA512 5503a2cb7f2d6a423dd3e38e208073046b4bd3c87140f2d4e16fc7d4963a04f5ea53796836803200c3c4e6e06a470481c23ed893bfec7e8b0db2af5c2e7a0686
+EBUILD dash-table-4.12.1.ebuild 709 BLAKE2B 317c7048333d77cec721470512bc241d543b58215d417d011b29c348ecdb14f8da8fedfca98acf53e8f98c76f5d8895808d19b7efa3aebdf73b88d3d6cfa23a6 SHA512 5503a2cb7f2d6a423dd3e38e208073046b4bd3c87140f2d4e16fc7d4963a04f5ea53796836803200c3c4e6e06a470481c23ed893bfec7e8b0db2af5c2e7a0686
MISC metadata.xml 541 BLAKE2B dade9511f3675f376f669a0b60a90cc7e608a1cd3c30f308f3c50653a7fdaec01f425a6eb3ea58b26a03dc3b370cca43507dade19c0ee4630d674aeeba1e4469 SHA512 f3b66f31573fbd08801ddd69691a42452c0ce59a444141dccee28f7064cfdf397512e37c442684becc11aee4cca771f53d65ab912b38190df1502a1dd77d2abd
diff --git a/sci-visualization/dash-table/dash-table-4.12.1.ebuild b/sci-visualization/dash-table/dash-table-4.12.1.ebuild
new file mode 100644
index 000000000000..273b870d6b77
--- /dev/null
+++ b/sci-visualization/dash-table/dash-table-4.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="First-Class interactive DataTable for Dash"
+HOMEPAGE="https://plot.ly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Test execution depends on sci-visualization/dash being installed
+# but sci-visualization/dash depends on this
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needs percy - not available
+ rm -r tests/selenium || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/sci-visualization/dash/Manifest b/sci-visualization/dash/Manifest
index 75bdb38c5963..17128b28c142 100644
--- a/sci-visualization/dash/Manifest
+++ b/sci-visualization/dash/Manifest
@@ -1,3 +1,5 @@
DIST dash-1.20.0.tar.gz 1786368 BLAKE2B 2826336f72b9bea80be6ef77df49109b7b68ed93678b606c998a1906907551551a3228e1140d20c6e1b5bf5e53fb9cebd0c0a4d7ab5cc1a590e47ef351558a40 SHA512 670cf593068370c70f1db25c70c7a76ce98c696efbff1146cc90f90a99b8b48bf80cf47688504d173ef253ccb9f1170c2067b3af9414eacb226f7ef25149ffff
+DIST dash-1.21.0.tar.gz 1753608 BLAKE2B 07530da9e39065e80f653f97eda5ae8840a05cbc90969640910e1788daea8c5227841fd7de74b90bbb763e3c4b027442eb9e35f52d8ea57a0e8bae4dcab87ce0 SHA512 8254a918f60de9dc329af53f8ff15841be39b130c56c6c6037a2fe4d699fa71f565d7cb0a14d1405f0a1d32cfe886e1531558158596ea1a2b69fd7c62af5a8ce
EBUILD dash-1.20.0-r1.ebuild 1099 BLAKE2B 588a7aff16b79f8d0bfc2160e225606f829e3dc103821f70dfb159295b08bbe7b7204e14ff6d36b0647123e1503c8a158ac31dad024879bd5c44e01a1df8ac6a SHA512 1113de0c0e9ff38ae870dea8bb59be3c84b19aa4e99773ae07dc6fb9450e341f9378ecf797338ba6a4aed6dbda8f2703a55e28f4daf2c27c7e7abff2f1b31c27
+EBUILD dash-1.21.0.ebuild 899 BLAKE2B b65150bea8386dfc7311b3d3e42652e8b6c3e883680310c7fb8be5409073c05cddd31ab55844ac3e8a89f84a7932325a7470ea40df48c293e8e04c29be6234f8 SHA512 5530f5be27a85ba9ca91031eba1d62457697e9479a71c4a7516338f25782a82807ab0e1e0e0046e881cf36871696c0473ba18013f32f8e7206157bed8e5fa2c8
MISC metadata.xml 1362 BLAKE2B 476d401a89b61e6f3351eb372460651ca969ec7ce0e93610f446f502a37ff29b40cd16108f0b38a9d2639e76b8845d0da6eb313367c8b1d248b6d41c266f57e8 SHA512 beb967cce5f39ae8af1aa1e123ee901cc2a3683a820d61e9daf21ce8363e35236d97b1896229cecc7a605092a9ba189d848af0d0b31c515b1c02e2f1094b2eb5
diff --git a/sci-visualization/dash/dash-1.21.0.ebuild b/sci-visualization/dash/dash-1.21.0.ebuild
new file mode 100644
index 000000000000..b41f8e0c29a3
--- /dev/null
+++ b/sci-visualization/dash/dash-1.21.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ sci-visualization/dash-table[${PYTHON_USEDEP}]
+ sci-visualization/dash-html-components[${PYTHON_USEDEP}]
+ sci-visualization/dash-core-components[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/sci-visualization/paraview/Manifest b/sci-visualization/paraview/Manifest
index 0d3c247b8837..3dfb8a72eb46 100644
--- a/sci-visualization/paraview/Manifest
+++ b/sci-visualization/paraview/Manifest
@@ -1,13 +1,8 @@
AUX paraview-4.0.1-xdmf-cstring.patch 360 BLAKE2B 919de8333b22125dd1122987f780ad65594982f4fd403c45a80ae1294d1acb11cda61adc8c62f97243651679b044130e94850ecd9e06f26da1c538268fd02ba8 SHA512 5577b7bae26959546795721d712c4e4f6a5403b35c0871040f6c74c07cd3aecd5b03e9f7a07ef49714b8adb4c7cc880385215b8742895006d2ad3dfeccc50472
-AUX paraview-5.3.0-fix_buildsystem.patch 797 BLAKE2B f77c72f34c13eae42a4da281f954808f7db47c7765b9084a99d2e0ea6297d30092d1b3dae7ab26df7ac1e4de6559805748c0994853e2ad34c0f8f639ce732b12 SHA512 18526dc29219fd8dbc3679920ce271977cfb153a51cf217d49ba544510da23ee02f57b3ee9450ad9ee421d272a18fecdf3bd5043225cc16d04a2b115f62ce1f0
AUX paraview-5.5.0-allow_custom_build_type.patch 1036 BLAKE2B ff00093034196935e9075c5751f8a64027da009679de5c3f5b941681e65df9b91b0a05a3f0201a873313d859f029596739b1c5d705a1c35ae3cc83251312774e SHA512 0c79315d28b98d4cf45bfd48198dbb3315ebf6ffbd05e9720b35e7bdea05bd98c086dbb02cd7ac6d9580f504c7d29f498244d2b30d9e2932e881261a78b020c7
-AUX paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch 1185 BLAKE2B 9573a94af926615a3e6e8e043ea5bbbbf7a7946e33bce30c9fe6475de074142043463c345cf6caed09a60a63c241cac19ca2a54383b41752441b72e0bf5d9f17 SHA512 3552ae966be577840187590c651abc98e41047cbac6b679a17779b83b37c8d1ddd1a36a6ddd6dffb01b66138d2fc8a1bd335afb3ee488d2faa60c7ec1e4323e0
-AUX paraview-5.8.1-find-xmlpatterns.patch 1343 BLAKE2B 6786f27d4a3d5539f0265d1b3426b16063e795fca57d51ac3d232e5258d4d3db1b765379607ba143a422fe8f49b12354edc51fd4f4700a709e2e4aa362e75b8c SHA512 08aa76bdb1251638d52a2871116f507cc492cf03895a1950e05a56048571edb932efebe0f7704d56cd61afadee8f1f9e7003bc02825df83550944f84265b1658
AUX paraview-5.9.0-gcc11-include.patch 1045 BLAKE2B 2b6b709cf081391f6b3c9c214ce7da33a8c83f187b00e803a9df651cbf6aac8a7dc7ba080f073fcbfba5266369d2f556cc4b21fe6d3ad830bd24fb3a0908aad0 SHA512 f3af80d8c59edb1625207b447e1c6975c67e8d988e9af3592597e5a2b4c39d4e6f0c6786abc0e31a6b30fa77124e9368802d5b9e4bab5453c5ed82c5b9391dbb
-DIST ParaView-v5.8.1.tar.xz 49822084 BLAKE2B 1b99392a85c19fdc02f8f9f0f055fb7efd8a0b17eedfd84005d1af9b170c34ec4eedb25700f91c3a2241ee80e271fe1e744e3a729b7726deb8f9c7a9fd2e4191 SHA512 94861c01da2f98c47e7453d072a4de34a7f52f5df280a8745b44d58d8d6a1dba42a15d0bac31895bbe25f23d993d4d356e5af1f8415137e289afd60570070248
DIST ParaView-v5.9.0.tar.xz 62784788 BLAKE2B f07bfce50304b2bfba0de4ba3127d686cf4c32633f8c707fbb2d93c19685f7e8a119ba211e27c29b986ca5b22afab4f57c273077a1c0a7ab0abefa55c8874e28 SHA512 44d93b49449262aa3f068aa990419415c3197916a002555d914efc407ed7ccd57b15b829f0fe711afee780e5e63fb1bd072175fc382f3afd36daecc541c382d5
DIST ParaView-v5.9.1.tar.xz 62835572 BLAKE2B ba15771de9d972de533627ce3e2c74fd5f25df08884680ea6f1ceea0adb513c024f58e4436691bf17b11728f8e1c09f6ce1d55d9875729169dbc5f4b38c05de8 SHA512 d424e22d962f21c32971ca0001c10c266a1768713a3d0ae9d4c73dc83260c4661326cfbed7773845cf31dedc0474096ed9d6eb8a42ab7677cdde95f9f6abd2f2
-EBUILD paraview-5.8.1.ebuild 6297 BLAKE2B 482f81ceec21718b73710e462e33c6108c66d823ecd087fbab98fd79c7a19a8ba8786ae677c373f909b3269bfd82beb7eb91bf847db74d18270556e4baf390fd SHA512 cfc17bb2510ea09e286ae4a2c4c92327426569777450dc5e2b7ad4971eb66231c06e6775f524ffd1dead9e8043797759d13c11b8773364df08db242f48968d56
EBUILD paraview-5.9.0.ebuild 5787 BLAKE2B 44cbe70e16d604a7051620f596411c93414da8ba444a08c0dfbeb782f86e60c2af3dc47cb73db9e593393b1a7689ecabaa026361533c709e54244a84948169ce SHA512 b2121bd30d3b1536f45239afb11f0486a3590be7d8e1a1ab89c39d555ff82426bafe068b36b8a176c299d5848c97f842a8710bc8be96ef4cca626b82b3ea691e
EBUILD paraview-5.9.1.ebuild 5787 BLAKE2B 44cbe70e16d604a7051620f596411c93414da8ba444a08c0dfbeb782f86e60c2af3dc47cb73db9e593393b1a7689ecabaa026361533c709e54244a84948169ce SHA512 b2121bd30d3b1536f45239afb11f0486a3590be7d8e1a1ab89c39d555ff82426bafe068b36b8a176c299d5848c97f842a8710bc8be96ef4cca626b82b3ea691e
-MISC metadata.xml 874 BLAKE2B 8dd92b0b845c52c5ce399a143e66d5f70019ead1bc1d1695353ef016a20d8ae00a289c1767644f1b158de077936daa9ee59ce5eb65254ec1370d27b5b31f687f SHA512 02e377edfd10caaf9edfd4b2990f49e7c804368be4cf1cb371d0f5d979d2f2cd1660a66c15468b1a936daa0e5c02ca973591f9f3405ca8f29079d7f926ba5da8
+MISC metadata.xml 672 BLAKE2B d7b831a15dca3e43eb563b7ae157ccb0fe7e2df6aa82aa7f291473a13d75ac433e04fbf39b4a420bef5c0a9fd6e23cecc3d8d4a48768768ffdd059abc4f1106b SHA512 bcca9b9dec041dc8ea9738b6f141f4bc2d6b214e8c20f92e95ee5870293cf428e7c1e4a2b219f2a94079c2b5295e105e40ca899d30b13e344476a0ad05725e9e
diff --git a/sci-visualization/paraview/files/paraview-5.3.0-fix_buildsystem.patch b/sci-visualization/paraview/files/paraview-5.3.0-fix_buildsystem.patch
deleted file mode 100644
index 600c7d43744a..000000000000
--- a/sci-visualization/paraview/files/paraview-5.3.0-fix_buildsystem.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From dcc3d775bddc270aa1a4d06f85807979ab0c8358 Mon Sep 17 00:00:00 2001
-From: Matthias Maier <tamiko@kyomu.43-1.org>
-Date: Thu, 1 Jun 2017 02:27:16 -0500
-Subject: [PATCH] fix buildsystem
-
----
- VTK/Utilities/Doxygen/CMakeLists.txt | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/VTK/Utilities/Doxygen/CMakeLists.txt b/VTK/Utilities/Doxygen/CMakeLists.txt
-index 3f285f6..7ebf3ee 100644
---- a/VTK/Utilities/Doxygen/CMakeLists.txt
-+++ b/VTK/Utilities/Doxygen/CMakeLists.txt
-@@ -80,7 +80,4 @@ if(NOT VTK_INSTALL_NO_DOCUMENTATION)
- install(FILES doc_readme.txt
- DESTINATION ${VTK_INSTALL_DOXYGEN_DIR}
- COMPONENT Development)
-- install(DIRECTORY ${VTK_BINARY_DIR}/Utilities/Doxygen/doc/html
-- DESTINATION ${VTK_INSTALL_DOXYGEN_DIR}
-- COMPONENT Development)
- endif()
---
-2.13.0
-
diff --git a/sci-visualization/paraview/files/paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch b/sci-visualization/paraview/files/paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch
deleted file mode 100644
index 1f76b84ac2d6..000000000000
--- a/sci-visualization/paraview/files/paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 797f28697d5ba50c1fa2bc5596af626a3c277826 Mon Sep 17 00:00:00 2001
-From: "Andrew J. P. Maclean" <andrew.amaclean@gmail.com>
-Date: Wed, 27 May 2020 15:27:15 +1000
-Subject: [PATCH] Qt 5.15 needs the include file QPainterPath
-
----
- Rendering/Qt/vtkQtLabelRenderStrategy.cxx | 1 +
- Rendering/Qt/vtkQtStringToImage.cxx | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/VTK/Rendering/Qt/vtkQtLabelRenderStrategy.cxx b/VTK/Rendering/Qt/vtkQtLabelRenderStrategy.cxx
-index afda585cca..eca65c64cd 100644
---- a/VTK/Rendering/Qt/vtkQtLabelRenderStrategy.cxx
-+++ b/VTK/Rendering/Qt/vtkQtLabelRenderStrategy.cxx
-@@ -41,6 +41,7 @@
- #include <QImage>
- #include <QMap>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPair>
- #include <QPixmap>
- #include <QTextDocument>
-diff --git a/VTK/Rendering/Qt/vtkQtStringToImage.cxx b/VTK/Rendering/Qt/vtkQtStringToImage.cxx
-index 659c71570e..fbb9b78f05 100644
---- a/VTK/Rendering/Qt/vtkQtStringToImage.cxx
-+++ b/VTK/Rendering/Qt/vtkQtStringToImage.cxx
-@@ -30,6 +30,7 @@
- #include <QFontMetrics>
- #include <QImage>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QString>
- #include <QTextDocument>
---
-2.26.2
-
diff --git a/sci-visualization/paraview/files/paraview-5.8.1-find-xmlpatterns.patch b/sci-visualization/paraview/files/paraview-5.8.1-find-xmlpatterns.patch
deleted file mode 100644
index b02107bad7a7..000000000000
--- a/sci-visualization/paraview/files/paraview-5.8.1-find-xmlpatterns.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 7fe2ebc709ecb3e7f3b2aa6fc124dda0622541d4 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Wed, 25 Nov 2020 16:32:56 +0100
-Subject: [PATCH] Make qt_xmlpatterns_executable overridable
-
-So far this relies on fragile guessing of path or binary being in PATH.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMake/ParaViewClient.cmake | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/CMake/ParaViewClient.cmake b/CMake/ParaViewClient.cmake
-index b0dea2b328..13b59cd744 100644
---- a/CMake/ParaViewClient.cmake
-+++ b/CMake/ParaViewClient.cmake
-@@ -512,11 +512,13 @@ function (paraview_client_documentation)
- endif ()
-
- include("${_ParaViewClient_cmake_dir}/paraview-find-package-helpers.cmake" OPTIONAL)
-- find_program(qt_xmlpatterns_executable
-- NAMES xmlpatterns-qt5 xmlpatterns
-- HINTS "${Qt5_DIR}/../../../bin"
-- "${Qt5_DIR}/../../../libexec/qt5/bin"
-- DOC "Path to xmlpatterns")
-+ if (NOT qt_xmlpatterns_executable)
-+ find_program(qt_xmlpatterns_executable
-+ NAMES xmlpatterns-qt5 xmlpatterns
-+ HINTS "${Qt5_DIR}/../../../bin"
-+ "${Qt5_DIR}/../../../libexec/qt5/bin"
-+ DOC "Path to xmlpatterns")
-+ endif ()
- mark_as_advanced(qt_xmlpatterns_executable)
-
- if (NOT qt_xmlpatterns_executable)
---
-2.29.2
-
diff --git a/sci-visualization/paraview/metadata.xml b/sci-visualization/paraview/metadata.xml
index a6c779ecf4b5..2048ce66a32d 100644
--- a/sci-visualization/paraview/metadata.xml
+++ b/sci-visualization/paraview/metadata.xml
@@ -8,8 +8,6 @@
<use>
<flag name="boost">Enable the usage of dev-libs/boost</flag>
<flag name="cg">Add support for nvidia's cg shaders</flag>
- <flag name="coprocessing">Enable the coprocessing infrastructure which is mainly useful in the context of clusters</flag>
- <flag name="development">Install development files including headers</flag>
<flag name="nvcontrol">Add NVCONTROL support for OpenGL options</flag>
<flag name="offscreen">Offscreen rendering through OSMesa</flag>
<flag name="plugins">Build and install additional plugins</flag>
diff --git a/sci-visualization/paraview/paraview-5.8.1.ebuild b/sci-visualization/paraview/paraview-5.8.1.ebuild
deleted file mode 100644
index cea5bd462e92..000000000000
--- a/sci-visualization/paraview/paraview-5.8.1.ebuild
+++ /dev/null
@@ -1,250 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-inherit cmake desktop python-single-r1 qmake-utils toolchain-funcs xdg-utils
-
-MAIN_PV=$(ver_cut 0-1)
-MAJOR_PV=$(ver_cut 1-2)
-MY_P="ParaView-v${PV}"
-
-DESCRIPTION="Powerful scientific data visualization application"
-HOMEPAGE="https://www.paraview.org"
-SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
-
-LICENSE="paraview GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boost cg coprocessing development doc examples ffmpeg mpi mysql nvcontrol openmp offscreen plugins python +qt5 +sqlite test tk +webengine"
-
-RESTRICT="mirror test"
-
-# "vtksqlite, needed by vtkIOSQL" and "vtkIOSQL, needed by vtkIOMySQL"
-REQUIRED_USE="
- python? ( mpi ${PYTHON_REQUIRED_USE} )
- mysql? ( sqlite )
- webengine? ( qt5 )
- qt5? ( sqlite )
- ?? ( offscreen qt5 )"
-
-RDEPEND="
- app-arch/lz4
- dev-libs/expat
- dev-libs/jsoncpp:=
- dev-libs/libxml2:2
- dev-libs/protobuf:=
- dev-libs/pugixml
- media-libs/freetype
- media-libs/glew:0
- media-libs/libpng:0
- media-libs/libtheora
- media-libs/tiff:0=
- sci-libs/cgnslib
- sci-libs/hdf5:=[mpi=]
- >=sci-libs/netcdf-4.2[hdf5]
- >=sci-libs/netcdf-cxx-4.2:3
- sys-libs/zlib
- virtual/glu
- virtual/jpeg:0
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXt
- coprocessing? (
- dev-python/PyQt5
- dev-qt/qtgui:5[-gles2-only]
- )
- ffmpeg? ( media-video/ffmpeg )
- mpi? ( virtual/mpi[cxx,romio] )
- mysql? ( dev-db/mysql-connector-c )
- offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
- !offscreen? ( virtual/opengl )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/constantly[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sip[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
- qt5? ( dev-python/PyQt5[opengl,${PYTHON_USEDEP}] )
- ')
- )
- qt5? (
- dev-qt/designer:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qthelp:5
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtx11extras:5
- dev-qt/qtxmlpatterns:5
- )
- sqlite? ( dev-db/sqlite:3 )
- tk? ( dev-lang/tk:0= )
- webengine? ( dev-qt/qtwebengine:5[widgets] )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? (
- $(python_gen_cond_dep '
- dev-libs/boost[mpi?,${PYTHON_USEDEP}]
- ')
- )
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0.1-xdmf-cstring.patch
- "${FILESDIR}"/${PN}-5.3.0-fix_buildsystem.patch
- "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
- "${FILESDIR}"/${PN}-5.8.0-w-vtk-8.2.0-qt-5.15.patch # bug 729348
- "${FILESDIR}"/${P}-find-xmlpatterns.patch # bug 755977, downstream patch
-)
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != "binary" ]] && use openmp && tc-check-openmp
- use python && python-single-r1_pkg_setup
- PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
-}
-
-src_prepare() {
- # Bug #661812
- mkdir -p Plugins/StreamLinesRepresentation/doc || die
-
- cmake_src_prepare
-
- # lib64 fixes
- sed -i \
- -e "s:/lib/python:/$(get_libdir)/python:g" \
- VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
- sed -i \
- -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
- Remoting/Application/vtkInitializationHelper.cxx || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
- -UBUILD_SHARED_LIBS
- -DPARAVIEW_BUILD_SHARED_LIBS=ON
- -DCMAKE_VERBOSE_MAKEFILE=ON
-
- -DVTK_DEFAULT_RENDER_WINDOW_OFFSCREEN=TRUE
-
- -DVTK_USE_OGGTHEORA_ENCODER=TRUE
-
- -DVTK_GROUP_ENABLE_Imaging=YES
- -DVTK_GROUP_ENABLE_Rendering=YES
- -DVTK_GROUP_ENABLE_StandAlone=YES
- -DVTK_GROUP_ENABLE_Views=YES
-
- # boost
- -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
-
- # coprocessing
-# -DVTK_MODULE_ENABLE_ParaView_Catalyst="$(usex coprocessing YES NO)"
-
- # doc
- -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
-
- # examples
- -DBUILD_EXAMPLES="$(usex examples)"
-
- # ffmpeg
- -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
- -DVTK_USE_FFMPEG_ENCODER="$(usex ffmpeg)"
-
- # mpi
- -DPARAVIEW_USE_MPI="$(usex mpi)"
- -DXDMF_BUILD_MPI="$(usex mpi)"
- -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
-
- # mysql
- -DVTK_MODULE_ENABLE_VTK_IOMySQL="$(usex mysql YES NO)"
-
- # offscreen
- -DVTK_USE_X="$(usex !offscreen)"
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
-
- # plugins
- -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
-
- # python
- -DModule_pqPython="$(usex python)"
- -DPARAVIEW_USE_PYTHON="$(usex python)"
-
- # qt5
- -DPARAVIEW_INSTALL_DEVELOPMENT_FILES="$(usex development)"
- -DPARAVIEW_USE_QT="$(usex qt5)"
- -DModule_pqPython="$(usex qt5 "$(usex python)" "off")"
- -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
- -DVTK_GROUP_ENABLE_Qt="$(usex qt5 YES NO)"
-
- # sqlite
- -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
-
- # test
- -DBUILD_TESTING="$(usex test)"
-
- # tk
- -DVTK_USE_TK="$(usex tk)"
- -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
-
- # webengine
- -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
- -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
- )
-
- if use openmp; then
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
- fi
-
- if use qt5; then
- mycmakeargs+=(
- -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
- -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
- -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
- -Dqt_xmlpatterns_executable="$(qt5_get_bindir)/xmlpatterns"
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # remove wrapper binaries and put the actual executable in place
- for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
- if [ -f "${ED}"/usr/lib/"$i" ]; then
- mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
- fi
- done
-
- # set up the environment
- echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
- doenvd "${T}"/40${PN}
-
- newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
- make_desktop_entry paraview "Paraview" paraview
-
- use python && python_optimize "${D}"/usr/$(get_libdir)/${PN}-${MAJOR_PV}
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}