summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
commit7f740fcb9a0165d81bfecf7fb5da647763d76a1b (patch)
tree45dab58d8bd40ef97234398e9e1850495ea60273 /sci-visualization
parent0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (diff)
gentoo auto-resync : 23:09:2022 - 05:29:13
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin5365 -> 5369 bytes
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.10.0.ebuild66
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 4a41c669100b..a54b65fda9a6 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 3c6e5b9c05a9..019e3ad386ad 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,5 +1,7 @@
+DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
DIST tensorboard-2.8.0.zip 5776309 BLAKE2B b06c740fbe01c707e937018184e286fb7221391715c5ca6d843a89c9dd3a364b8693e748ccbde735d074b0abdbca65d4e2dd9a6e57b4ede61f78a661bd16e702 SHA512 3d937e41ac0abfe44cfab12f0b5269de45615c512499107a239bb348df7f3ccaabf283afcea2a7bac4a34d7b9318947c709a84154d0d2e61912138c31c86673f
DIST tensorboard-2.9.0.zip 5797045 BLAKE2B e91988637a0e30fcd6341f02bc5e83ba92ae1f6e65a2aa5ddb1626ec4bb95a97d1306984b899279281e5d5f5ac70be76669ddc87524910861429e02259269b79 SHA512 244e117de989a56efc4120b6374d5cc6c31bb233e234cf95df9ddf7cbd0ec494b925dae238c59f3663087136bbf789284096f20b300f0b4c56c9de7faddc520b
+EBUILD tensorboard-2.10.0.ebuild 2124 BLAKE2B 60ba28bb80ce56cf9a55c08c8d95dc11c8bcdce34d76d76966fde2b4ac68e3b3e22f3099df49de6b51ad540e94cc16068f863cbf3b3438ff93d044a163155568 SHA512 735a3730f46a649182efa0100f2dea3ead0f0a6d906fe963d49f32eeff34f26e6ce6eaea2c8f06089eb8eb5ea904bae0b6132dd384568b007999ef4256e532e3
EBUILD tensorboard-2.8.0.ebuild 1989 BLAKE2B 7be66c15f34a2c5ada826d3f52baba864ea2b2e38a6f8cb45bb73df2e73a08b56e1e3198006c28e301876d1e821fe1fbce6d270b8b6d2a999669112e42892282 SHA512 cb7dbc970814bb129d6854fde45f3ac8cfa3c2e14946d127e3f573258fa3e9367f0fce827c8a735202622f3c9f052b925d7031e17308fe30c6a570397a5572e0
EBUILD tensorboard-2.9.0.ebuild 2124 BLAKE2B 60ba28bb80ce56cf9a55c08c8d95dc11c8bcdce34d76d76966fde2b4ac68e3b3e22f3099df49de6b51ad540e94cc16068f863cbf3b3438ff93d044a163155568 SHA512 735a3730f46a649182efa0100f2dea3ead0f0a6d906fe963d49f32eeff34f26e6ce6eaea2c8f06089eb8eb5ea904bae0b6132dd384568b007999ef4256e532e3
MISC metadata.xml 495 BLAKE2B 29256478e1ec3cfd33b592d66ac413d784a581cf95d47efac7e828adc8230ec333e3ab3637cdc21e37298c0ba9f52d231b37127a7bd61149a56df8dca4fabb31 SHA512 9532577d0a0aa30608cb724983a9d070eab68b5ba6f6adea125b02cf55aad6a8dcb658b9179fd0d74d1dbbc0299f85e0e2c0b6ec084127060b2e12ab1b706948
diff --git a/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
new file mode 100644
index 000000000000..33cd44742483
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}