summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /sci-visualization
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin5869 -> 5875 bytes
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.5.0.ebuild64
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 71fd5dca986d..4de97ff0c193 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 54a201a783fd..87f966eff877 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,3 +1,5 @@
DIST tensorboard-2.4.0.zip 10631832 BLAKE2B e892c3f62855bd900320adbbea2758191296e2863e8865f4ffed3c5623fe5273a5a26554504b63db58c60d2a8c407e234d6cf3edc3868c88dfebd894def99859 SHA512 2301f526a98ac85cf5d182fff0f565c86883ec795bbaf2322696416621c8473d850a3f508079f89ca2a86a05fe020acde1282b72e2bb5ad77aab2d0e5ea2db4f
+DIST tensorboard-2.5.0.zip 6019104 BLAKE2B f07db4fec7cc39e15c4f580f479679f0db4f06e66d81768799ed3652bb9ba63c7b61bde7f12119d09474009e55c12d91ef0f2b3aeeb05682532630314cab871a SHA512 e39ca09bd00fab9b5f6f9393e48cb6be2313f86c24b2f0ffcfd08b08b9ed4e95e7e19297bb67d8b558e1913640774f9b9d512a34153251acb9f566d6485e0f78
EBUILD tensorboard-2.4.0.ebuild 1944 BLAKE2B 8de93c1331c5a18ae04c366fbc38288c28bb80c2c1dff889bbd88683ce5c451f1e9db4a9011ff7980448e778ef01475f2838442e871ea039d9a3eb4a9b3d61d8 SHA512 da210f7574f030b59f2944f6fcbdbf45d6395dad603e69e24344d21942c2aa0a2eb9b5a3eca883ab9d83337f2648b47f162bcee4044de5f61148fcdb1f3ebeb1
+EBUILD tensorboard-2.5.0.ebuild 2058 BLAKE2B 06a05e5f60caeb5bfb4c308b2ec77e640265472f8a282ab6bb113c3cb4eee4f039b2ae22b87a099479b8d46b6b5d900be22a1001b20de96119adf5813b743473 SHA512 c3777889abaae86b754787a95a58291a5d2e7952165a21638ec8429cf0dc0eb5aa83f6262bd87b5fa1778d142e78e4c6a00a1203717377401190591cbbf778e3
MISC metadata.xml 494 BLAKE2B 367959e934fdf8e447da9632a05ea0ada6116a7c39cf42096a3b24f0dcf0c0bfbd3263e6f3913611c27e76f629b77d1e5022fa124d7e79f03a224bd3627bb538 SHA512 b59bedcac4e07ddbb62e90df57670116ba51c3d8c6294679ba5d8f17d7adbf3644f3d203c1d1ef4fa06d7e50640148ee259a081afb807477784350b98c52da11
diff --git a/sci-visualization/tensorboard/tensorboard-2.5.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.5.0.ebuild
new file mode 100644
index 000000000000..345a4c811517
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}