summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
commit50c291a3ace58006f8fa9cf44a36f6e42bff2b54 (patch)
tree6d245677a5bb2d38b74c141346e35465540e9b7f /sci-visualization
parent53623081143d09702d8f3d7224e9da8c5f681c3b (diff)
gentoo auto-resync : 05:06:2023 - 21:37:49
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin4860 -> 4862 bytes
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.12.0.ebuild72
3 files changed, 74 insertions, 0 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index e0f58e65b8ce..675adbed9145 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 60d472600420..3ca7c3839e04 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,5 +1,7 @@
DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
DIST tensorboard-2.11.0-py3-none-any.whl.zip 5990351 BLAKE2B d6796fceb047abc69c84c8f30ce6b5e0739a376e110fb7e2bb78ee5b6c7dd8d1344546950d46dbdc3a47780f4ad685be186087286225dbeb9ebce558f0837d8c SHA512 f1b908e13a56a86f6618ae8bf596339243642d0f00793d326ac884fd8e736bb316331728b474022936570fb6202b323d8ba2bf4908619aa1f79411b904edf209
+DIST tensorboard-2.12.0-py3-none-any.whl.zip 5638388 BLAKE2B 617c76fa49b2aa647d7f099d8dbc7d53449e3024981f2f5858c1eff44b6a3c9369169579436562373fd2f44222e506b54d10083292352b70c400f16dcfaf1dec SHA512 d7eaeeb68adf1ad121bffd15f5147564af78ee74b7f2f251f6111bc94973b4ee7c952de51eab4608126a230b4709af5c67944608f4c5c73918af82945abc63e3
EBUILD tensorboard-2.10.0.ebuild 2118 BLAKE2B 4f6149423fa394f9b4b6654db4f44ec40acb6dc007b041276096df46b21d046b692becfb5a9ecd21c37b5817a4a87530bbe87cc41fd17acc7a75e1bad2ca54a3 SHA512 7056883d8a3a59a4a341e4cd1b69b3029f9cf48ce5710e6a08d82fccc432796af68cb326dfb051635ae4ff625cc8824373bc10dc69cbc62cafb109cc125c02bf
EBUILD tensorboard-2.11.0.ebuild 2172 BLAKE2B 898adf6f89f32b9ec5785a9778a1a1af4beb8ec4ca2844f319cf162c8f266d8d8fcf2827dc374c95ada1cd4fc90856c14c413ff94495931298494fc2473e5333 SHA512 dbdc5b031a7a147ade28a57d9f91115181b1ff1fa0569a8303c9fcbe56b01d53fb7457fe85bb9c78748209fde5144d23036fcb5787d94c760580d1b96b14f3a2
+EBUILD tensorboard-2.12.0.ebuild 2183 BLAKE2B 625d235cee533159c2076e89e38574035cd0ecda68461958acb5ca7b153f970ad56aa5aede0a7d21b9f0721acd67fc514382af8946c832b946dddc51425210dc SHA512 0331431047ab28fd2fda360a9be72a236d938886e6e3752046790b39061fc747349f480aee3f90a676126a71a5334686a8d0f230f1f3ef23d210a3d1af268f73
MISC metadata.xml 495 BLAKE2B 29256478e1ec3cfd33b592d66ac413d784a581cf95d47efac7e828adc8230ec333e3ab3637cdc21e37298c0ba9f52d231b37127a7bd61149a56df8dca4fabb31 SHA512 9532577d0a0aa30608cb724983a9d070eab68b5ba6f6adea125b02cf55aad6a8dcb658b9179fd0d74d1dbbc0299f85e0e2c0b6ec084127060b2e12ab1b706948
diff --git a/sci-visualization/tensorboard/tensorboard-2.12.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.12.0.ebuild
new file mode 100644
index 000000000000..c85363899451
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.12.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 python3_11 )
+inherit python-r1 pypi
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="$(pypi_wheel_url --unpack)"
+S=${WORKDIR}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+ ${PYTHON_DEPS}
+"
+PDEPEND="
+ sci-libs/tensorflow[python,${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+ sed -i -e 's/protobuf.*$/protobuf/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax protobuf deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}