summaryrefslogtreecommitdiff
path: root/sci-visualization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-26 02:00:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-26 02:00:48 +0000
commit403335d7014372971e9e9267493a808d08bab48e (patch)
treeffd28ddc69e6fe6543b018a00c9fad058bdda027 /sci-visualization
parent7f0b7329b3aa78ea82792fdf68ab48415fe4cc35 (diff)
gentoo auto-resync : 26:11:2024 - 02:00:48
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/Manifest.gzbin4351 -> 4351 bytes
-rw-r--r--sci-visualization/gcalc/Manifest2
-rw-r--r--sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild (renamed from sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild)31
-rw-r--r--sci-visualization/paraview/Manifest7
-rw-r--r--sci-visualization/paraview/files/paraview-5.11.1-missing-include.patch11
-rw-r--r--sci-visualization/paraview/paraview-5.11.1-r1.ebuild244
-rw-r--r--sci-visualization/paraview/paraview-5.12.0.ebuild245
-rw-r--r--sci-visualization/paraview/paraview-5.12.0_rc1-r1.ebuild245
8 files changed, 16 insertions, 769 deletions
diff --git a/sci-visualization/Manifest.gz b/sci-visualization/Manifest.gz
index 5f2337fd237e..a459423e7bd1 100644
--- a/sci-visualization/Manifest.gz
+++ b/sci-visualization/Manifest.gz
Binary files differ
diff --git a/sci-visualization/gcalc/Manifest b/sci-visualization/gcalc/Manifest
index 45aeb3342a55..2029c378b4d9 100644
--- a/sci-visualization/gcalc/Manifest
+++ b/sci-visualization/gcalc/Manifest
@@ -1,3 +1,3 @@
DIST GCalc-3.1-rc1.tar.gz 543699 BLAKE2B d9d9c05ef8d0eca0f5c67ab250ca6df66e5061e458c6adaf53a612ead63e904a4d3c3d8dc381288eb06b626ae2eefff0a69b83583e77b38590a95093d5db4b39 SHA512 6cf66bb1a3867370c027c1c5b82f30b22d146483a8be4a997a6f917142bc83d732cc064eb3f2ff28ea4fcb1583695097d218c7fa092e78d8fb9ba2511261cbda
-EBUILD gcalc-3.1_rc1-r2.ebuild 788 BLAKE2B 5a6726e898b50134461c3fd4ef3a7d146493c03970be0c21dc7938ddb059c9d97bfc4ac8269c7b6487126aadb22710eeb7a351c8e4e71546a67fa9e583727c08 SHA512 c11ed2ad0ab37c27b909619ca23a8e6b48283af8929711ffcbf34ff78022c4143d6cde7ab9094c655370208e49133ad56360a8166f072508069f74ba257c4e87
+EBUILD gcalc-3.1_rc1-r3.ebuild 821 BLAKE2B 6412a5b3ae9bb36144eeb06080c96c743c2179672ca574c613a1cfe45fcc00d75aabb0923d4e5867edeb625494bc3b3ecdf1c084611c4f855473c61aae73ca7b SHA512 655bc4bfc06a1fd1b2786baf175d29ec313912f0b098b1114a1f353129f84033eca757f547be6caf1431194800b34b1bec7e9133d9a6ebb26298ded1676056f4
MISC metadata.xml 343 BLAKE2B b7ed32ab44656a5b3a62221431ac1fc56e5b14bb87ee6940467bdf77b25b1f1a2eaf4bf2fd4273d826df3c46aee8e6a2672d23a642ba5ee3036a03f2997b192e SHA512 09d2eae942294d202cc820d65fb616daf2b46de42dc78857a69aae66497e2043a5b08c1b0dc5530adb69b3013ccf7d2407c196fd9bac46de012e2999ea5d3fa9
diff --git a/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild b/sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild
index f5a27970376f..825f3b99f106 100644
--- a/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild
+++ b/sci-visualization/gcalc/gcalc-3.1_rc1-r3.ebuild
@@ -1,38 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop java-pkg-2 java-pkg-simple
MY_P="GCalc-${PV/_/-}"
DESCRIPTION="Java Mathematical Graphing System"
-HOMEPAGE="http://gcalc.net/"
-SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"
+HOMEPAGE="https://gcalc.net/"
+SRC_URI="https://gcalc.net/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
-KEYWORDS="~amd64"
SLOT="0"
+KEYWORDS="~amd64"
-RDEPEND=">=virtual/jre-1.8:*"
DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
-S="${WORKDIR}/${MY_P}"
+JAVA_MAIN_CLASS="net.gcalc.calc.GCalc"
+JAVA_RESOURCE_DIRS="res"
+JAVA_SRC_DIR="src"
src_prepare() {
+ java-pkg-2_src_prepare
java-pkg_clean
- default
-}
-
-src_compile() {
- java-pkg-simple_src_compile
- java-pkg_addres ${PN}.jar src ! -name "*.html"
+ mkdir res || die
+ mv {src,res}/resources || die
+ cp {src,res}/pluginlist.xml || die
}
src_install() {
java-pkg-simple_src_install
- java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc
-
- newicon src/resources/gicon.png ${PN}.png
+ newicon res/resources/gicon.png ${PN}.png
make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
}
diff --git a/sci-visualization/paraview/Manifest b/sci-visualization/paraview/Manifest
index aa070e33a345..cd5659a0d8ea 100644
--- a/sci-visualization/paraview/Manifest
+++ b/sci-visualization/paraview/Manifest
@@ -1,11 +1,4 @@
-AUX paraview-5.11.1-missing-include.patch 554 BLAKE2B 12950a55fa80cd729cee64a85a9f88f2bfd886e1bf8fb05fa35b3f838181a80e015892042d876d306bfd24f880d02a64bfe6bedd9a6237743e6f4db874769d24 SHA512 82d2176018eef081a89982ee0529e2dd622c3331b79376a85e6306be3cefdc3087bfca0634e6502445242fd5e50f7d086f706e565c9f922224621aa48f1f0115
AUX paraview-5.5.0-allow_custom_build_type.patch 1036 BLAKE2B ff00093034196935e9075c5751f8a64027da009679de5c3f5b941681e65df9b91b0a05a3f0201a873313d859f029596739b1c5d705a1c35ae3cc83251312774e SHA512 0c79315d28b98d4cf45bfd48198dbb3315ebf6ffbd05e9720b35e7bdea05bd98c086dbb02cd7ac6d9580f504c7d29f498244d2b30d9e2932e881261a78b020c7
-DIST ParaView-v5.11.1.tar.xz 79847556 BLAKE2B efef5e519a82ef1c0a7d532578778f6a95f07ebd72ebefd0cbdcff0bfc3af1773601cd102ff81f45f302fcaa4bb6ec7ee68f7dec77f5d4e137c2842fbbb54e11 SHA512 d0e666b49f49e41dba23e23d454a9462f018bd6d832628b0029e8d54760f0439ca97841a26da3126c5144780fc01dc25234a6624fb35346a98d35cbe0e0c98ca
-DIST ParaView-v5.12.0-RC1.tar.xz 128908020 BLAKE2B 3222ac21f733559b9f5c7e8c1009a19c0e462e2622805db7d61b683f25d70fc40cf096d699afde6dab9e23c102e3df9251a718d3ecbaac7a56db01c898270cd9 SHA512 1c6a052081e274a120563c5ffc73dadf4e02be237cc0c213a22d0b93a9865713c83992a3fc0cc1c52742b0753546b5b983a3f650989e8a472ac2f7e90383de92
-DIST ParaView-v5.12.0.tar.xz 129439820 BLAKE2B b9a59c22d15ee1582704c7e6c70a259d8b8df5d0f59fb87902ade07bce3ef7b52b055d75bb0876b7a0a9b493a7ef8df377f0ac281c370c72d9b89418efec9657 SHA512 d7ad95105f43672c5f0001f673977b7742cca113b78b0d953f4c55f60a6cf72b8a216515136251f63b8294becb0ea717b5118bf48b78ca8db85949a1b59892c1
DIST ParaView-v5.13.0.tar.xz 133195632 BLAKE2B f4e639d01667dfb7ad02fa51133b1e2d29429aefa89e7f77772d0080aa537d910f9b6f7868e4a31d52b392762c38d94ec228b2a754936409077eb2f8ffcf7f1c SHA512 ba0051902efb2a9c599e500f85f9b20bc46eead1e1f68daa0fea0295ee606844fb72fb8eee04f67f7cced3a35be2b2b442c6f1160fc4f2c2eedfbe9c440b5b1f
-EBUILD paraview-5.11.1-r1.ebuild 6252 BLAKE2B 35512f8f1167933619408841b6d8d5d20f7a901009cdd8d99d2803023b58865cdc6de841c58a12c84f8b08c2da19e8b7b73a4f0423fb10d7dadd3e16be5be4b2 SHA512 89c609902d1e47ffc40c8f4ed521e00fbe2975cf594ac3ce991fe7f74d4d5a7e3b05cb6013416225e84511ff0e2b5c45e3bb23755901d8594f60edeb99bae225
-EBUILD paraview-5.12.0.ebuild 6261 BLAKE2B 73a68b1ff77b1c66c455ae8c36b92020cb2300bfad9282e8cc33c2e6021c093fe01ae03c957e7f5e951b4f583c7dd5afc3b3a31cedcf482c19eb92677f0d89f8 SHA512 3139940ca868cb2ba8872cbf7ad8a3446eef5682430332da3e61810e52eaf546035d98ed679fe8dd3625bececd56f3af2b0e231a43b35396b18f856b5ccec324
-EBUILD paraview-5.12.0_rc1-r1.ebuild 6261 BLAKE2B d44b9340a49f34ddcc9fe5c8bc1c4a1bc91c23771956fb81aff1803bfaf8398c5640d65584685fabd57219a8fca4c65ffcc86c775c21cd4b7be052739853dd44 SHA512 bd7c45bbbba57e6d3bc7e355b4ee0a074b93e960a703cc20cfe26a96bf9ca2fab12dc54b6872742ed95bb6ed61866b8fd951e4f293cb97b2c0764a83f0db93da
EBUILD paraview-5.13.0.ebuild 6069 BLAKE2B dfe7c6c9922c03a4dba2cb5be21283a37ae1c2278a11a09904f0753a2db8463e9d10a4dea4467a4cfb97e205a9090c775c47797b39de949a1805c34c0f448bd0 SHA512 33a3dea1d9a3a77fa6e3edccb7ac5c702276886b6d6dc7f5d63ae2ae48ca3d3416fc31d50046d799ca0a643a18f4045063aa55d2222e5271f63f93f7f5a17c53
MISC metadata.xml 683 BLAKE2B 28b4017609ac733ac1c1ff4cb4ac3b5341f72180f487542b9db3b8bee59357ac9fed25bc0287a2f8c93f7429d098d1b26c74741b86b943564a4caafd7ee8450e SHA512 0bd4a1c8331532529d405f36c4556f57caecc299ceddd4ca8ff23138d96bd450c1d4fade7f02edddd8f9b3062d6b31bcb9a7696b2b628494c1d1b60d0312bc91
diff --git a/sci-visualization/paraview/files/paraview-5.11.1-missing-include.patch b/sci-visualization/paraview/files/paraview-5.11.1-missing-include.patch
deleted file mode 100644
index d59d78412750..000000000000
--- a/sci-visualization/paraview/files/paraview-5.11.1-missing-include.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urNp ParaView-v5.11.1-orig/VTK/ThirdParty/libproj/vtklibproj/src/proj_json_streaming_writer.hpp ParaView-v5.11.1-dwok/VTK/ThirdParty/libproj/vtklibproj/src/proj_json_streaming_writer.hpp
---- ParaView-v5.11.1-orig/VTK/ThirdParty/libproj/vtklibproj/src/proj_json_streaming_writer.hpp 2023-03-30 16:08:08.000000000 +0200
-+++ ParaView-v5.11.1-dwok/VTK/ThirdParty/libproj/vtklibproj/src/proj_json_streaming_writer.hpp 2023-08-26 14:53:20.211944383 +0200
-@@ -33,6 +33,7 @@
-
- #include <vector>
- #include <string>
-+#include <cstdint>
-
- #define CPL_DLL
-
diff --git a/sci-visualization/paraview/paraview-5.11.1-r1.ebuild b/sci-visualization/paraview/paraview-5.11.1-r1.ebuild
deleted file mode 100644
index 111639407469..000000000000
--- a/sci-visualization/paraview/paraview-5.11.1-r1.ebuild
+++ /dev/null
@@ -1,244 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DOCS_BUILDER="doxygen"
-inherit cmake flag-o-matic desktop docs python-single-r1 qmake-utils toolchain-funcs xdg
-
-MAJOR_PV="$(ver_cut 1-2)"
-MINOR_PV="$(ver_cut 3)"
-RC_PV="$(ver_cut 4-5)"
-RC_PV="${RC_PV:+-${RC_PV^^}}"
-MY_P="ParaView-v${MAJOR_PV}.${MINOR_PV}${RC_PV}"
-
-DESCRIPTION="Powerful scientific data visualization application"
-HOMEPAGE="https://www.paraview.org"
-SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}"
-
-# TODO: check licenses of plugins (USE=plugins)
-LICENSE="BSD MIT PSF-2 VTK"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boost cg examples ffmpeg mpi nvcontrol openmp offscreen plugins python +qt5 +sqlite test tk +webengine"
-
-RESTRICT="mirror test"
-
-REQUIRED_USE="
- python? ( mpi ${PYTHON_REQUIRED_USE} )
- webengine? ( qt5 )
- qt5? ( sqlite )
- ?? ( offscreen qt5 )"
-
-RDEPEND="
- app-arch/lz4
- dev-libs/expat
- dev-libs/jsoncpp:=
- dev-libs/libxml2:2
- dev-libs/protobuf:=
- dev-libs/pugixml
- media-libs/freetype
- media-libs/glew:0
- media-libs/libpng:0
- media-libs/libtheora
- media-libs/tiff:=
- sci-libs/cgnslib
- sci-libs/hdf5:=[mpi=]
- >=sci-libs/netcdf-4.2[hdf5]
- >=sci-libs/netcdf-cxx-4.2:3
- sys-libs/zlib
- virtual/glu
- media-libs/libjpeg-turbo:=
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXt
- ffmpeg? ( media-video/ffmpeg )
- mpi? ( virtual/mpi[cxx,romio] )
- offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
- !offscreen? ( virtual/opengl )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/constantly[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sip:5[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
- qt5? ( dev-python/pyqt5[opengl,${PYTHON_USEDEP}] )
- ')
- )
- qt5? (
- dev-qt/designer:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qthelp:5
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtx11extras:5
- dev-qt/qtxmlpatterns:5
- )
- sqlite? ( dev-db/sqlite:3 )
- tk? ( dev-lang/tk:0= )
- webengine? ( dev-qt/qtwebengine:5[widgets] )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? (
- $(python_gen_cond_dep '
- dev-libs/boost[mpi?,python,${PYTHON_USEDEP}]
- ')
- )
-"
-
-BDEPEND="
- openmp? ( virtual/fortran )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
- "${FILESDIR}"/${P}-missing-include.patch
-)
-
-# false positive when checking for available HDF5 interface, bug #904731
-QA_CONFIG_IMPL_DECL_SKIP=(
- H5Pset_coll_metadata_write
- H5Pset_all_coll_metadata_ops
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- use python && python-single-r1_pkg_setup
- PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
-}
-
-src_prepare() {
- # Bug #661812
- mkdir -p Plugins/StreamLinesRepresentation/doc || die
-
- cmake_src_prepare
-
- # lib64 fixes
- sed -i \
- -e "s:/lib/python:/$(get_libdir)/python:g" \
- VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
- sed -i \
- -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
- Remoting/Application/vtkInitializationHelper.cxx || die
-}
-
-src_configure() {
- # Needed to compile bundled VTK in ParaView 5.11.1 with gcc 12
- # see also, bug #863299
- filter-lto
- append-cflags $(test-flags-CC -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
- append-cxxflags $(test-flags-CXX -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
-
- # Make sure qmlplugindump is in path:
- export PATH="$(qt5_get_bindir):${PATH}"
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
- -UBUILD_SHARED_LIBS
- -DPARAVIEW_BUILD_SHARED_LIBS=ON
- -DCMAKE_VERBOSE_MAKEFILE=ON
-
- # boost
- -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
-
- # doc
- -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
-
- # examples
- -DBUILD_EXAMPLES="$(usex examples)"
-
- # ffmpeg
- -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
-
- # mpi
- -DPARAVIEW_USE_MPI="$(usex mpi)"
- -DXDMF_BUILD_MPI="$(usex mpi)"
- -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
-
- # offscreen
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
-
- # plugins
- -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
-
- # python
- -DModule_pqPython="$(usex python)"
- -DPARAVIEW_USE_PYTHON="$(usex python)"
-
- # qt5
- -DPARAVIEW_USE_QT="$(usex qt5)"
- -DModule_pqPython="$(usex qt5 "$(usex python)" "off")"
- -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
- -DVTK_GROUP_ENABLE_Qt="$(usex qt5 YES NO)"
- -DCMAKE_INSTALL_QMLDIR="${EPREFIX}/usr/$(get_libdir)/qt5/qml"
-
- # sqlite
- -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
-
- # test
- -DBUILD_TESTING="$(usex test)"
-
- # tk
- -DVTK_USE_TK="$(usex tk)"
- -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
-
- # webengine
- -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
- -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
- )
-
- if use openmp; then
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
- fi
-
- if use qt5; then
- mycmakeargs+=(
- -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
- -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
- -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
- -Dqt_xmlpatterns_executable="$(qt5_get_bindir)/xmlpatterns"
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # remove wrapper binaries and put the actual executable in place
- for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
- if [ -f "${ED}"/usr/lib/"$i" ]; then
- mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
- fi
- done
-
- # set up the environment
- echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
- doenvd "${T}"/40${PN}
-
- newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
- make_desktop_entry paraview "Paraview" paraview
-
- use python && python_optimize "${ED}/usr/$(get_libdir)/${PN}-${MAJOR_PV}"
-}
diff --git a/sci-visualization/paraview/paraview-5.12.0.ebuild b/sci-visualization/paraview/paraview-5.12.0.ebuild
deleted file mode 100644
index 08dae57f667a..000000000000
--- a/sci-visualization/paraview/paraview-5.12.0.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DOCS_BUILDER="doxygen"
-inherit cmake flag-o-matic desktop docs python-single-r1 qmake-utils toolchain-funcs xdg
-
-MAJOR_PV="$(ver_cut 1-2)"
-MINOR_PV="$(ver_cut 3)"
-RC_PV="$(ver_cut 4-5)"
-RC_PV="${RC_PV:+-${RC_PV^^}}"
-MY_P="ParaView-v${MAJOR_PV}.${MINOR_PV}${RC_PV}"
-
-DESCRIPTION="Powerful scientific data visualization application"
-HOMEPAGE="https://www.paraview.org"
-SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}"
-
-# TODO: check licenses of plugins (USE=plugins)
-LICENSE="BSD MIT PSF-2 VTK"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boost cg examples ffmpeg mpi nvcontrol openmp offscreen plugins python +qt5 +sqlite test tk +webengine"
-
-RESTRICT="mirror test"
-
-REQUIRED_USE="
- python? ( mpi ${PYTHON_REQUIRED_USE} )
- webengine? ( qt5 )
- qt5? ( sqlite )
- ?? ( offscreen qt5 )"
-
-RDEPEND="
- app-arch/lz4
- dev-libs/expat
- dev-libs/jsoncpp:=
- dev-libs/libxml2:2
- dev-libs/protobuf:=
- dev-libs/pugixml
- media-libs/freetype
- media-libs/glew:0
- media-libs/libpng:0
- media-libs/libtheora
- media-libs/tiff:=
- sci-libs/cgnslib
- sci-libs/hdf5:=[mpi=]
- >=sci-libs/netcdf-4.2[hdf5]
- >=sci-libs/netcdf-cxx-4.2:3
- sys-libs/zlib
- virtual/glu
- media-libs/libjpeg-turbo:=
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXt
- ffmpeg? ( media-video/ffmpeg )
- mpi? ( virtual/mpi[cxx,romio] )
- offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
- !offscreen? ( virtual/opengl )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/constantly[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sip:5[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
- qt5? ( dev-python/pyqt5[opengl,${PYTHON_USEDEP}] )
- ')
- )
- qt5? (
- dev-qt/designer:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qthelp:5
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtx11extras:5
- dev-qt/qtxmlpatterns:5
- )
- sqlite? ( dev-db/sqlite:3 )
- tk? ( dev-lang/tk:0= )
- webengine? ( dev-qt/qtwebengine:5[widgets] )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? (
- $(python_gen_cond_dep '
- dev-libs/boost[mpi?,python,${PYTHON_USEDEP}]
- ')
- )
-"
-
-BDEPEND="
- openmp? ( virtual/fortran )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
-)
-
-# false positive when checking for available HDF5 interface, bug #904731
-QA_CONFIG_IMPL_DECL_SKIP=(
- H5Pset_coll_metadata_write
- H5Pset_all_coll_metadata_ops
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- use python && python-single-r1_pkg_setup
- PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
-}
-
-src_prepare() {
- # Bug #661812
- mkdir -p Plugins/StreamLinesRepresentation/doc || die
-
- cmake_src_prepare
-
- # lib64 fixes
- sed -i \
- -e "s:/lib/python:/$(get_libdir)/python:g" \
- VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
- sed -i \
- -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
- Remoting/Application/vtkInitializationHelper.cxx || die
-}
-
-src_configure() {
- # Needed to compile bundled VTK in ParaView 5.11.1 with gcc 12
- # see also, bug #863299
- filter-lto
- append-cflags $(test-flags-CC -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
- append-cxxflags $(test-flags-CXX -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
-
- # Make sure qmlplugindump is in path:
- export PATH="$(qt5_get_bindir):${PATH}"
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
- -UBUILD_SHARED_LIBS
- -DPARAVIEW_BUILD_SHARED_LIBS=ON
- -DCMAKE_VERBOSE_MAKEFILE=ON
-
- # boost
- -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
-
- # doc
- -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
-
- # examples
- -DBUILD_EXAMPLES="$(usex examples)"
-
- # ffmpeg
- -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
-
- # mpi
- -DPARAVIEW_USE_MPI="$(usex mpi)"
- -DXDMF_BUILD_MPI="$(usex mpi)"
- -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
-
- # offscreen
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
-
- # plugins
- -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
-
- # python
- -DModule_pqPython="$(usex python)"
- -DPARAVIEW_USE_PYTHON="$(usex python)"
-
- # qt5
- -DPARAVIEW_USE_QT="$(usex qt5)"
- -DPARAVIEW_QT_VERSION="5"
- -DVTK_QT_VERSION="5"
- -DModule_pqPython="$(usex qt5 "$(usex python)" "off")"
- -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
- -DVTK_GROUP_ENABLE_Qt="$(usex qt5 YES NO)"
- -DCMAKE_INSTALL_QMLDIR="${EPREFIX}/usr/$(get_libdir)/qt5/qml"
-
- # sqlite
- -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
-
- # test
- -DBUILD_TESTING="$(usex test)"
-
- # tk
- -DVTK_USE_TK="$(usex tk)"
- -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
-
- # webengine
- -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
- -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
- )
-
- if use openmp; then
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
- fi
-
- if use qt5; then
- mycmakeargs+=(
- -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
- -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
- -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
- -Dqt_xmlpatterns_executable="$(qt5_get_bindir)/xmlpatterns"
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # remove wrapper binaries and put the actual executable in place
- for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
- if [ -f "${ED}"/usr/lib/"$i" ]; then
- mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
- fi
- done
-
- # set up the environment
- echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
- doenvd "${T}"/40${PN}
-
- newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
- make_desktop_entry paraview "Paraview" paraview
-
- use python && python_optimize "${ED}/usr/$(get_libdir)/${PN}-${MAJOR_PV}"
-}
diff --git a/sci-visualization/paraview/paraview-5.12.0_rc1-r1.ebuild b/sci-visualization/paraview/paraview-5.12.0_rc1-r1.ebuild
deleted file mode 100644
index 11313384200a..000000000000
--- a/sci-visualization/paraview/paraview-5.12.0_rc1-r1.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DOCS_BUILDER="doxygen"
-inherit cmake flag-o-matic desktop docs python-single-r1 qmake-utils toolchain-funcs xdg
-
-MAJOR_PV="$(ver_cut 1-2)"
-MINOR_PV="$(ver_cut 3)"
-RC_PV="$(ver_cut 4-5)"
-RC_PV="${RC_PV:+-${RC_PV^^}}"
-MY_P="ParaView-v${MAJOR_PV}.${MINOR_PV}${RC_PV}"
-
-DESCRIPTION="Powerful scientific data visualization application"
-HOMEPAGE="https://www.paraview.org"
-SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}"
-
-# TODO: check licenses of plugins (USE=plugins)
-LICENSE="BSD MIT PSF-2 VTK"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boost cg examples ffmpeg mpi nvcontrol openmp offscreen plugins python +qt5 +sqlite test tk +webengine"
-
-RESTRICT="mirror test"
-
-REQUIRED_USE="
- python? ( mpi ${PYTHON_REQUIRED_USE} )
- webengine? ( qt5 )
- qt5? ( sqlite )
- ?? ( offscreen qt5 )"
-
-RDEPEND="
- app-arch/lz4
- dev-libs/expat
- dev-libs/jsoncpp:=
- dev-libs/libxml2:2
- dev-libs/protobuf:=
- dev-libs/pugixml
- media-libs/freetype
- media-libs/glew:0
- media-libs/libpng:0
- media-libs/libtheora
- media-libs/tiff:=
- sci-libs/cgnslib
- sci-libs/hdf5:=[mpi=]
- >=sci-libs/netcdf-4.2[hdf5]
- >=sci-libs/netcdf-cxx-4.2:3
- sys-libs/zlib
- virtual/glu
- media-libs/libjpeg-turbo:=
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXt
- ffmpeg? ( media-video/ffmpeg )
- mpi? ( virtual/mpi[cxx,romio] )
- offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
- !offscreen? ( virtual/opengl )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/constantly[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sip:5[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
- qt5? ( dev-python/pyqt5[opengl,${PYTHON_USEDEP}] )
- ')
- )
- qt5? (
- dev-qt/designer:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qthelp:5
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtx11extras:5
- dev-qt/qtxmlpatterns:5
- )
- sqlite? ( dev-db/sqlite:3 )
- tk? ( dev-lang/tk:0= )
- webengine? ( dev-qt/qtwebengine:5[widgets] )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? (
- $(python_gen_cond_dep '
- dev-libs/boost[mpi?,python,${PYTHON_USEDEP}]
- ')
- )
-"
-
-BDEPEND="
- openmp? ( virtual/fortran )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
-)
-
-# false positive when checking for available HDF5 interface, bug #904731
-QA_CONFIG_IMPL_DECL_SKIP=(
- H5Pset_coll_metadata_write
- H5Pset_all_coll_metadata_ops
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- use python && python-single-r1_pkg_setup
- PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
-}
-
-src_prepare() {
- # Bug #661812
- mkdir -p Plugins/StreamLinesRepresentation/doc || die
-
- cmake_src_prepare
-
- # lib64 fixes
- sed -i \
- -e "s:/lib/python:/$(get_libdir)/python:g" \
- VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
- sed -i \
- -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
- Remoting/Application/vtkInitializationHelper.cxx || die
-}
-
-src_configure() {
- # Needed to compile bundled VTK in ParaView 5.11.1 with gcc 12
- # see also, bug #863299
- filter-lto
- append-cflags $(test-flags-CC -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
- append-cxxflags $(test-flags-CXX -fno-strict-aliasing \
- -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
-
- # Make sure qmlplugindump is in path:
- export PATH="$(qt5_get_bindir):${PATH}"
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
- -UBUILD_SHARED_LIBS
- -DPARAVIEW_BUILD_SHARED_LIBS=ON
- -DCMAKE_VERBOSE_MAKEFILE=ON
-
- # boost
- -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
-
- # doc
- -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
-
- # examples
- -DBUILD_EXAMPLES="$(usex examples)"
-
- # ffmpeg
- -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
-
- # mpi
- -DPARAVIEW_USE_MPI="$(usex mpi)"
- -DXDMF_BUILD_MPI="$(usex mpi)"
- -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
-
- # offscreen
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
- -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
-
- # plugins
- -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
-
- # python
- -DModule_pqPython="$(usex python)"
- -DPARAVIEW_USE_PYTHON="$(usex python)"
-
- # qt5
- -DPARAVIEW_USE_QT="$(usex qt5)"
- -DPARAVIEW_QT_VERSION="5"
- -DVTK_QT_VERSION="5"
- -DModule_pqPython="$(usex qt5 "$(usex python)" "off")"
- -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
- -DVTK_GROUP_ENABLE_Qt="$(usex qt5 YES NO)"
- -DCMAKE_INSTALL_QMLDIR="${EPREFIX}/usr/$(get_libdir)/qt5/qml"
-
- # sqlite
- -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
-
- # test
- -DBUILD_TESTING="$(usex test)"
-
- # tk
- -DVTK_USE_TK="$(usex tk)"
- -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
-
- # webengine
- -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
- -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
- )
-
- if use openmp; then
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
- fi
-
- if use qt5; then
- mycmakeargs+=(
- -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
- -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
- -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
- -Dqt_xmlpatterns_executable="$(qt5_get_bindir)/xmlpatterns"
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # remove wrapper binaries and put the actual executable in place
- for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
- if [ -f "${ED}"/usr/lib/"$i" ]; then
- mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
- fi
- done
-
- # set up the environment
- echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
- doenvd "${T}"/40${PN}
-
- newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
- make_desktop_entry paraview "Paraview" paraview
-
- use python && python_optimize "${ED}/usr/$(get_libdir)/${PN}-${MAJOR_PV}"
-}