summaryrefslogtreecommitdiff
path: root/sci-visualization/tensorboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
commit7bd77a6744e2cd6d203240181996a998985e0288 (patch)
tree75dc88e47dcab0692b84f1b2684ffa9fde351aff /sci-visualization/tensorboard
parentc33b50e5d2446c439465ff4575253db72ef2b8f6 (diff)
gentoo auto-resync : 26:11:2022 - 01:13:45
Diffstat (limited to 'sci-visualization/tensorboard')
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.11.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 939e011619f1..cae45654e320 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,3 +1,5 @@
DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
+DIST tensorboard-2.11.0.zip 5990351 BLAKE2B d6796fceb047abc69c84c8f30ce6b5e0739a376e110fb7e2bb78ee5b6c7dd8d1344546950d46dbdc3a47780f4ad685be186087286225dbeb9ebce558f0837d8c SHA512 f1b908e13a56a86f6618ae8bf596339243642d0f00793d326ac884fd8e736bb316331728b474022936570fb6202b323d8ba2bf4908619aa1f79411b904edf209
EBUILD tensorboard-2.10.0.ebuild 2124 BLAKE2B 60ba28bb80ce56cf9a55c08c8d95dc11c8bcdce34d76d76966fde2b4ac68e3b3e22f3099df49de6b51ad540e94cc16068f863cbf3b3438ff93d044a163155568 SHA512 735a3730f46a649182efa0100f2dea3ead0f0a6d906fe963d49f32eeff34f26e6ce6eaea2c8f06089eb8eb5ea904bae0b6132dd384568b007999ef4256e532e3
+EBUILD tensorboard-2.11.0.ebuild 2235 BLAKE2B affeebf6d25c97dbad5c788685a206d76869b2f0216441cd870c757b67b62835c3d6aa3aa2abd904d450e31b0c5c131cafe4615db5f4a7f460f7c2a6f62af623 SHA512 ec404f0f535cf3ccaa94c7012cd63c3d1875f98124e9b41f957d4af9938acd6fd1f89d0d67b56ac069e33f7a71995f1a7e8fdfb56a29e562e7b913bf499b87c7
MISC metadata.xml 495 BLAKE2B 29256478e1ec3cfd33b592d66ac413d784a581cf95d47efac7e828adc8230ec333e3ab3637cdc21e37298c0ba9f52d231b37127a7bd61149a56df8dca4fabb31 SHA512 9532577d0a0aa30608cb724983a9d070eab68b5ba6f6adea125b02cf55aad6a8dcb658b9179fd0d74d1dbbc0299f85e0e2c0b6ec084127060b2e12ab1b706948
diff --git a/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild
new file mode 100644
index 000000000000..f9f4786e1e1e
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+ sed -i -e 's/protobuf.*$/protobuf/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax protobuf deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}