summaryrefslogtreecommitdiff
path: root/sci-visualization/tensorboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-visualization/tensorboard
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-visualization/tensorboard')
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.8.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 68df595b9638..4bab49426034 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,5 +1,7 @@
DIST tensorboard-2.5.0.zip 6019104 BLAKE2B f07db4fec7cc39e15c4f580f479679f0db4f06e66d81768799ed3652bb9ba63c7b61bde7f12119d09474009e55c12d91ef0f2b3aeeb05682532630314cab871a SHA512 e39ca09bd00fab9b5f6f9393e48cb6be2313f86c24b2f0ffcfd08b08b9ed4e95e7e19297bb67d8b558e1913640774f9b9d512a34153251acb9f566d6485e0f78
DIST tensorboard-2.7.0.zip 5757617 BLAKE2B 98e67e322548f4b88448856da3a2457a6aae9ecb1540916d46a90401307f4919df37af8a3048bdb850ea78886d18423edc87fca51812f3b9489de62d3effa0fc SHA512 e9b046000250a78eab4e6e68e5cc05696254893cf7422b59d2e168d7322287501654370a797e90af7437e91b64a27743e348513bcb5571805b3f10bb2059636d
+DIST tensorboard-2.8.0.zip 5776309 BLAKE2B b06c740fbe01c707e937018184e286fb7221391715c5ca6d843a89c9dd3a364b8693e748ccbde735d074b0abdbca65d4e2dd9a6e57b4ede61f78a661bd16e702 SHA512 3d937e41ac0abfe44cfab12f0b5269de45615c512499107a239bb348df7f3ccaabf283afcea2a7bac4a34d7b9318947c709a84154d0d2e61912138c31c86673f
EBUILD tensorboard-2.5.0.ebuild 2060 BLAKE2B 5eec94d8cb854130b0bae18c4fc2c96497beb5ab9daf1e8086b0171fef3fa50c50483b160a83ecee605db6126ff455fa666557a1baa30d36c8314cae388aa6ed SHA512 12c1c737a9eced8fc90b9dfd570d00d6430cb30ff836a399ac1dd2cad62f2d3e1d5a2741d0a4ab7fe527df8b1e588cb0d77b3f6cc08abc85a6e5cbd1bdcd1627
EBUILD tensorboard-2.7.0.ebuild 1991 BLAKE2B 86ca8924a455bbcae095492799c3d481e220e8175b4c66d8d9e15f33cccee2d6e9f75af543a6b5b6ddc90d43469d2b388d39900d0c6b3bfd688dfe65e6e33b4b SHA512 80c9d6ea3f4bddb508daf5c1c63b7d198f8147badb7c0802a99a7997356687a0a7e8b516e1a6838dd0fa41279726be2587d226002c6e2f4d8e552fd5e8489f68
+EBUILD tensorboard-2.8.0.ebuild 1989 BLAKE2B 7be66c15f34a2c5ada826d3f52baba864ea2b2e38a6f8cb45bb73df2e73a08b56e1e3198006c28e301876d1e821fe1fbce6d270b8b6d2a999669112e42892282 SHA512 cb7dbc970814bb129d6854fde45f3ac8cfa3c2e14946d127e3f573258fa3e9367f0fce827c8a735202622f3c9f052b925d7031e17308fe30c6a570397a5572e0
MISC metadata.xml 495 BLAKE2B 29256478e1ec3cfd33b592d66ac413d784a581cf95d47efac7e828adc8230ec333e3ab3637cdc21e37298c0ba9f52d231b37127a7bd61149a56df8dca4fabb31 SHA512 9532577d0a0aa30608cb724983a9d070eab68b5ba6f6adea125b02cf55aad6a8dcb658b9179fd0d74d1dbbc0299f85e0e2c0b6ec084127060b2e12ab1b706948
diff --git a/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild
new file mode 100644
index 000000000000..8923ebaec0e7
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}