summaryrefslogtreecommitdiff
path: root/sci-visualization/grace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sci-visualization/grace/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sci-visualization/grace/files')
-rw-r--r--sci-visualization/grace/files/grace-5.1.21-netcdf.patch11
-rw-r--r--sci-visualization/grace/files/grace-5.1.22-ldflags.patch41
-rw-r--r--sci-visualization/grace/files/grace-5.1.22-mkstemp.patch55
3 files changed, 0 insertions, 107 deletions
diff --git a/sci-visualization/grace/files/grace-5.1.21-netcdf.patch b/sci-visualization/grace/files/grace-5.1.21-netcdf.patch
deleted file mode 100644
index d843cb4b284c..000000000000
--- a/sci-visualization/grace/files/grace-5.1.21-netcdf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure 2007-02-16 22:44:49.000000000 +0000
-+++ b/configure 2007-09-28 23:03:29.000000000 +0100
-@@ -15181,7 +15181,7 @@
- int main(void) {
- char *vlib;
- vlib = nc_inq_libvers();
-- if (strcmp(vlib, "3.0") < 0) {
-+ if (((vlib[0] == '"') && (strcmp(vlib, "\"3.0") < 0)) || ((vlib[0] != '"') && (strcmp(vlib, "3.0") < 0))){
- exit(1);
- }
- exit(0);
diff --git a/sci-visualization/grace/files/grace-5.1.22-ldflags.patch b/sci-visualization/grace/files/grace-5.1.22-ldflags.patch
deleted file mode 100644
index 2a65cd233361..000000000000
--- a/sci-visualization/grace/files/grace-5.1.22-ldflags.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Respect LDFLAGS
-
-http://bugs.gentoo.org/show_bug.cgi?id=336984
-
---- grace-5.1.22/src/Makefile
-+++ grace-5.1.22/src/Makefile
-@@ -37,10 +37,10 @@
- include Make.dep
-
- xmgrace$(EXE) : $(GROBJS) $(PARS_C) $(GUIOBJS) $(CEPHES_LIB)
-- $(CC) $(CFLAGS) $(GROBJS) $(GUIOBJS) -o $@ $(LDFLAGS) $(LIBS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) $(GROBJS) $(GUIOBJS) -o $@ $(LIBS)
-
- grace$(EXE) : $(GROBJS) $(PARS_C) $(CEPHES_LIB)
-- $(CC) $(CFLAGS) $(GROBJS) -o $@ $(LDFLAGS) $(LIBS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) $(GROBJS) -o $@ $(LIBS)
-
-
- buildinfo$(EXE) : buildinfo$(O)
---- grace-5.1.22/auxiliary/Makefile
-+++ grace-5.1.22/auxiliary/Makefile
-@@ -22,7 +22,7 @@
- devclean : distclean
-
- convcal$(EXE) : convcal.c
-- $(CC) $(CFLAGS0) $(CPPFLAGS) -o $@ convcal.c $(NOGUI_LIBS)
-+ $(CC) $(LDFLAGS) $(CFLAGS0) $(CPPFLAGS) -o $@ convcal.c $(NOGUI_LIBS)
-
- install : $(AUXILIARIES) $(PROGRAMS) $(SCRIPTS)
- $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
---- grace-5.1.22/grconvert/Makefile
-+++ grace-5.1.22/grconvert/Makefile
-@@ -23,7 +23,7 @@
- all : $(PROG)
-
- $(PROG) : $(OBJS)
-- $(CC) -o $@ $(OBJS) $(LDFLAGS) $(LIBS)
-+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
-
- $(OBJS) : grconvert.h
-
diff --git a/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch b/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch
deleted file mode 100644
index 402a5162c584..000000000000
--- a/sci-visualization/grace/files/grace-5.1.22-mkstemp.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -Naur grace-5.1.22/src/editpwin.c grace-5.1.22.new/src/editpwin.c
---- grace-5.1.22/src/editpwin.c 2006-06-03 17:19:52.000000000 -0400
-+++ grace-5.1.22.new/src/editpwin.c 2008-07-26 12:45:21.000000000 -0400
-@@ -776,12 +776,12 @@
- */
- void do_ext_editor(int gno, int setno)
- {
-- char *fname, ebuf[256];
-+ char fname[64], ebuf[256];
- FILE *cp;
- int save_autos;
-
-- fname = tmpnam(NULL);
-- cp = grace_openw(fname);
-+ strcpy(fname, "grace-XXXXXX");
-+ cp = fdopen(mkstemp(fname), "wb");
- if (cp == NULL) {
- return;
- }
-diff -Naur grace-5.1.22/src/plotone.c grace-5.1.22.new/src/plotone.c
---- grace-5.1.22/src/plotone.c 2005-05-19 16:30:25.000000000 -0400
-+++ grace-5.1.22.new/src/plotone.c 2008-07-26 12:45:40.000000000 -0400
-@@ -121,19 +121,27 @@
- sprintf(print_file, "%s.%s", get_docbname(), dev.fext);
- }
- strcpy(fname, print_file);
-+ prstream = grace_openw(fname);
- } else {
-+ int hdfd;
- s = get_print_cmd();
- if (s == NULL || s[0] == '\0') {
- errmsg("No print command defined, output aborted");
- return;
- }
-- tmpnam(fname);
-- /* VMS doesn't like extensionless files */
-- strcat(fname, ".prn");
-+ strcpy(fname, "grace-hardcopy-XXXXXX");
-+ hdfd=mkstemp(fname);
-+ if (hdfd == -1) {
-+ errmsg("Could not create a temporary file, output aborted.");
-+ return;
-+ }
-+ prstream = fdopen(hdfd, "wb");
-+ if (prstream == NULL) {
-+ errmsg("Could not create a temporary file, output aborted.");
-+ return;
-+ }
- }
-
-- prstream = grace_openw(fname);
--
- if (prstream == NULL) {
- return;
- }