summaryrefslogtreecommitdiff
path: root/sci-visualization/gr/gr-0.50.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sci-visualization/gr/gr-0.50.0-r1.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sci-visualization/gr/gr-0.50.0-r1.ebuild')
-rw-r--r--sci-visualization/gr/gr-0.50.0-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sci-visualization/gr/gr-0.50.0-r1.ebuild b/sci-visualization/gr/gr-0.50.0-r1.ebuild
new file mode 100644
index 000000000000..b15a75608877
--- /dev/null
+++ b/sci-visualization/gr/gr-0.50.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Universal framework for cross-platform visualization applications"
+HOMEPAGE="http://gr-framework.org/"
+SRC_URI="https://github.com/sciapp/gr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo ffmpeg postscript tiff truetype X"
+
+DEPEND="
+ dev-qt/qtgui:5
+ media-libs/fontconfig
+ media-libs/glfw
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/qhull
+ sys-libs/zlib
+ virtual/opengl
+ cairo? ( x11-libs/cairo )
+ ffmpeg? ( media-video/ffmpeg )
+ postscript? ( app-text/ghostscript-gpl )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
+
+src_configure() {
+ use cairo || mycmakeargs+=( -DCAIRO_LIBRARY= )
+ use postscript || mycmakeargs+=( -DGS_LIBRARY= )
+ use ffmpeg || mycmakeargs+=( -DFFMPEG_INCLUDE_DIR= )
+ use truetype || mycmakeargs+=( -DFREETYPE_LIBRARY= )
+ use tiff || mycmakeargs+=( -DTIFF_LIBRARY= )
+
+ # todo: X11 automagic
+
+ mycmakeargs+=( -DCMAKE_INSTALL_PREFIX=/usr/gr )
+ #
+ # I need to have a serious conversation with upstream.
+ # * The main consumer of this package is dev-lang/julia.
+ # * If I patch gr to install in standard locations, julia does
+ # not find it anymore.
+ # * I can't patch julia, since the corresponding scripts are
+ # downloaded at runtime from its package registry ...
+ #
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.a' -delete
+
+ echo "GRDIR=/usr/gr" > "${T}/99gr"
+ echo "LDPATH=/usr/gr/$(get_libdir)" >> "${T}/99gr"
+ doenvd "${T}/99gr"
+
+ dosym ../gr/bin/gksqt /usr/bin/gksqt
+}