summaryrefslogtreecommitdiff
path: root/sci-physics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-22 14:46:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-22 14:46:57 +0100
commit614dee2f9d146b148d9c54dd480e7df81ba2f3a7 (patch)
tree43d363dcd2170608ea58bd156435bf2d29daa66c /sci-physics
parent593b66fb6ac6aa53bd2016d7409fc12a22a10214 (diff)
gentoo auto-resync : 22:07:2022 - 14:46:57
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/Manifest.gzbin4021 -> 4188 bytes
-rw-r--r--sci-physics/fastjet-contrib/Manifest4
-rw-r--r--sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild39
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch11
-rw-r--r--sci-physics/fastjet-contrib/metadata.xml15
-rw-r--r--sci-physics/fastjet/Manifest6
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6-r3.ebuild4
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0.ebuild75
-rw-r--r--sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch11
-rw-r--r--sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch75
10 files changed, 237 insertions, 3 deletions
diff --git a/sci-physics/Manifest.gz b/sci-physics/Manifest.gz
index a77302089766..6f1325492a22 100644
--- a/sci-physics/Manifest.gz
+++ b/sci-physics/Manifest.gz
Binary files differ
diff --git a/sci-physics/fastjet-contrib/Manifest b/sci-physics/fastjet-contrib/Manifest
new file mode 100644
index 000000000000..11efbb258b01
--- /dev/null
+++ b/sci-physics/fastjet-contrib/Manifest
@@ -0,0 +1,4 @@
+AUX fastjet-contrib-1.049-soname.patch 772 BLAKE2B 88c50c5f425aba7d4eaf760def43baa145d15c550a3e857b70b3a98d0796e2a2f912e7ac652ae559fcf26ddb67013df392851398f92eb2b8362cbf84ebb8dae3 SHA512 715c269c80421baa682b2eda604ff60e21cf08a754ba8051dd684f9c846e444f57735f98102582ee81d975294b7f5873d265e4c8951dade91c5817f065970bef
+DIST fjcontrib-1.049.tar.gz 850931 BLAKE2B ed80c231220794cda36fb0cbbad225eb8d741f2de5558878f17d1774e16e3046d2af4b0cb895d5fc897f382c36f50def0b3ecb0fba06010347752e0a59ee402f SHA512 21dc066cc8f2667f41377924bad6c3df625fa73d16b6bc3dd49ff76e6e15abbfeac0317850699e7047a7c2445c4a94a67d0f37119922163eae8bf77a56edd9e6
+EBUILD fastjet-contrib-1.049.ebuild 1017 BLAKE2B e06a205ac569fb59a80e007cba0aa00264fa14856caa05e621de7e02cb70a6f538e9f46eaaf92d18904ab7aeb202118bff162b9f206363418a6bdce51fdcbf64 SHA512 bb413688d0f482d434726ca46f2657c1c9ff154260297223503a68888217ea839fcb599b6dedf93d64d509868a24abad661542e74214b4c715dee7b1f675c464
+MISC metadata.xml 539 BLAKE2B a45a74080df65fd40841789ca8465301103cea5c6da01882f17d3153b45ef1bba36440d776ceea6214cf1fa63195fd4c425f249ecd78782116a31c5b3288dc56 SHA512 1e76b7065a64af7bb43284d20817827227d0a70070c7684348f8a093b2330c6e407fa6c237570bb4d002088a7cbcbaa7f150f6d6cc95eab2cb3d3ead4755c5c5
diff --git a/sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild b/sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild
new file mode 100644
index 000000000000..c5de8596605c
--- /dev/null
+++ b/sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=fjcontrib
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="3rd party extensions of FastJet."
+HOMEPAGE="https://fastjet.hepforge.org/contrib/"
+SRC_URI="https://fastjet.hepforge.org/contrib/downloads/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=sci-physics/fastjet-3.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-soname.patch
+)
+
+src_configure() {
+ ./configure --prefix=/usr --fastjet-config=/usr/bin/fastjet-config CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" FFLAGS="${FFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+src_compile() {
+ emake
+ emake fragile-shared
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+ dolib.so libfastjetcontribfragile.so
+ # The name used for requesting this library varies
+ dosym libfastjetcontribfragile.so /usr/$(get_libdir)/libfastjetcontribfragile.so.0
+ dosym libfastjetcontribfragile.so /usr/$(get_libdir)/fastjetcontribfragile.so.0
+}
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
new file mode 100644
index 000000000000..5f69900cdc30
--- /dev/null
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
@@ -0,0 +1,11 @@
+--- fjcontrib-1.046.orig/Makefile.in 2022-03-10 13:44:33.963887464 +0100
++++ fjcontrib-1.046/Makefile.in 2022-03-10 13:45:02.573890763 +0100
+@@ -54,7 +54,7 @@
+
+ fragile_SHARED_SRC_LIST=@FRAGILE_SHARED_SRC_LIST@
+ libfastjetcontribfragile.@DYNLIBEXT@: $(fragile_SHARED_SRC_LIST)
+- $(CXX) @DYNLIBOPT@ -fPIC -DPIC $(CXXFLAGS) `$(FASTJETCONFIG) --cxxflags --libs` $(fragile_SHARED_SRC_LIST) -o libfastjetcontribfragile.@DYNLIBEXT@
++ $(CXX) @DYNLIBOPT@ -fPIC -DPIC -Wl,-Ol -Wl,--as-needed -Wl,-soname,fastjetcontribfragile.so.0 $(LDFLAGS) $(CXXFLAGS) `$(FASTJETCONFIG) --cxxflags --libs` $(fragile_SHARED_SRC_LIST) -o libfastjetcontribfragile.@DYNLIBEXT@
+
+ fragile-shared-install: fragile-shared
+ utils/install-sh -c -m 755 libfastjetcontribfragile.@DYNLIBEXT@ $(PREFIX)/lib
diff --git a/sci-physics/fastjet-contrib/metadata.xml b/sci-physics/fastjet-contrib/metadata.xml
new file mode 100644
index 000000000000..2ba65cdb8045
--- /dev/null
+++ b/sci-physics/fastjet-contrib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The fastjet-contrib space is intended to provide a common location for access to 3rd party extensions of FastJet.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
index a4b88bcd4d32..75a5d727c89a 100644
--- a/sci-physics/fastjet/Manifest
+++ b/sci-physics/fastjet/Manifest
@@ -1,4 +1,8 @@
AUX fastjet-3.0.6-system-siscone.patch 3726 BLAKE2B b8fcd8b93631892b68b7d4584c3e456118fd66f80e12e39be3fc82f2f6dac3c52a3d2218c7e8f342166047aee385c9f12192777454be333b2a01b307bc67cdac SHA512 7522e3fd0fe789bc5b3172c2c26566136004b828a46a81fb0ec39bb6bedbf358efc0b51acab8cb19a40dd5b4138190f87655ddd2679cc91c819f5c7c9e9f4c57
+AUX fastjet-3.4.0-gfortran.patch 460 BLAKE2B 59fc23a0326274363bdaa325b279c3b798726b1d1e68ce24d591d74ece325533d04bb430b8d3cd9afe9041bb6ea35e1013836634c334984a2b38df53691d75e6 SHA512 c687213cf01ce3d46bbe17db48581dfe7980137d568e0cfc4c1b0665b189cfb64b2feba50763ae511688f10c4eb08e0c43260f76238b5e4c9ea0f00b281e157c
+AUX fastjet-3.4.0-system-siscone.patch 3905 BLAKE2B dbd08874af57cf611b40d4a0ec8c8acff5acff5a6a0959e45b486926a3e50e5ff2c4ac9992161e11666cf09ca52a189c51cb192f907c97b2d8b60c96f5a90fed SHA512 448171e01cc608b0b8e84d1a1bb4e2a146e81fefd6b660e149d181b5c6fdd71f8317e92fe301d47e359819cb03a757034d66a2ab5be96cc2b2d7fc500de6afcc
DIST fastjet-3.0.6.tar.gz 2216501 BLAKE2B 1aacab5c91cb70d66035deddc4929d60c51444f6f23396f947d704f607d5f2267ccc5e09ec633d6e0ec1255b3a6bc7e51e4ea49c4cb06d0e3b6953b601ab76ee SHA512 1f01b7ed0e07bd94c88faa123f72c2e3bcd81ad32ab4d03dc0a18dd18635f3b18ba8d339176b0ef1d6e58cecd9f37aaea30b4ad909d2782ce5be7c11e205c3a5
-EBUILD fastjet-3.0.6-r3.ebuild 1350 BLAKE2B 72ead73cf9b69a67b527f7ceb6c4d15e6b4d8d896c4cfc5f8abd3fd946635582adf6442548b6ba72b5b0eccaecbfbdb93403d7852e393359747c672380b992f4 SHA512 02dc1208066265536cb2625a6e7bbbe8237d5a402ea0dde136c9ea005fb4c66d11164dd69ceb57c779c4fa0be29893268c5debd022eb9b936abed8559bdcfef7
+DIST fastjet-3.4.0.tar.gz 2959127 BLAKE2B c99e89ee5cea3fd4e3edebdfebb50efd3c58e7ab15215a384c44120ac930882bd2d4e446b61977fe65dcc49056b958c6510abb7c5889024ae49776b1955bd023 SHA512 af8aeb6197f6bd82ec5f127647f49cd5d455c20e614c23d928b850fc97bc12c70cf6e3b09f1bb0308c2a080fcd4fa13416eea0195695060efaa0e400a687d7b7
+EBUILD fastjet-3.0.6-r3.ebuild 1355 BLAKE2B 4c95e8fbaa04c8d213957e0d3b8059df285b4a83dea0237e51176f3d498e549f9764162406d79da42adb036cc52b11b60f287be6cef79a1a02951a114408e62f SHA512 9d2932b070827a824f590adfea08380899fc55f89bc071dccd9e642e9627e25e176d3db8b9732ba35d5ff12db7d47291a01db8865b4c2d9f3fcddd35de9ad52e
+EBUILD fastjet-3.4.0.ebuild 1521 BLAKE2B a07989493610619222d6f615136658c897a1e03637e3f31b9552e4480319f1672b00139b7f0145ee970498e654e2e828f1deee76134200886b148db524427393 SHA512 edabb05c03476796f53d63e7847720acb73d4f3612fa5ff9bc80803a5344f3cf3c52c5f18b558d49964de60abd957cede86c427d5db5282705d49985b0a57dd0
MISC metadata.xml 847 BLAKE2B e83be614f0f62c0134590b689846e3fd481d49268bc45d2cd0a8fcf4628d56551a76336843da0c596e992dd0aefa829de07cb0877d3bba8aa1123c7f9f54d062 SHA512 b9fc075c1fb0cd8da6f44ddc2ce55b4f3492bf23a6ec3a56865559afdfbd2a1d79bcd07d34974c5f44e96edca08830c057852fa85a7ab88b8b2f784c4a34519f
diff --git a/sci-physics/fastjet/fastjet-3.0.6-r3.ebuild b/sci-physics/fastjet/fastjet-3.0.6-r3.ebuild
index 083818379ede..b62fa18aba46 100644
--- a/sci-physics/fastjet/fastjet-3.0.6-r3.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.6-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cgal doc examples +plugins"
RDEPEND="
- cgal? ( sci-mathematics/cgal:=[shared(+)] )
+ cgal? ( <sci-mathematics/cgal-5.3:=[shared(+)] )
plugins? ( sci-physics/siscone:= )"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
diff --git a/sci-physics/fastjet/fastjet-3.4.0.ebuild b/sci-physics/fastjet/fastjet-3.4.0.ebuild
new file mode 100644
index 000000000000..f114cdf358f0
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ cgal? ( <sci-mathematics/cgal-5.3:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/fortran"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-siscone.patch
+ "${FILESDIR}"/${P}-gfortran.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ $(use_enable cgal) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch b/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch
new file mode 100644
index 000000000000..639cbf253589
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch
@@ -0,0 +1,11 @@
+--- a/plugins/PxCone/Makefile.am 2022-07-20 18:25:01.390035710 +0200
++++ b/plugins/PxCone/Makefile.am 2022-07-20 18:25:43.261623399 +0200
+@@ -7,7 +7,7 @@
+ endif
+ libPxConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
+ libPxConePlugin_la_SOURCES = pxcone.f PxConePlugin.cc
+-libPxConePlugin_la_LIBADD = ../../src/libfastjet.la
++libPxConePlugin_la_LIBADD = ../../src/libfastjet.la -lgfortran
+
+ EXTRA_DIST = makefile.static pxcone.h
+
diff --git a/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch b/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch
new file mode 100644
index 000000000000..0aa29d07ab38
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch
@@ -0,0 +1,75 @@
+diff -Nur fastjet-3.0.6.orig/configure.ac fastjet-3.0.6/configure.ac
+--- fastjet-3.0.6.orig/configure.ac 2014-05-06 10:29:55.240632504 -0700
++++ fastjet-3.0.6/configure.ac 2014-05-06 10:36:20.156246416 -0700
+@@ -261,6 +261,12 @@
+ fi
+
+ dnl SISCone
++AC_ARG_WITH(bundle-siscone,
++ [ --with-bundle-siscone Build the bundled SISCone library [default=no]],
++ [bundle_siscone=$withval],
++ [bundle_siscone=no])
++AM_CONDITIONAL(BUNDLE_SISCONE, test x$bundle_siscone != xno)
++
+ ACX_CHECK_PLUGIN(SISCone, siscone, SISCONE, yes,
+ [CONFIG_LIBS_PLUGINS=${CONFIG_LIBS_PLUGINS}" -lsiscone_spherical -lsiscone"
+ CONFIG_LIBS_PLUGINS_STATIC=${CONFIG_LIBS_PLUGINS_STATIC}" \${installationdir}/lib/libsiscone.a \${installationdir}/lib/libsiscone_spherical.a"])
+diff -Nur fastjet-3.0.6.orig/example/Makefile.am fastjet-3.0.6/example/Makefile.am
+--- fastjet-3.0.6.orig/example/Makefile.am 2014-05-06 10:29:55.239632499 -0700
++++ fastjet-3.0.6/example/Makefile.am 2014-05-06 10:36:20.156246416 -0700
+@@ -43,7 +43,7 @@
+ 03_plugin_CXXFLAGS = $(AM_CXXFLAGS) $(CGAL_CPPFLAGS) -I$(srcdir)/../include
+ 03_plugin_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ 03_plugin_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ else
+ EXTRA_DIST += 03-plugin.cc
+ endif
+@@ -125,7 +125,7 @@
+ fastjet_areas_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ if BUILD_PLUGIN_SISCONE
+ fastjet_areas_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+
+ fastjet_timing_plugins_SOURCES = fastjet_timing_plugins.cc CmdLine.cc
+@@ -135,7 +135,7 @@
+ fastjet_timing_plugins_LDADD += ../tools/libfastjettools.la
+ if BUILD_PLUGIN_SISCONE
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+ if BUILD_PLUGIN_CDFCONES
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/CDFCones
+diff -Nur fastjet-3.4.0/plugins/SISCone/Makefile.am.orig fastjet-3.4.0/plugins/SISCone/Makefile.am
+--- fastjet-3.4.0/plugins/SISCone/Makefile.am.orig 2022-03-10 11:21:49.888900042 +0100
++++ fastjet-3.4.0/plugins/SISCone/Makefile.am 2022-03-10 11:23:07.790909024 +0100
+@@ -1,12 +1,22 @@
+-SUBDIRS = siscone fastjet .
++SUBDIRS = fastjet .
+
+ if MONOLITHIC_PLUGINS
+ noinst_LTLIBRARIES = libSISConePlugin.la
+ else
+ lib_LTLIBRARIES = libSISConePlugin.la
+ endif
+-libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/siscone -I$(srcdir)/../../include -I./siscone
++libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
++
++if BUNDLE_SISCONE
++SUBDIRS += siscone
++libSISConePlugin_la_CXXFLAGS += -I$(srcdir)/siscone
++libSISConePlugin_la_LIBADD = \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/libsiscone.la \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++else
++libSISConePlugin_la_LIBADD = -lsiscone -lsiscone_spherical
++endif
+ libSISConePlugin_la_SOURCES = SISConeBasePlugin.cc SISConePlugin.cc SISConeSphericalPlugin.cc
+-libSISConePlugin_la_LIBADD = ../../src/libfastjet.la siscone/siscone/libsiscone.la siscone/siscone/spherical/libsiscone_spherical.la
++
+
+ EXTRA_DIST = makefile.static