summaryrefslogtreecommitdiff
path: root/sci-physics/yoda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-physics/yoda
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-physics/yoda')
-rw-r--r--sci-physics/yoda/Manifest2
-rw-r--r--sci-physics/yoda/yoda-1.9.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 336dd9fcc566..0760a9852944 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1,3 +1,5 @@
DIST YODA-1.8.5.tar.bz2 1057576 BLAKE2B 3c6abb680afcfb8250c3ae340a1b1307cb5498b726199ecf9afe593fc49c4099fd2b4ac881568c303abd10c22fcf91ffae4283021443fc6230456376617f0de1 SHA512 d1fffa55af069f894b3c88bcd105f77a3105095281febf9c06c0cea2fadea6c63d69df5bde4aa96646d2d560bd83cade6802d9ed19d5a30553cd003ace19dfc8
+DIST YODA-1.9.0.tar.bz2 1061105 BLAKE2B 70d68d31456747fcb14e27585aae245930061b5135b8a96c8ff3fe0375175d00a1c2d24a6c1ca3f18fc8464e610ef6287184f3990e12ff3fb108def600e34189 SHA512 eb82f1df832c2124dd81e07c06f165ddf13c4c4b70fcd0113f85045e22085d82751325bc57bfbd167649580980d98a15b666de56dada639160f24682b58b2f71
EBUILD yoda-1.8.5.ebuild 841 BLAKE2B 451e469bbca5da56c96177719bb2766ddae3a7302f31dd7461df5a2190736bd2953e82e0da02730dd65568abb9748d781796460f78a029bd9cdb66251d6ec6fa SHA512 e50f47d5664dd5e5888bb40fa7355081ad04cea31ebcfcb0501e445239c19cf426aa996494fd64610eaada2bcc3d683dc642d546683b65c17661985215ecd30b
+EBUILD yoda-1.9.0.ebuild 843 BLAKE2B 94946e19f1b8f36dd4151592207d99ccf0c0d4a46e29323d3cce470dcfcb2f07fe050ce712726a12394f4388de43c5af1ccab56cbf8d4d2f861725d70c8c1634 SHA512 8aa5189d75b21b1d88b56952557c1be48ffa9b81e2ba0d292a99fbbab47f792bbcb89454c055d0c0319fe31b43243a369e6b0d88fdab792e36f15d401d49a0d5
MISC metadata.xml 659 BLAKE2B 460df9dfdf485eb860ba7eb737ee9cc715e823b4961894a99e51e9bbdb98ce14a87639ddb0774aeed11d111ed21ddc4e1804f41fcb4cd72c5b0b456402588f6f SHA512 ad6899122310e6e4ecb0e72737362379cc180524dd7e60c6dbacbd7d2a0eab5c633eb5ecf8b6731ed40b12e0e186eba8ce6def539c1c0969974e75467250b7b7
diff --git a/sci-physics/yoda/yoda-1.9.0.ebuild b/sci-physics/yoda/yoda-1.9.0.ebuild
new file mode 100644
index 000000000000..eccb09af10af
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+
+ newbashcomp "${ED}"/etc/bash_completion.d/yoda-completion yoda
+ rm "${ED}"/etc/bash_completion.d/yoda-completion || die
+}