summaryrefslogtreecommitdiff
path: root/sci-physics/yoda/yoda-1.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
commitcdfd4f0c915964d401cba19362c7dea8e89ad1da (patch)
treef6d313d1b57913d1309e00a578166e1e10fa6b8d /sci-physics/yoda/yoda-1.9.6.ebuild
parent05a34d98821265bf73820931936f86704b9002c6 (diff)
gentoo auto-resync : 23:08:2022 - 14:44:46
Diffstat (limited to 'sci-physics/yoda/yoda-1.9.6.ebuild')
-rw-r--r--sci-physics/yoda/yoda-1.9.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-physics/yoda/yoda-1.9.6.ebuild b/sci-physics/yoda/yoda-1.9.6.ebuild
new file mode 100644
index 000000000000..5802ef26d25b
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 autotools python-single-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+S="${WORKDIR}/${P^^}"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="root python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) root? ( python )"
+
+RDEPEND="
+ root? ( sci-physics/root:=[${PYTHON_SINGLE_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # reconf due to python3_10 patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable root) \
+ $(use_enable python pyext)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools to be installed already
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ # prevent double installation of python library
+ emake install DESTDIR="${ED}"
+ find "${ED}" -name '*.la' -delete || die
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion yoda
+ python_optimize
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+}