summaryrefslogtreecommitdiff
path: root/sci-physics/vmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sci-physics/vmc
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sci-physics/vmc')
-rw-r--r--sci-physics/vmc/Manifest4
-rw-r--r--sci-physics/vmc/metadata.xml24
-rw-r--r--sci-physics/vmc/vmc-1.0_p2.ebuild45
-rw-r--r--sci-physics/vmc/vmc-9999.ebuild45
4 files changed, 118 insertions, 0 deletions
diff --git a/sci-physics/vmc/Manifest b/sci-physics/vmc/Manifest
new file mode 100644
index 000000000000..e76a68a4d446
--- /dev/null
+++ b/sci-physics/vmc/Manifest
@@ -0,0 +1,4 @@
+DIST vmc-1.0_p2.tar.gz 91400 BLAKE2B d444a003433f4939f1b737ee8aa117a3230f83428ff9a79f8219a88bf5146104460a8be80ada9ab3a0a0edebc7d85d02bc51de053d54b06739d26cb0bbec3429 SHA512 51d6a8462c854411b595a20a2657b8012f19cd9c139f3341ccd72eb262473d01f6909ad22ee8d083f01cc5a2e43b2af265a7ed7c62a1285e8fab34c1b68ee3cd
+EBUILD vmc-1.0_p2.ebuild 1013 BLAKE2B 13342eb9c395fca1d4562c9822f877ef161122aa63770ff842cb58e526ff5bb761e5d560884dea39af41f0b68abaaf1e3a52f245dd4444be3f8a05763df8d24b SHA512 d5ac7b7ebf74ec367374efe4f40dd6d003f21a3be969b87d7b1155ba2f5587bedb74545790dbb13d91e701df444b281912f6f5901809e33801362df7c651cc8a
+EBUILD vmc-9999.ebuild 1013 BLAKE2B 13342eb9c395fca1d4562c9822f877ef161122aa63770ff842cb58e526ff5bb761e5d560884dea39af41f0b68abaaf1e3a52f245dd4444be3f8a05763df8d24b SHA512 d5ac7b7ebf74ec367374efe4f40dd6d003f21a3be969b87d7b1155ba2f5587bedb74545790dbb13d91e701df444b281912f6f5901809e33801362df7c651cc8a
+MISC metadata.xml 789 BLAKE2B e58e20f9b0e3254b2cc437d069f2d45d6cc02a8827a6015edcec1a47028b0089f5283dde64c62c5ea2e6d811ec12ecbcc9562e3c5605b47fc2d951009c732275 SHA512 850ccb5bb65bad8767756c4869f3b368d4a7664425287a23ae60aebb6d9b22d10586289a838a195bcbc74b15eef923eb10b005a30958d9d6541efc208a517516
diff --git a/sci-physics/vmc/metadata.xml b/sci-physics/vmc/metadata.xml
new file mode 100644
index 000000000000..3cf146831ddf
--- /dev/null
+++ b/sci-physics/vmc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>amadio@gentoo.org</email>
+ <name>Guilherme Amadio</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="c++11">Build using the C++11 standard</flag>
+ <flag name="c++14">Build using the C++14 standard</flag>
+ <flag name="c++17">Build using the C++17 standard</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">vmc-project/vmc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/vmc/vmc-1.0_p2.ebuild b/sci-physics/vmc/vmc-1.0_p2.ebuild
new file mode 100644
index 000000000000..fdebc4ac86fa
--- /dev/null
+++ b/sci-physics/vmc/vmc-1.0_p2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="The Virtual Monte Carlo core library."
+HOMEPAGE="https://vmc-project.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+c++11 c++14 c++17 doc"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND=">=sci-physics/root-6.18:=[c++11?,c++14?,c++17?,-vmc]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.md History)
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ # TRAVIS_BUILD_DIR hardcoded in Doxyfile by upstream.
+ TRAVIS_BUILD_DIR="${S}" doxygen doc/doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}
diff --git a/sci-physics/vmc/vmc-9999.ebuild b/sci-physics/vmc/vmc-9999.ebuild
new file mode 100644
index 000000000000..fdebc4ac86fa
--- /dev/null
+++ b/sci-physics/vmc/vmc-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="The Virtual Monte Carlo core library."
+HOMEPAGE="https://vmc-project.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+c++11 c++14 c++17 doc"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND=">=sci-physics/root-6.18:=[c++11?,c++14?,c++17?,-vmc]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.md History)
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ # TRAVIS_BUILD_DIR hardcoded in Doxyfile by upstream.
+ TRAVIS_BUILD_DIR="${S}" doxygen doc/doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}