summaryrefslogtreecommitdiff
path: root/sci-physics/root/root-6.26.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
commit40a480a83a10d1718e26a6f4fc54d271c1f13a95 (patch)
treebfe08ce789f69c5862fd8e5d1bc17b22f9f21b86 /sci-physics/root/root-6.26.9999.ebuild
parent2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (diff)
gentoo auto-resync : 20:10:2022 - 14:00:29
Diffstat (limited to 'sci-physics/root/root-6.26.9999.ebuild')
-rw-r--r--sci-physics/root/root-6.26.9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/sci-physics/root/root-6.26.9999.ebuild b/sci-physics/root/root-6.26.9999.ebuild
index c1dddda91e80..a3a2a140ba5a 100644
--- a/sci-physics/root/root-6.26.9999.ebuild
+++ b/sci-physics/root/root-6.26.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} ) # python3_11 fails to compile
inherit cmake cuda elisp-common fortran-2 python-single-r1 toolchain-funcs
@@ -167,6 +167,8 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"
+ -DLLVM_BUILD_TYPE=$(usex debug RelWithDebInfo Release)
+ -DCMAKE_BUILD_TYPE=$(usex debug RelWithDebInfo Release)
-DCMAKE_CUDA_HOST_COMPILER="$(tc-getCXX)"
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
@@ -291,16 +293,9 @@ src_configure() {
${EXTRA_ECONF}
)
- CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake_src_configure
}
-src_compile() {
- # needed for hsimple.root
- addwrite /dev/random
- cmake_src_compile
-}
-
src_install() {
cmake_src_install