summaryrefslogtreecommitdiff
path: root/sci-physics/rivet/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
commitee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (patch)
treef4cdf4b4814dfa35e701a066e3bc3c50f6afd7cf /sci-physics/rivet/files
parentdbd6eaafcce6a59fa9b3323124c38fa17aa88e26 (diff)
gentoo auto-resync : 21:03:2024 - 01:00:11
Diffstat (limited to 'sci-physics/rivet/files')
-rw-r--r--sci-physics/rivet/files/rivet-3.1.6-binreloc.patch12
-rw-r--r--sci-physics/rivet/files/rivet-3.1.9-pythontests.patch21
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-physics/rivet/files/rivet-3.1.6-binreloc.patch b/sci-physics/rivet/files/rivet-3.1.6-binreloc.patch
new file mode 100644
index 000000000000..e16691b88b47
--- /dev/null
+++ b/sci-physics/rivet/files/rivet-3.1.6-binreloc.patch
@@ -0,0 +1,12 @@
+diff -Naru Rivet-3.1.6.orig/src/Tools/binreloc.c Rivet-3.1.6/src/Tools/binreloc.c
+--- a/src/Tools/binreloc.c 2022-06-26 23:23:44.359890803 +0200
++++ b/src/Tools/binreloc.c 2022-06-26 23:24:36.962045655 +0200
+@@ -215,7 +215,7 @@
+ break;
+
+ /* Sanity check. */
+- if (strchr (line, '/') == NULL)
++ if (strstr (line, " r-xp ") == NULL || strchr (line, '/') == NULL)
+ /* With binutils > 2.30 (const void *) "" is placed in "r--p" area of memory
+ In general, for the mechanism of detection it doesn't really matter where your symbol is,
+ therefore, check for strstr (line, " r-xp ") == NULL is removed */
diff --git a/sci-physics/rivet/files/rivet-3.1.9-pythontests.patch b/sci-physics/rivet/files/rivet-3.1.9-pythontests.patch
new file mode 100644
index 000000000000..ad08ab63db5d
--- /dev/null
+++ b/sci-physics/rivet/files/rivet-3.1.9-pythontests.patch
@@ -0,0 +1,21 @@
+--- a/test/Makefile.am 2024-03-18 22:15:31.296275378 +0100
++++ b/test/Makefile.am 2024-03-18 22:15:57.499969373 +0100
+@@ -35,14 +35,16 @@
+ RIVET_TESTS_SRC=$(srcdir)
+
+ TESTS = \
+-testMath testMatVec testCmp testApi.sh testNaN.sh testBeams \
+-testImport.sh
++testMath testMatVec testCmp testApi.sh testNaN.sh testBeams
++if ENABLE_PYEXT
++TESTS += testImport.sh
+
+ if ENABLE_ANALYSES
+
+ TESTS += testCmdLine.sh
+
+ endif
++endif
+
+ EXTRA_DIST = testApi.hepmc testCmdLine.sh testImport.sh testApi.sh testNaN.sh
+