summaryrefslogtreecommitdiff
path: root/sci-physics/qmeq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /sci-physics/qmeq
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'sci-physics/qmeq')
-rw-r--r--sci-physics/qmeq/Manifest4
-rw-r--r--sci-physics/qmeq/metadata.xml11
-rw-r--r--sci-physics/qmeq/qmeq-1.0.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-physics/qmeq/Manifest b/sci-physics/qmeq/Manifest
new file mode 100644
index 000000000000..06fd9ad5ec3a
--- /dev/null
+++ b/sci-physics/qmeq/Manifest
@@ -0,0 +1,4 @@
+DIST qmeq-1.0.tar.gz 590715 BLAKE2B 7f091be0651236f2dcb45825df541813e27b43b2b8ec9184a342c962363921e29462726ba23530d0b956bba45793ed2036cec6287696e5fa58f91204d9267933 SHA512 3589fe927740cac5130a5b936e7fb8f73ce20f280878a326cdf91fe6340e8853f5e055c7e07170433c0977130cbb31644b0d9f84d23cd467aaa82557c8541e6f
+DIST qmeq-examples-1.0.tgz 289316 BLAKE2B add7520b579023c8da91aff294dd5a8fd29ba3520c3b496f2a98c8159dab4ad6bcdd1d12070357d868a10bbf224511ab27da069b94951d2c8632064344d2e143 SHA512 4a7b78a200ab4fa407401ea89740cdbcfb82376d97e8146e20a1cdab154269a6b9ce8217fb7ce78af73677b544ab535c5eadd386655dbff9c4ebde6c8eda9e38
+EBUILD qmeq-1.0.ebuild 949 BLAKE2B 39d10d665ab467b772b8ecee6f539338497898009fc98429757437204dd22f7114300fdb407533a5ea462886095f5390461ffcfa5ab63ca61dd8bbf9449e43a0 SHA512 a49606c74ed8dd460bba2441741937efd607a35891fe82cbd8352c45cacb22464a2f5f855f18d5f9b1663bd6bc9002df75b5b28c1a190eb5f451374782e9e689
+MISC metadata.xml 342 BLAKE2B 8bfc619eb36e81fb749932d8478b86b7ebce4e36378b3caf00b7d76b3a0d876debf3b42b1182fc68f5e1122974430a48b6977e69d9699f4eb04efe34b8be1ed1 SHA512 678efb4d82074368f3d07aa488049a79ccaa214c729b8de358e5f4eaeb3f49728a1019bf0ed5fb5bb6859f667b6d5ae2632a60d9af8b6cbd82c63c68b7624660
diff --git a/sci-physics/qmeq/metadata.xml b/sci-physics/qmeq/metadata.xml
new file mode 100644
index 000000000000..02fe3b97774d
--- /dev/null
+++ b/sci-physics/qmeq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gedaskir/qmeq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/qmeq/qmeq-1.0.ebuild b/sci-physics/qmeq/qmeq-1.0.ebuild
new file mode 100644
index 000000000000..b08ced5452ae
--- /dev/null
+++ b/sci-physics/qmeq/qmeq-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Quantum master equation package for Quantum dot transport calculations"
+HOMEPAGE="https://github.com/gedaskir/qmeq"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ examples? ( https://github.com/gedaskir/${PN}-examples/archive/${PV}.tar.gz -> ${PN}-examples-${PV}.tgz )
+"
+
+KEYWORDS="~amd64"
+IUSE="examples"
+LICENSE="BSD-2"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ examples? ( dev-python/jupyter[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ docompress -x "/usr/share/doc/${PF}"
+ use examples && dodoc -r "${WORKDIR}/${PN}-examples-${PV}"/*
+}