summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-physics/hepmc
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/Manifest5
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09-r1.ebuild92
-rw-r--r--sci-physics/hepmc/metadata.xml28
3 files changed, 125 insertions, 0 deletions
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
new file mode 100644
index 000000000000..ac5c1ad95ed9
--- /dev/null
+++ b/sci-physics/hepmc/Manifest
@@ -0,0 +1,5 @@
+DIST HepMC-2.06.09.tar.gz 4612637 SHA256 c60724ca9740230825e06c0c36fb2ffe17ff1b1465e8656268a61dffe1611a08 SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4 WHIRLPOOL 62b91da92ec30bbc1f5619a87e6172fd563751fe29453ed5bdf31ecae6c5964b59a601b4a52f5c3249cfc20664041ee27bb7114d006dabdf05c5926194890370
+EBUILD hepmc-2.06.09-r1.ebuild 2008 SHA256 ab8e3996e4927e3b7b6ac7d2c4fc55d394519c51833cf184bbdf89db7ad9446f SHA512 45ae43d27f3a46c79feaed8f9071f45b9a63d6d22dc8f93c0f329f412eda80eb722db0cce12a441f6a94356bf69131c8508a72c9d90b8fc7bcc1abb37ff52b0a WHIRLPOOL 276f66ccb72364d52167fdf186f1d8a2eab3404650dc7ae5c1c9c53817a78216a88fb7e8d49c8f2b1dc8b1d93cb8547faf64f447710eb743794144f5b50dd482
+MISC ChangeLog 3586 SHA256 1c634047c1bde1e526fb7ba5f9a2a87bcf3567dea5bc66afb442a47f3003c862 SHA512 7c8e331067647437ecc9f278c1d1d63e0538fd70b80f360c9cdfc97c1687e7b393d85440814aaed9f322c5071e3f1e3f2cbcb8ed67c805bcd136a35f4cf77045 WHIRLPOOL b5fe5f2ce632efb3b96e5aafd67545370edf2bfe48d3a798ca9f907cdd412338f4b8d71fbe373f25d7bea014b1cacc734287ea105a205dc7e075bfa8a81fe949
+MISC ChangeLog-2015 5053 SHA256 1fb557bf408eee5a73f39185d63736db7e3b298e4ac6c3fd3415d90179b4b600 SHA512 c5d7567e359699d58ad9c4a62f7ebd27dd1369d4d6f565b6045a4c199932a6b820ad8a882915637f31364cf86fc6841bbbc9b84d49e41c86e29f265b1e57825d WHIRLPOOL 420a066d467a9c17111c0254620000a3d8d0c53440c8a4842f97858471c5040ab955c3a4e4f327fd5a3620f997e59bac3288f7668142ca7413cd7f27d89ffdcb
+MISC metadata.xml 1386 SHA256 6d4ce6cb438474cffb889b1314febc176012fdd85ea1de72957e7596f2f8e0e1 SHA512 b0ef90b6404b04d1d393e9e8bb04ff08a51f72938362f4ae1e2806bfe29c99d50089f15ddacb59b94d6d554d0ec8842ba7b89777434e0bab08c51627ab8bd9ce WHIRLPOOL 3eefd0c08807619b539c4935dd2ca7fc6c3c894939b16547a954a44fea904dd0ff57508b960cd9e610874b5a77aca2eab74b985f7037d1feb582da077efa8c54
diff --git a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
new file mode 100644
index 000000000000..20b3409bd416
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepMC/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="cm doc examples gev static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ || (
+ dev-texlive/texlive-latex
+ dev-tex/floatflt
+ )
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_prepare() {
+ sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt
+ # CMake doc building broken
+ # gentoo doc directory
+ #sed -i \
+ # -e "s:share/HepMC/doc:share/doc/${PF}:" \
+ # doc/CMakeLists.txt || die
+
+ # gentoo examples directory
+ sed -i \
+ -e "s:share/HepMC:share/doc/${PF}:" \
+ $(find examples -name CMakeLists.txt) || die
+
+ # respect user's flags
+ sed -i \
+ -e "s/-O -ansi -pedantic -Wall//g" \
+ cmake/Modules/HepMCVariables.cmake || die
+
+ # gentoo libdir love
+ sed -i \
+ -e '/DESTINATION/s/lib/lib${LIB_SUFFIX}/g' \
+ {src,fio}/CMakeLists.txt || die
+
+ # remove targets if use flags not set
+ use examples || sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt
+ use test || sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt
+ if ! use static-libs; then
+ sed -i \
+ -e '/(HepMC\(fio\|\)S/d' \
+ -e '/TARGETS/s/HepMC\(fio\|\)S//' \
+ {src,fio}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ # use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ mycmakeargs+=(
+ -Dlength=${length_conf}
+ -Dmomentum=${momentum_conf}
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd doc
+ ./buildDoc.sh || die
+ ./buildDoxygen.sh || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc doc/*.pdf && dohtml -r doc/html/*
+}
diff --git a/sci-physics/hepmc/metadata.xml b/sci-physics/hepmc/metadata.xml
new file mode 100644
index 000000000000..b89c291af1b6
--- /dev/null
+++ b/sci-physics/hepmc/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+</maintainer>
+<longdescription lang="en">
+ The HepMC package is an object oriented event record written in C++
+ for High Energy Physics Monte Carlo Generators. Many extensions from
+ HEPEVT, the Fortran HEP standard, are supported: the number of entries
+ is unlimited, spin density matrices can be stored with each vertex,
+ flow patterns (such as color) can be stored and traced, integers
+ representing random number generator states can be stored, and an
+ arbitrary number of event weights can be included. Particles and
+ vertices are kept separate in a graph structure, physically similar to
+ a physics event. The added information supports the modularisation of
+ event generators. The package has been kept as simple as possible with
+ minimal internal/external dependencies. Event information is accessed
+ by means of iterators supplied with the package.
+
+ Reference: M. Dobbs and J.B. Hansen, Comput. Phys. Commun. 134 (2001)41.
+</longdescription>
+<use>
+ <flag name="gev">Build with GeV instead of default MeV for momentum units</flag>
+ <flag name="cm">Build with cm instead of default mm for length units</flag>
+</use>
+</pkgmetadata>