summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-physics/hepmc
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/Manifest2
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09-r2.ebuild (renamed from sci-physics/hepmc/hepmc-2.06.09-r1.ebuild)41
2 files changed, 20 insertions, 23 deletions
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
index 39780112468a..417240d0fbdb 100644
--- a/sci-physics/hepmc/Manifest
+++ b/sci-physics/hepmc/Manifest
@@ -1,3 +1,3 @@
DIST HepMC-2.06.09.tar.gz 4612637 BLAKE2B 6bbf1a6a8410b6717ddff29fc3643247582f7a61a05fd9e52a0b09f78bf75de587c1c55525f6a1367b306a26a4687ce55b64908c049d91bdb2db3d40467af62b SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4
-EBUILD hepmc-2.06.09-r1.ebuild 2050 BLAKE2B d5cca53267e511861f5b085bf105cb7720fe2b46a83c756baf2b0d6039aa653752c5f1fce649f00cdfa44194c3adba066c7aa88aacbc0f2c225e73138b167cd5 SHA512 b0bcff52f6d8e1cca09e7c2bc83d726eb77b11c9daf68cf18b02e12715a4dfdafbe1c56a627f641e770fbdeaa71853f95f9a309ce9fc74fc985414a60a00ae92
+EBUILD hepmc-2.06.09-r2.ebuild 1944 BLAKE2B 9c768aae3cb4bcc0d4c6953e7577e0bff407ec61ef1efb9ec34b60944ac8880e832a196c04cb1adcf1539488807af3729db35282cc71383ae560f22473dfca70 SHA512 0c45e436498dea65ea1b801a44b8b4c6e232305dbb7d002656a0f11feb4fb2a0d23cf6a63f0bfd7c711bff6fba60f69367ca7f173a6af0bac54c664bbd0b2cb6
MISC metadata.xml 1387 BLAKE2B fea7ce2a6373cb4c3dcc91f5cc9f7ddee03e12ae9f35769d949115e8d21e70bca4f2304cb6384d708b447e0e4a5b4bb5713d0abad011e10bacab84b601648b12 SHA512 c82cab58777d4e1ca0fe563e5625cba2cb99edfe27f477c191f5ef0afba40ff62f5d1834e8472294958e6c36f17af10b8da0c91fcb3b147bb3bd8dfda37a79fe
diff --git a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild b/sci-physics/hepmc/hepmc-2.06.09-r2.ebuild
index e8453c9991df..8a0b2af2611b 100644
--- a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.09-r2.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
MYP=HepMC-${PV}
DESCRIPTION="Event Record for Monte Carlo Generators"
HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cm doc examples gev static-libs test"
+IUSE="cm doc examples gev test"
RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="${RDEPEND}
+BDEPEND="
doc? (
app-doc/doxygen
dev-texlive/texlive-latex
@@ -26,12 +26,8 @@ DEPEND="${RDEPEND}
dev-texlive/texlive-latexrecommended
)"
-S="${WORKDIR}/${MYP}"
-
-DOCS=( ChangeLog AUTHORS )
-
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt || die
# CMake doc building broken
@@ -62,12 +58,12 @@ src_prepare() {
if ! use test; then
sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt || die
fi
- if ! use static-libs; then
- sed -i \
- -e '/(HepMC\(fio\|\)S/d' \
- -e '/TARGETS/s/HepMC\(fio\|\)S//' \
- {src,fio}/CMakeLists.txt || die
- fi
+
+ # remove static libs
+ sed -i \
+ -e '/(HepMC\(fio\|\)S/d' \
+ -e '/TARGETS/s/HepMC\(fio\|\)S//' \
+ {src,fio}/CMakeLists.txt || die
}
src_configure() {
@@ -76,20 +72,21 @@ src_configure() {
-Dlength=$(usex cm CM MM)
-Dmomentum=$(usex gev GEV MEV)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
+
if use doc; then
- cd doc
+ cd doc || die
./buildDoc.sh || die
./buildDoxygen.sh || die
+ HTML_DOCS=( doc/html/. )
fi
}
src_install() {
- use doc && HTML_DOCS=( doc/html/. )
+ cmake_src_install
use doc && dodoc doc/*.pdf
- cmake-utils_src_install
}