summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 17:23:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 17:23:01 +0100
commite805507c58bab294dddb75f6fc9b551d9d92de86 (patch)
tree0ea187e6b9c02a5666b5b05c33691360d7c3cfca /sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
parent4f39f95b585c2bd23d646439b444a8738b01d37e (diff)
gentoo auto-resync : 02:05:2023 - 17:23:00
Diffstat (limited to 'sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild b/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
new file mode 100644
index 000000000000..e61cb750aa34
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-3.2.5_p20230225-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit fortran-2 cmake python-single-r1
+
+MYPN=HepMC3
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.cern.ch/hepmc/HepMC3"
+else
+ COMMIT="e05d32ebac8705c0097e9e7d00ce815a205110db"
+ SRC_URI="https://gitlab.cern.ch/${PN}/${MYPN}/-/archive/${COMMIT}/${MYPN}-${COMMIT}.tar.gz"
+ S="${WORKDIR}/${MYPN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="3"
+IUSE="doc test examples python root"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ root? ( sci-physics/root:= )
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHEPMC3_ENABLE_ROOTIO=$(usex root ON OFF)
+ -DHEPMC3_ENABLE_PYTHON=$(usex python ON OFF)
+ -DHEPMC3_ENABLE_TEST=$(usex test ON OFF)
+ -DHEPMC3_BUILD_DOCS=$(usex doc ON OFF)
+ -DHEPMC3_BUILD_EXAMPLES=$(usex examples ON OFF)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+ use python && python_optimize
+}