summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sci-physics/fastjet
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sci-physics/fastjet')
-rw-r--r--sci-physics/fastjet/Manifest2
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6-r1.ebuild56
2 files changed, 35 insertions, 23 deletions
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
index 765deb5cdd3a..e892880122d9 100644
--- a/sci-physics/fastjet/Manifest
+++ b/sci-physics/fastjet/Manifest
@@ -1,4 +1,4 @@
AUX fastjet-3.0.6-system-siscone.patch 3726 BLAKE2B b8fcd8b93631892b68b7d4584c3e456118fd66f80e12e39be3fc82f2f6dac3c52a3d2218c7e8f342166047aee385c9f12192777454be333b2a01b307bc67cdac SHA512 7522e3fd0fe789bc5b3172c2c26566136004b828a46a81fb0ec39bb6bedbf358efc0b51acab8cb19a40dd5b4138190f87655ddd2679cc91c819f5c7c9e9f4c57
DIST fastjet-3.0.6.tar.gz 2216501 BLAKE2B 1aacab5c91cb70d66035deddc4929d60c51444f6f23396f947d704f607d5f2267ccc5e09ec633d6e0ec1255b3a6bc7e51e4ea49c4cb06d0e3b6953b601ab76ee SHA512 1f01b7ed0e07bd94c88faa123f72c2e3bcd81ad32ab4d03dc0a18dd18635f3b18ba8d339176b0ef1d6e58cecd9f37aaea30b4ad909d2782ce5be7c11e205c3a5
-EBUILD fastjet-3.0.6-r1.ebuild 1247 BLAKE2B 9df00a2006025aa82f6294ed5b7e0b921453c7e1c316d947ca40a3ea9e582d79beb9978ac1f82caf5f1514fa24354620de3b2550807491637293f694ff5d2428 SHA512 16ff337d0ef81f76028335f80d31b0eafdfde521dc11527f4e87624ebcda23caa3afc3d1ca49f2a264bbed588499e7cd439436956355bc063a833bc9430276ed
+EBUILD fastjet-3.0.6-r1.ebuild 1304 BLAKE2B 58f7f12b6ad33bd2976ba53623c3ec0575a920381d016173fe39385dcb9403d186d06ffa13f3babc9b7e60c39e99988da11a40e5705108cb32339e880f8f84aa SHA512 0a535d074e76d74759aa1de5fce5635d0ae12b3f88516011ce3a48bed42cb5908cbb639b7a4a69c14b36429ab79398d4d0bd6cbfdba7021518bcf1ee4c59cd82
MISC metadata.xml 846 BLAKE2B 011aac1c331a66bf050ec977961ea2091f54dad9b15611c02c84210a460b791ff1862a9b210c4acc2ba7e8877e0fb8db735dbdb16d71b2e3aee0b918d6286e4a SHA512 7a785ebae9232cef55c62ada47e4ec87507b6e4c7115f928fa3260474e67f56db336f7698833fe995d4f046b7013c88f62faf71758a881a86c982fe60a92c40a
diff --git a/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
index a7fec5728253..b5cfe12ace33 100644
--- a/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=plugins
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils fortran-2 flag-o-matic
+inherit autotools flag-o-matic fortran-2
DESCRIPTION="Fast implementation of several recombination jet algorithms"
HOMEPAGE="http://www.fastjet.fr/"
@@ -15,40 +14,53 @@ SRC_URI="http://www.fastjet.fr/repo/${P}.tar.gz"
LICENSE="GPL-2 QPL"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cgal doc examples +plugins static-libs"
+IUSE="cgal doc examples +plugins"
-RDEPEND="cgal? ( sci-mathematics/cgal )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- plugins? ( sci-physics/siscone:0= )"
+RDEPEND="
+ cgal? ( sci-mathematics/cgal:= )
+ plugins? ( sci-physics/siscone:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}"/${P}-system-siscone.patch )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use cgal && \
- has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
- local myeconfargs=(
- $(use_enable cgal)
- $(use_enable plugins allplugins)
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ --disable-static \
+ $(use_enable cgal) \
+ $(use_enable plugins allplugins) \
$(use_enable plugins allcxxplugins)
- )
- autotools-utils_src_configure
}
src_compile() {
- autotools-utils_src_compile
+ default
+
if use doc; then
doxygen Doxyfile || die
+ HTML_DOCS=( html/. )
fi
}
src_install() {
- autotools-utils_src_install
- use doc && dohtml -r html/*
+ default
+
if use examples; then
- insinto /usr/share/doc/${PF}
- find example \
- -name Makefile -or Makefile.in -or Makefile.am -delete
- doins -r example/*
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}