summaryrefslogtreecommitdiff
path: root/sci-physics/espresso/espresso-4.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-physics/espresso/espresso-4.1.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-physics/espresso/espresso-4.1.3.ebuild')
-rw-r--r--sci-physics/espresso/espresso-4.1.3.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/sci-physics/espresso/espresso-4.1.3.ebuild b/sci-physics/espresso/espresso-4.1.3.ebuild
new file mode 100644
index 000000000000..ef5f6578edce
--- /dev/null
+++ b/sci-physics/espresso/espresso-4.1.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
+ EGIT_BRANCH="python"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}md/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cuda doc examples +fftw +hdf5 test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/boost:=[mpi]
+ hdf5? ( sci-libs/hdf5:=[mpi] )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_CUDA=$(usex cuda)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DWITH_TESTS=$(usex test)
+ -DINSTALL_PYPRESSO=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
+ -DWITH_HDF5=$(usex hdf5)
+ -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
+ -DCMAKE_SKIP_RPATH=YES
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doxygen
+ [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
+}
+
+src_install() {
+ local i docdir="${S}"
+
+ cmake_src_install
+
+ insinto /usr/share/${PN}/
+ doins "${BUILD_DIR}/myconfig-sample.hpp"
+
+ save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
+
+ if use doc; then
+ [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
+ newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ dodoc -r "${BUILD_DIR}/doc/doxygen/html"
+ fi
+
+ if use examples; then
+ insinto "/usr/share/${PN}/examples/python"
+ doins -r samples/${i}/.
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.hpp"
+ echo
+}