summaryrefslogtreecommitdiff
path: root/sci-physics/bullet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /sci-physics/bullet
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'sci-physics/bullet')
-rw-r--r--sci-physics/bullet/Manifest2
-rw-r--r--sci-physics/bullet/bullet-3.08.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
index 6992ef66595f..a36222cad833 100644
--- a/sci-physics/bullet/Manifest
+++ b/sci-physics/bullet/Manifest
@@ -1,4 +1,6 @@
AUX bullet-2.85-soversion.patch 1094 BLAKE2B 8dc035b80d812b3c2382067796f1626a932ce887246b34a8b5e08fddf45d330078a970eb6c2147259285a45974b8aaa26a2494ad4aa4824d89bf58aa7af3ac37 SHA512 f437d553c51c6cc6646a4a3bf0ffe02e2691a3b2109ea560c986f69c602055c409028a5a3711597aca757d3e3b33cab14d60e03fc120f0975f35c6e16be6362d
DIST bullet-3.07.tar.gz 148413637 BLAKE2B 776cd7651d11d865095ea000d353860bea09c6ff4ec8dd8e43282a78373e2830f6ce1ce2b87ed25a67be7bded297b3a6320b2872a71dfd3849e7b197c6d2c936 SHA512 31fc7cb4ed8b939abc9eeb0a8f6fff3a454ea4ebcffd797fd35a2320fe3ab222fcd315569809ea148d0efff47267f5eec9f4bf7aaf07730a06aa9babd2abc9a6
+DIST bullet-3.08.tar.gz 129282084 BLAKE2B daa5b6719575af28c6f6359ef51c7a9b8ca9cde2e5b4ea1b00c2991fc4d6b13175d034c7a694eaf36e8ff3ab343457027f57bb511639b3701341ad4551f1a6ca SHA512 4177c2b2f3b007691102973e7a3d4337b8de559d20058db75a2d25eab35b9be62fa14e3362435ef6f7ea2f6b8cf02a78770cc49c17e979adf3a2b41f19ee702a
EBUILD bullet-3.07.ebuild 1929 BLAKE2B c0a1c9c8c2f92c7e7493164eca8f4d27d83944eff2bd5dbffe6705b6c6bd69705b275eff2074de76ac6747702e792e6ff1110247d9fb18b4713efc8d07a7b2a4 SHA512 df6585dc25557f961177d89b340eed84c28a23e2bb8174540ad833e06bf1ec735e3135535348c79323eb2fafa504643eea9a8d386b56ede968344092321c7408
+EBUILD bullet-3.08.ebuild 1931 BLAKE2B 975648f912744474bf610c45ab06f786698b677a0633c7b71dfd514e7b0ec8f138048e13a04aa04c0aa0cfa1d21cccd020255aba23aa5b1dfcacb90be5f31b0b SHA512 3176b2563d9ee11de1d75ad0d51427d761df548699f98772c6337440ba3593a0e83fb19428acb9cf55a6160dd2de8491910bb9db04901698775bec24c93dcfa1
MISC metadata.xml 1119 BLAKE2B 0242add0b8c197137e448ac9a34cf4a1b543decd8e120e6673ac70e32f493b14531fac469dbfc2f44e49659977789fcc5b917a743354fc5cbb2b1d0d3a5780ad SHA512 8831dc59734db66ca01cc2901f1efe360cc8ad9f96cf4712df92d2975797002fbb193fe0f55a79f4ef71affc53be7a084c38f506c65f663759df3d40073ff59e
diff --git a/sci-physics/bullet/bullet-3.08.ebuild b/sci-physics/bullet/bullet-3.08.ebuild
new file mode 100644
index 000000000000..255f3af6bc82
--- /dev/null
+++ b/sci-physics/bullet/bullet-3.08.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="https://www.bulletphysics.com/"
+SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc double-precision examples openmp tbb test threads"
+
+REQUIRED_USE="
+ openmp? ( threads )
+ tbb? ( threads )
+"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
+
+DOCS=( AUTHORS.txt LICENSE.txt README.md )
+
+# Building / linking of third Party library BussIK does not work out of the box
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_OPENGL3_DEMOS=OFF
+ -DBUILD_BULLET2_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DBUILD_BULLET3=ON
+ -DBUILD_EXTRAS=OFF
+ -DUSE_DOUBLE_PRECISION=$(usex double-precision)
+ -DBUILD_UNIT_TESTS=$(usex test)
+ -DBULLET2_MULTITHREADING=$(usex threads)
+ -DBULLET2_USE_OPEN_MP_MULTITHREADING=$(usex openmp)
+ -DBULLET2_USE_TBB_MULTITHREADING=$(usex tbb)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ doxygen || die
+ HTML_DOCS+=( html/. )
+ DOCS+=( docs/*.pdf )
+ fi
+
+ if use examples; then
+ # throws QA warnings
+ rm examples/ThirdPartyLibs/openvr/*/linux*/libopenvr_api.so || die
+ DOCS+=( examples )
+ fi
+}