summaryrefslogtreecommitdiff
path: root/sci-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
commita4e37a9aeeef82eba5858dbc609f65b838b0f836 (patch)
treee4348e571adc5713a413fbaf411d45c511a7da31 /sci-misc
parentd03ec6c0e9c1683a824ce77667440dcb4a13974e (diff)
gentoo auto-resync : 05:10:2022 - 19:20:12
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/Manifest.gzbin2920 -> 2918 bytes
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest2
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.6.1.ebuild116
-rw-r--r--sci-misc/vitables/Manifest1
-rw-r--r--sci-misc/vitables/vitables-3.0.2-r1.ebuild41
5 files changed, 160 insertions, 0 deletions
diff --git a/sci-misc/Manifest.gz b/sci-misc/Manifest.gz
index e14d4e487cda..b93f4a7d1962 100644
--- a/sci-misc/Manifest.gz
+++ b/sci-misc/Manifest.gz
Binary files differ
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 42e6a57379c6..078c2b47259f 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-desktop-bin-3.4.5.1.rpm 335639840 BLAKE2B 6be6792ba7ce8db996701b287c5b4686be6088fdbf7ba3eecdac1bed25c9caba46b81ff61e8a66350558b36f69a27e4ea9559d00a431a9a702b99a0cfe0bf437 SHA512 025e31f7baa1da186343538ea3f9668c0873dfe0081572cac5673aae1691843e6d14145a6fedd7330f043b127d84ec74563436ae08c7a4d3254093ab9560c0c1
+DIST jupyterlab-desktop-bin-3.4.6.1.rpm 335746672 BLAKE2B d9c85fe80bba55a6fadfd2cd7ff6ff5f0991df40764c9c28f83eb258fbf7d26a620089ea7aadcb1c5c827c65446eda05861b9c5102edbd4eab2b5d53fd955a5b SHA512 c9a33bc6980afdfe979dbfb45d71e4954ce1913712010c2fdc7ce73ac480e56f005eb289df840524058163a61a79fab01bd27240515ec353c0b23f0b07a32807
EBUILD jupyterlab-desktop-bin-3.4.5.1.ebuild 2942 BLAKE2B 111aafffa57e9c2750e1f9dff3c4f7105e1842299e9ffdbf3aa2948ca4582890ac25114c3e10ad9c7c636f2c9b0299a6f0b43f5bafc0008bc8b65295b2c1f121 SHA512 8baf8de102b663ce0e6df335b05c2bbfcaa95ac95a387a53ca19de23295196faebc873bc0882a9ea9bc90e786baf61783e448cbd7616e089f7588ea118032707
+EBUILD jupyterlab-desktop-bin-3.4.6.1.ebuild 2942 BLAKE2B 111aafffa57e9c2750e1f9dff3c4f7105e1842299e9ffdbf3aa2948ca4582890ac25114c3e10ad9c7c636f2c9b0299a6f0b43f5bafc0008bc8b65295b2c1f121 SHA512 8baf8de102b663ce0e6df335b05c2bbfcaa95ac95a387a53ca19de23295196faebc873bc0882a9ea9bc90e786baf61783e448cbd7616e089f7588ea118032707
MISC metadata.xml 430 BLAKE2B 1bd3f621bb4d25086cc80c5b44a7eef4a61f58c1f56c7cb91ca4e39b8a5e7d5fdd37e912e48d99ee6ba6a19de1c61252b4ebe3afd554d487c549d22597c376fc SHA512 b99b088cb0bdcfdaa9d584fb580b12a754f30a378fdede655f7723075e81948fc57f9aad11a59944b164eb8c9c24f6f0828e95c5a227766e985778900ea08079
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.6.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.6.1.ebuild
new file mode 100644
index 000000000000..a413416551f2
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.6.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+ done
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ exeinto "${DESTDIR}/swiftshader"
+ doexe swiftshader/*.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}
diff --git a/sci-misc/vitables/Manifest b/sci-misc/vitables/Manifest
index f15e3a34884f..dc3adf71cdc2 100644
--- a/sci-misc/vitables/Manifest
+++ b/sci-misc/vitables/Manifest
@@ -1,3 +1,4 @@
DIST ViTables-3.0.2.tar.gz 921231 BLAKE2B 5800cf222260f0d4c4c7c652f8ecab32b764f3555d7a19bc3aca6acdb68648b0b381389737a67f8b2d558ba09dc9f9837103a6c3c27ca6f7b9c0b0ca31bf8978 SHA512 d9b5fc0c5c31cd663a5ce8af415b8e7feef89b5d542933dbb8809961b9bdf325d115238526856f928e8326192e73c8cd84879566d569d70c6418921dac444766
+EBUILD vitables-3.0.2-r1.ebuild 904 BLAKE2B 15e77f5167ee05e903a15dd1f67e6a320d22ebbc0ab6583481d2f30414f26517f17eaa69d9f09bf8cecf664dcd63facfef6805e536cf11dddc79510f53cd519b SHA512 4e0ffa8fe95a4f89d1cb31bfe3bb754ac44ec9bc12b9e69bd55b30930feea3ae70334ade025e8798e1e222e91478b47f19dfeb77beada44d21b8e16699da4915
EBUILD vitables-3.0.2.ebuild 871 BLAKE2B 581a5cc815cd8a17a2e21c7e6fe93e77565a4fa519daaa099180699ed938627ebe2814990e2f93936ab9d7cf5f85aab87fc8ab6fe12542ec8bc08cffa116d798 SHA512 dacdb59394a6b598daadcda540692e56cdb3c0017310c75f3d49e2d1b39180b8e47a79a2ba2b40cdc2f27995738553a920b39284246552c5a537339ac93005d3
MISC metadata.xml 638 BLAKE2B 9a51b0a13085174216614fb77fde8f782d03b5edb1ffc11c96183e1b0f976ffdae335680cdb5a2fc39bfa98d6d75c5c2b9f976189e59cba1f6e41cb9fd58bf14 SHA512 3c4e845b39a051d43e6ae2f59bc4ad41f732ca7b6607deab2e378e0104ea63f7fb63471ec6a668ae6581057610eb352139c062f9bc025e232ec6dc1ea57b0709
diff --git a/sci-misc/vitables/vitables-3.0.2-r1.ebuild b/sci-misc/vitables/vitables-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..3b9e8f66f750
--- /dev/null
+++ b/sci-misc/vitables/vitables-3.0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="ViTables"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
+HOMEPAGE="https://vitables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ <dev-python/sip-5[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest