summaryrefslogtreecommitdiff
path: root/sci-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-misc
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/Manifest.gzbin2735 -> 2920 bytes
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest3
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild65
-rw-r--r--sci-misc/jupyterlab-desktop-bin/metadata.xml12
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-misc/Manifest.gz b/sci-misc/Manifest.gz
index 437932b3024f..cf88b29a5129 100644
--- a/sci-misc/Manifest.gz
+++ b/sci-misc/Manifest.gz
Binary files differ
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
new file mode 100644
index 000000000000..ce1d1ef42c0b
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -0,0 +1,3 @@
+DIST jupyterlab-desktop-bin-3.2.4.3.rpm 269019824 BLAKE2B cc4acde522b3cab06e1d4b26ed21352cb20396e766c71da889fb19fae52af0df7c8acd4e9b91083ab944995fdc2f3acf3af28c7320e0da951505ea75e2c70b63 SHA512 6eb5220e149cd2f61cbaf35e377bdd02fefa292eb0145936da6d7b875f68779a47f5a99be12bf57b44840f6b5bdfd3e9923bf0947cbe3c2e155cd5f5e2c64317
+EBUILD jupyterlab-desktop-bin-3.2.4.3.ebuild 1544 BLAKE2B 5a945b02f4afb5093834256e0bc2618a3101f22ff65a02192d7fae5b17f0c3a4875d0d3d4323aee602ae4c1be60bd976919d11f1c669fac68df6debd1dc7c768 SHA512 965e965bbc31e876f92343dc87f82c03bca4bf6d888a3d060a27d5fec18d24c7163ef0b0cf35571c257370f9bb884bd0a1a2f5420bd91780cb504338bb623471
+MISC metadata.xml 430 BLAKE2B 1bd3f621bb4d25086cc80c5b44a7eef4a61f58c1f56c7cb91ca4e39b8a5e7d5fdd37e912e48d99ee6ba6a19de1c61252b4ebe3afd554d487c549d22597c376fc SHA512 b99b088cb0bdcfdaa9d584fb580b12a754f30a378fdede655f7723075e81948fc57f9aad11a59944b164eb8c9c24f6f0828e95c5a227766e985778900ea08079
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild
new file mode 100644
index 000000000000..c83878c8b02f
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}
diff --git a/sci-misc/jupyterlab-desktop-bin/metadata.xml b/sci-misc/jupyterlab-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..af73f75812c1
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">jupyterlab/jupyterlab-desktop</remote-id>
+ <bugs-to>https://github.com/jupyterlab/jupyterlab-desktop/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>