summaryrefslogtreecommitdiff
path: root/sci-misc/h5utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-misc/h5utils/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-misc/h5utils/files')
-rw-r--r--sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch63
-rw-r--r--sci-misc/h5utils/files/h5utils-1.12.1-png15.patch43
2 files changed, 106 insertions, 0 deletions
diff --git a/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch b/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch
new file mode 100644
index 000000000000..8de8580cfe38
--- /dev/null
+++ b/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch
@@ -0,0 +1,63 @@
+--- configure.ac
++++ configure.ac
+@@ -74,44 +74,23 @@
+
+ ###########################################################################
+
+-# Only build h5fromh4 if we are using a version of HDF5 prior to 1.4, and
+-# thus don't have the superior h4toh5 utility. Similarly for h5toh4.
+-AC_CHECK_PROG(H4TOH5, h4toh5, h4toh5)
+-AC_CHECK_PROG(H5TOH4, h5toh4, h5toh4)
+-
+-AC_ARG_WITH(hdf4,
+- [AC_HELP_STRING([--with-hdf4], [build hdf4 utils even if h4toh5 and h5toh4 are present])],
+- ok=$withval, ok=maybe)
+-if test "x$ok" = xyes; then
+- H4TOH5=""
+- H5TOH4=""
+-elif test "x$ok" = xno; then
+- H4TOH5="h4toh5"
+- H5TOH4="h5toh4"
+-fi
+-
+-HDF4=no
+-if test "x$H4TOH5" != xh4toh5 -o "x$H5TOH4" != xh5toh4; then
+- AC_CHECK_LIB(jpeg, jpeg_start_compress,
+- [AC_CHECK_LIB(df, DFSDgetdata,
+- [H4_LIBS="-ldf -ljpeg"; HDF4=yes],
+- [AC_MSG_WARN([can't find libdf (HDF4): won't be able to compile h5fromh4 or h4fromh5])], -ljpeg)],
+- [AC_MSG_WARN([can't find libjpeg: won't be able to compile h5fromh4 or h4fromh5])])
+-
+- if test $HDF4 = yes; then
+- if test "x$H4TOH5" != xh4toh5; then
+- MORE_H5UTILS="h5fromh4\$(EXEEXT) $MORE_H5UTILS"
+- MORE_H5UTILS_MANS="h5fromh4.1 $MORE_H5UTILS_MANS"
+- fi
+- if test "x$H5TOH4" != xh5toh4; then
+- MORE_H5UTILS="h4fromh5\$(EXEEXT) $MORE_H5UTILS"
+- # MORE_H5UTILS_MANS="h4fromh5.1 $MORE_H5UTILS_MANS"
+- fi
+- fi
+-fi
+-AC_CHECK_HEADERS(hdf.h hdf/hdf.h)
++AC_ARG_WITH([hdf], AS_HELP_STRING([--with-hdf], [build hdf4 utils even if h4toh5 and h5toh4 are present]))
+
+-AC_SUBST(H4_LIBS)
++AS_IF([test "x$with_hdf" = "xyes"], [
++ AC_CHECK_HEADERS(hdf.h hdf/hdf.h)
++ AC_CHECK_LIB(jpeg, jpeg_start_compress,
++ [AC_CHECK_LIB(df, DFSDgetdata,
++ [H4_LIBS="-ldf -ljpeg"; HDF4=yes],
++ [AC_MSG_WARN([can't find libdf (HDF4): won't be able to compile h5fromh4 or h4fromh5])], -ljpeg)],
++ [AC_MSG_WARN([can't find libjpeg: won't be able to compile h5fromh4 or h4fromh5])])
++ if test $HDF4 = yes; then
++ MORE_H5UTILS="h5fromh4\$(EXEEXT) $MORE_H5UTILS"
++ MORE_H5UTILS_MANS="h5fromh4.1 $MORE_H5UTILS_MANS"
++ MORE_H5UTILS="h4fromh5\$(EXEEXT) $MORE_H5UTILS"
++ fi
++
++ AC_SUBST(H4_LIBS)
++])
+
+ ###########################################################################
+
diff --git a/sci-misc/h5utils/files/h5utils-1.12.1-png15.patch b/sci-misc/h5utils/files/h5utils-1.12.1-png15.patch
new file mode 100644
index 000000000000..e611310145eb
--- /dev/null
+++ b/sci-misc/h5utils/files/h5utils-1.12.1-png15.patch
@@ -0,0 +1,43 @@
+Fix build with png-1.5.
+
+https://bugs.gentoo.org/show_bug.cgi?id=378919
+
+Patch stolen from NetBSD
+--- writepng.c
++++ writepng.c
+@@ -240,6 +240,8 @@ void writepng(char *filename,
+ double skewsin = sin(skew), skewcos = cos(skew);
+ REAL minoverlay = 0, maxoverlay = 0;
+ png_byte mask_byte;
++ png_colorp palette = NULL;
++
+
+ /* we must use direct color for translucent overlays */
+ if (overlay)
+@@ -309,7 +311,7 @@ void writepng(char *filename,
+ }
+ /* Set error handling. REQUIRED if you aren't supplying your own *
+ * error hadnling functions in the png_create_write_struct() call. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file */
+ fclose(fp);
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
+@@ -334,8 +336,6 @@ void writepng(char *filename,
+ PNG_INTERLACE_NONE,
+ PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
+ else {
+- png_colorp palette;
+-
+ png_set_IHDR(png_ptr, info_ptr, width, height, 8 /* bit_depth */ ,
+ PNG_COLOR_TYPE_PALETTE,
+ PNG_INTERLACE_NONE,
+@@ -434,7 +434,7 @@ void writepng(char *filename,
+ png_write_end(png_ptr, info_ptr);
+
+ /* if you malloced the palette, free it here */
+- free(info_ptr->palette);
++ free(palette);
+
+ /* if you allocated any text comments, free them here */
+