summaryrefslogtreecommitdiff
path: root/sci-misc/flashdot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /sci-misc/flashdot/files
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'sci-misc/flashdot/files')
-rw-r--r--sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch10
-rw-r--r--sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch11
2 files changed, 21 insertions, 0 deletions
diff --git a/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch b/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch
new file mode 100644
index 000000000000..077367bd2ab0
--- /dev/null
+++ b/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch
@@ -0,0 +1,10 @@
+--- a/mathexpr/Makefile 2022-03-22 10:51:43.081062080 +0100
++++ b/mathexpr/Makefile 2022-03-22 10:53:37.226190652 +0100
+@@ -72,6 +72,6 @@
+ # Dependencies
+ depend:
+- $(OCAMLDEP) $(OCAMLINCS) *.mli *.ml > depend
++ $(OCAMLDEP) -I $(XMLLIGHTDIR) $(OCAMLINCSLOCAL) *.mli *.ml > depend
+
+ include depend
+
diff --git a/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
index 8b00b86d52b7..285a2c746e20 100644
--- a/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
+++ b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
@@ -9,3 +9,14 @@
fill_buff ()
in
let s = fill_buff () in
+--- a/mathexpr/mathexpr.ml 2022-03-22 12:36:30.252580025 +0100
++++ b/mathexpr/mathexpr.ml 2022-03-22 12:32:10.594137416 +0100
+@@ -2859,7 +2859,7 @@
+ while true do
+ let n = input f strbuf 0 1024 in
+ if n = 0 then raise Exit else
+- Buffer.add_substring resbuf strbuf 0 n
++ Buffer.add_subbytes resbuf strbuf 0 n
+ done;
+ Buffer.contents resbuf
+ with Exit -> Buffer.contents resbuf