summaryrefslogtreecommitdiff
path: root/sci-misc/fitsverify/fitsverify-4.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-misc/fitsverify/fitsverify-4.18.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-misc/fitsverify/fitsverify-4.18.ebuild')
-rw-r--r--sci-misc/fitsverify/fitsverify-4.18.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-misc/fitsverify/fitsverify-4.18.ebuild b/sci-misc/fitsverify/fitsverify-4.18.ebuild
new file mode 100644
index 000000000000..b7daee4cc8e1
--- /dev/null
+++ b/sci-misc/fitsverify/fitsverify-4.18.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="FITS file format checker"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/fitsverify/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/cfitsio:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) ${CPPFLAGS} -DSTANDALONE ${CFLAGS} ${LDFLAGS} \
+ $($(tc-getPKG_CONFIG) --cflags cfitsio) \
+ ftverify.c fvrf*.c \
+ $($(tc-getPKG_CONFIG) --libs cfitsio) -o ${PN} \
+ || die "compiled failed"
+}
+
+src_install() {
+ dobin fitsverify
+ dodoc README
+}