summaryrefslogtreecommitdiff
path: root/sci-misc/cdfplayer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /sci-misc/cdfplayer
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'sci-misc/cdfplayer')
-rw-r--r--sci-misc/cdfplayer/Manifest2
-rw-r--r--sci-misc/cdfplayer/cdfplayer-12.2.0-r1.ebuild (renamed from sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild)69
2 files changed, 34 insertions, 37 deletions
diff --git a/sci-misc/cdfplayer/Manifest b/sci-misc/cdfplayer/Manifest
index da142f203899..fe855ff89c15 100644
--- a/sci-misc/cdfplayer/Manifest
+++ b/sci-misc/cdfplayer/Manifest
@@ -1,3 +1,3 @@
DIST WolframPlayer_12.2.0_LINUX.sh 1003754320 BLAKE2B b37e2500e09543efd5084b6fadd6f5d6d6f7f2b75627fc8cb3819578d41de00a8ba5f529440d64efebabcf9d26a77b51b01969135f02baca851c42811ef521b7 SHA512 dc4449836419dd7abe8590319912b07019a4f2cf542e31759c15bde0055bfc6bebc880fd6ab88809758d5723862bbbe971affa07429a660b728698d24a4c9d20
-EBUILD cdfplayer-12.2.0.ebuild 2391 BLAKE2B d2eecbdac99d10dd52b67bdebf5020f490c7934330ccc6989b24ddc1004dfd844e10ae75804cecfb303e6bd1da17698781f37045a12ea3e17586be1bfd615f9f SHA512 0f9872d1736b50f6347cb6501eda62bc248ce694f0c2c678fb9d46642c2b13aa96aedd8b81fd92f7628a85efcbc738331ff4e40a62cee7f2589ea1f417353020
+EBUILD cdfplayer-12.2.0-r1.ebuild 2415 BLAKE2B 0718c2ba7b4cfd398343ec734dae6d957a5b4d05de78227ffa785d3e917cc31bf11010ebe6cb9c5aadae6d334c793e9a9de3ee941ef7954428861e43091a0d8d SHA512 6693d79d7c06da6c8702f2106e5f32d90a3b5efaf13454957411d75e0bdd932eda4a6f5b3cd6989040bb16c3d14490d2ffd530cb71400334db3714cb4cd5f384
MISC metadata.xml 261 BLAKE2B e57c0c3e4a59fdb630d23ae9d96afed10307c5308bace0cf58c22f41cbbf22fc82c5cd0d041800498570b1490a39f6c47547acfbb2766e21735820ae1c39bf8f SHA512 212dbdf6e688804621cd0ee28e47d3b9696182fe4850a87569e0727e5e811b7c4193807c2ecec65005e1689d4c0ba2c88fb67b29cc89928649e23d23a94d724b
diff --git a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild b/sci-misc/cdfplayer/cdfplayer-12.2.0-r1.ebuild
index 21828e52bedd..39c3c27587c7 100644
--- a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
+++ b/sci-misc/cdfplayer/cdfplayer-12.2.0-r1.ebuild
@@ -1,30 +1,35 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit desktop eapi7-ver multilib
+inherit desktop
DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
-SRC_URI="WolframPlayer_${PV}_LINUX.sh"
HOMEPAGE="http://www.wolfram.com/cdf-player/"
+SRC_URI="WolframPlayer_${PV}_LINUX.sh"
+S="${WORKDIR}"
LICENSE="WolframCDFPlayer"
KEYWORDS="-* ~amd64 ~x86"
SLOT="0"
-IUSE=""
-
RESTRICT="strip mirror bindist fetch"
-DEPEND=""
-
# this list comes from lsof output
# probably there are still some libraries missing
RDEPEND="
+ dev-libs/expat
+ dev-libs/icu
+ dev-libs/libxml2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-libs/ncurses-compat:5
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXau
+ x11-libs/libxcb
x11-libs/libXcursor
x11-libs/libXdmcp
x11-libs/libXext
@@ -34,14 +39,6 @@ RDEPEND="
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXt
- media-libs/alsa-lib
- dev-libs/expat
- media-libs/fontconfig
- dev-libs/icu
- x11-libs/libxcb
- dev-libs/libxml2
- sys-libs/ncurses-compat:5
- media-libs/freetype
"
# we need this a few times
@@ -51,42 +48,42 @@ MPV=$(ver_cut 1-2)
# we might as well list all files in all QA variables...
QA_PREBUILT="opt/*"
-S=${WORKDIR}
+pkg_nofetch() {
+ einfo "Sadly Wolfram provides no permanent link to the player files."
+ einfo "Please download the Wolfram CFD Player installation file ${SRC_URI} from"
+ einfo "${HOMEPAGE} and place it into your DISTDIR directory."
+}
src_unpack() {
- /bin/sh "${DISTDIR}/${A}" --nox11 --confirm --keep -- -auto "-targetdir=${S}/opt/Wolfram/${MPN}/${MPV}" "-execdir=${S}/opt/bin" || die
+ ${CONFIG_SHELL:-${BASH}} "${DISTDIR}/${A}" --nox11 --confirm --keep -- -auto "-targetdir=${S}/opt/Wolfram/${MPN}/${MPV}" "-execdir=${S}/opt/bin"
}
src_install() {
- local ARCH
- if use amd64; then ARCH='-x86-64'; else ARCH=''; fi
+ local ARCH=$(usev amd64 '-x86-64')
# move all over
- mv "${S}"/opt "${D}"/opt || die
+ (
+ insinto /
+ doins -r opt
+ )
# the autogenerated symlinks point into sandbox, redo
- rm "${D}"/opt/bin/* || die
+ rm "${ED}"/opt/bin/* || die
dosym ../Wolfram/${MPN}/${MPV}/Executables/wolframplayer opt/bin/wolframplayer
dosym ../Wolfram/${MPN}/${MPV}/Executables/WolframPlayer opt/bin/WolframPlayer
# fix some embedded paths and install desktop files
local filename
- for filename in $(find "${D}" -name "wolfram-cdf12.desktop") ; do
- echo Fixing "${filename}"
- sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
- echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+ while IFS="" read -d $'\0' -r filename ; do
+ einfo "Fixing ${filename}"
+ sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}" || die
+ echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}" || die
domenu "${filename}"
- done
+ done < <(find "${ED}" -type f -name "wolfram-cdf12.desktop" -print0)
# install a wrapper
- echo '#!/bin/sh' >> ${PN}
- echo "LD_PRELOAD=/usr/$(get_libdir)/libfreetype.so.6:/lib/libz.so.1 /opt/Wolfram/${MPN}/${MPV}/Executables/wolframplayer \$*" \
- >> ${PN}
- dobin ${PN}
-}
-
-pkg_nofetch() {
- einfo "Sadly Wolfram provides no permanent link to the player files."
- einfo "Please download the Wolfram CFD Player installation file ${SRC_URI} from"
- einfo "${HOMEPAGE} and place it into your DISTDIR directory."
+ newbin - ${PN} <<- _EOF_
+ #!/usr/bin/env sh
+ LD_PRELOAD=${EPREFIX}/usr/$(get_libdir)/libfreetype.so.6:${EPREFIX}/lib/libz.so.1 ${EPREFIX}/opt/Wolfram/${MPN}/${MPV}/Executables/wolframplayer \$*
+ _EOF_
}