summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-25 04:44:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-25 04:44:48 +0000
commita4a19f78acc305106f3b54bec9af212e38bfe7be (patch)
tree9db5e083c381cba07eefd91b2cf65089e9667998 /sci-mathematics
parent3f6b99c9f74a0a7bfa2e18f0a7bc7057739cc00b (diff)
gentoo auto-resync : 25:01:2024 - 04:44:48
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19159 -> 19159 bytes
-rw-r--r--sci-mathematics/coq/Manifest2
-rw-r--r--sci-mathematics/coq/coq-8.19.0.ebuild122
3 files changed, 124 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ed31110bc625..ae72824ca59a 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index e114e317f874..f084e09bf0d7 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,7 @@
DIST coq-8.17.1.tar.gz 7506035 BLAKE2B 29b5b11666185ec293f50264f5a8ad66433c3ce05d74128b524f6fc3c6810551fe76d11d6f9db7d3741b829ac8bacb66948aad522d0cd2c487692c3df8b563ff SHA512 9a35311acec2a806730b94ac7dceabc88837f235c52a14c026827d9b89433bd7fa9555a9fc6829aa49edfedb24c8bbaf1411ebf463b74a50aeb17cba47745b6b
DIST coq-8.18.0.tar.gz 7612742 BLAKE2B 2fb9f6205465ded60d2e1f7943f53ad884aea121c8129bb30c3f66c172f51f97eb553f8a745fd3ab1ec4da80d4ca08a7aea22f65d372fda3322c0f9ca7862923 SHA512 46922d5f2eb6802a148a52fd3e7f0be8370c93e7bc33cee05cf4a2044290845b10ccddbaa306f29c808e7c5019700763e37e45ff6deb507b874a4348010fed50
+DIST coq-8.19.0.tar.gz 7674352 BLAKE2B 195040c01797ac9ce67611e0c96a4601e0a48966e094e868b9f3644aa9f75fa85adf0e2e6340a14ae0a0598b746f5ad989d8f10736cd2d3852a449f6f79d2c93 SHA512 02fb5b4fb575af79e092492cbec6dc0d15a1d74a07f827f657a72d4e6066532630e5a6d15be4acdb73314bd40b9a321f9ea0584e0ccfe51fd3a56353bd30db9b
EBUILD coq-8.17.1.ebuild 2317 BLAKE2B ff2958b7e82400115ab634dd00bac13df99ba088d8d2ec48ad61663ba0aa3690e3cad26badedad5fd12958df4c7a343b5c9d2d827a2a7aac3ba35e9ddfe3f222 SHA512 4c04bb4aa2d97dfa21868e6246d8a35d96b55e80c7bf6206ce1c67f46102c449cad25f7062c93c7defdb0e118be57c8f86d3c3323df53ce3c794617a7d4ed6d5
EBUILD coq-8.18.0.ebuild 2317 BLAKE2B 4bc94547c21f41a7edd33aae51eff50e7fd911394e185548e645c71b181e48810997bc38dd3fc50be290873a10122958802ad75479fd20fbdc15bec82b8c8d64 SHA512 16949a6e9140d280a7081237cc83a04a99f248fce57fe4f3eb7055cf2fdf22aed84d11caa52e7c4c344660f48552c72a5d13d659dac71e61b133e1259f4a239f
+EBUILD coq-8.19.0.ebuild 2493 BLAKE2B 277efc3bf5c38592e7729a7a2e46cd21a7b5a02934ab22e4c57c8da13b59dd63bc21552291efc88cd542debe7cb940f4f93ea5e2d51aae33bb3ccc32a1fd8b7a SHA512 4196e78ef5929e6ecf2381bb11b760ddb90e9a0be00a6ce30bd8feeec15adfcc7534178f306a23fc22871d37b7de7bdf8effb3dec19731ca77ae087c21ebe2b1
MISC metadata.xml 1047 BLAKE2B 9f6defdf213139ee6549bc8f3b36ce5e8f53ea73bd5aad9262932cbaea7e90bd97c9ffc9dbbd03ac50097c5a6f19f5ddf00dd2b74cc6a5349faf1b597244fb67 SHA512 0f5bfbdd9ffd6f64379e697ed7cf90c2d9257cd1815e520aa14235f1cb399d20fc863221a0cae803cc88e5975be964b9debc3d750a6378ea157146f2e567c5dc
diff --git a/sci-mathematics/coq/coq-8.19.0.ebuild b/sci-mathematics/coq/coq-8.19.0.ebuild
new file mode 100644
index 000000000000..33c2b23fecf7
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.19.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+inherit check-reqs desktop dune edo
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/
+ https://github.com/coq/coq/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gui +ocamlopt test"
+
+# TODO: Lots of failing tests. Maybe investigate later.
+# RESTRICT="!test? ( test )"
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/num:=
+ dev-ml/zarith:=
+ gui? (
+ >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
+ >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/findlib
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx-rtd-theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ media-fonts/freefont
+ )
+ test? (
+ dev-ml/ounit2
+ )
+"
+
+CHECKREQS_DISK_BUILD="2G"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+declare -a DUNE_PACKAGES
+
+src_prepare() {
+ # Remove failing tests. bug #904186
+ rm -r test-suite/coq-makefile/timing || die
+
+ default
+}
+
+src_configure() {
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ DUNE_PACKAGES=(
+ coq-core
+ coq-stdlib
+ coqide-server
+ coq
+ )
+ use gui && DUNE_PACKAGES+=( coqide )
+
+ emake clean
+
+ local -a myconf=(
+ -prefix /usr
+ -libdir "/usr/$(get_libdir)/coq"
+ -mandir /usr/share/man
+ -docdir "/usr/share/doc/${PF}"
+ -datadir /usr/share/coq
+ -configdir "/etc/xdg/${PN}"
+ -native-compiler "$(usex ocamlopt yes no)"
+ )
+ use debug && myconf+=( -debug )
+ edob sh ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake DUNEOPT="--display=short --profile release" VERBOSE=1 dunestrap
+
+ dune-compile "${DUNE_PACKAGES[@]}"
+
+ use doc && emake refman-html
+}
+
+src_install() {
+ dune-install "${DUNE_PACKAGES[@]}"
+
+ if use gui ; then
+ make_desktop_entry coqide "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ fi
+
+ local ocamlc_where
+ ocamlc_where="$(ocamlc -where)"
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ local sym
+ for sym in "${DUNE_PACKAGES[@]}" ; do
+ dosym "${ocamlc_where}/${sym}" "/usr/$(get_libdir)/${sym}"
+ done
+
+ einstalldocs
+}