summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /sci-mathematics
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin13494 -> 13486 bytes
-rw-r--r--sci-mathematics/fricas/Manifest2
-rw-r--r--sci-mathematics/fricas/fricas-1.3.7.ebuild110
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 55537cffa785..e912b8eb7857 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 82a650843c54..40944a2164bc 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,4 +1,6 @@
AUX 64fricas-gentoo.el 101 BLAKE2B 7d2499931132bd7bf32b528cbc6b09127af060b879ebea93421206f6f5fbe685b070624e507390902d7cfc7cd06a5988ca2df9959b2549736be912b731990c21 SHA512 be36ef5bfb525aa054cd3881ece83d47ee3a9cb7ef1b0c26215d449ddcad8f9f57045b29ab9063a62f43caa764abb251e5fcd04cf1d15bcc423e40d9e69239ef
DIST fricas-1.3.6-full.tar.bz2 10422732 BLAKE2B c406907bbd8be66104db0ba52cfb49740a54daa53cbcb5949c4a4f090c7c978e8a5d345988544d4e93219be8c66a4c50b586ce4d99f32f8d020b1f015fe94b76 SHA512 5732a9645a15886a14b5778c3b2bd813462693e67ef2cd807742b325edd1ac4c3edbd671e25cc568c20e0a01b82d09defdac0b9eb7e355355461316be29d631c
+DIST fricas-1.3.7-full.tar.bz2 38008318 BLAKE2B 079a0e2739c0f28c7fb76681e9562802cd7d6f16a0a0bcd8310bb11a6678b2aeabca9cc8effdf81d9464742bf4a20d07845f870717326afbd87feb48fe408493 SHA512 fd3742eb56c279adcdbae62a8eb5843781d0da4318f1b6e55310a9ac243c712b24fef214414c8d656b222be890ec4d9d30ad243b77b8eeaeea95e0ae3dda890a
EBUILD fricas-1.3.6.ebuild 2382 BLAKE2B 4ba66ac739fc94f37debc949d6fdb57f838ae664e1a832e8dd24fe14b0cc2457b9e0f6b835cdc92e9f4588c244099adf3b7c7a424d86d27b9354f09c60ead144 SHA512 0799eb9e8ce77b1c75d93fc38c0dddbfd63c93744b7bc1bb376145b556bf78e3b0e73d17f5e04cb8657c979188b211c113768d6def8eb3632d449226fdb39282
+EBUILD fricas-1.3.7.ebuild 2447 BLAKE2B a4c1076388669c9111d3b69b6ffd22912e9b8b7d5804476bfde79640adcc9f120ced193681adf9da61a0415f71cb50744358b8028d75ae956fce96984ddecb51 SHA512 1bc746d4b70581438919a80981fb4d7188672913f764dc86b32122d033dd87baa7266a422a442826aeae463247ccb661ed0cfddaf72ddeafd6b54f732684c526
MISC metadata.xml 1061 BLAKE2B 1ee57daa6a688657712b8a917ab1d70bcd67a944133a7b625c8446334c1be03eb2b0ca65bd7c3ef4a54c29e00e6d5767456cb5fe93a9c20c7cf83fdc0df53869 SHA512 7835f6ea9fb94e2ab1ff2385990487802b868418757fb9c701c3081c452ca543716fa4a45f6467ce11144587ea40daf2cccb76345fc428740c225142e7b32291
diff --git a/sci-mathematics/fricas/fricas-1.3.7.ebuild b/sci-mathematics/fricas/fricas-1.3.7.ebuild
new file mode 100644
index 000000000000..eefad5493a0a
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.3.7.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://fricas.sourceforge.net/
+ https://github.com/fricas/fricas
+ https://fricas.github.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
+# Version restrictions, . means no restrictions
+REST=( . . . . . . )
+# command name: . means just ${LISP}
+COMS=( . lisp . ecl . ccl )
+
+IUSE="${LISPS[*]} X emacs gmp"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gmp? ( dev-libs/gmp:= )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ if [ "${REST[$n]}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP="${REST[$n]}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
+done
+if [ "${REST[0]}" = "." ]; then
+ DEP="dev-lisp/${LISPS[0]}"
+else
+ DEP="${REST[0]}"
+fi
+RDEPEND="${RDEPEND} ${DEP}:="
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n GMP
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # bug #650788
+ if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README.rst FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}