summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
commit6bf575618cf9022e99cbfcc64036fd9db79a749c (patch)
treef692d02fb905cd3d5bab465b790da48fb2de546b /sci-mathematics
parent5944ce177026c93b7dab690db9d970567ddbf75f (diff)
gentoo auto-resync : 05:12:2023 - 17:02:58
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin18985 -> 18984 bytes
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.12.3.ebuild111
3 files changed, 113 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 46aa5469cfb0..53f93b34141e 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 8904972bac79..06f9f7e43c27 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,4 +1,6 @@
AUX z3-4.12.2-gcc-13.patch 317 BLAKE2B 2b8f6cc02b3a1d02b4266b483ef2a7ea108cb94c12a9cab76c304d039804df600547bfe6b72f22592d374d552d77b0c5b6c39069297f7c8f5cecf7be2ce6f584 SHA512 faa47330f0d9213127a05af0a23441ce60ae1a1535994ed627edacba9d5082550eeaeae3d88ad9066e6dc6b6a0078a340fb1adf1603cd51d786149e6b8c89f13
DIST z3-4.12.2.tar.gz 5401038 BLAKE2B e83bc4067360888da1be20dffbbd4b060118080e1f8a1b0424c169ad1aaaccf5ab645960418db7ce544829c7831da90edb0e38003d7a0261df699c9bd69ab1f0 SHA512 375477cbbc9837b44e752c89916409d07bf6a73830b52878aab4f376f08b37dd5ab485da225744d394ab15f2a7e1014edc3be5eb9962934c440a8d55259317e2
+DIST z3-4.12.3.tar.gz 5471745 BLAKE2B ce14a13a0af651b414cd164658b5953d5ea398201fc299e5073690caa9625b23ffbdce33a2f220f1420570b1b21ace6be48486c2c333251325b7acb5ca6e0d43 SHA512 06d667b86e2d941e8cbcafe508392f5ef9307354a97428107e26ac7ef86246a86a0096fbf92034f2a3e47efe41f95ddc74460c2c4797aadec79e14020737afcb
EBUILD z3-4.12.2.ebuild 2727 BLAKE2B d12f07d771f728b1df2d4c705af570e4319c3bcfd9df44e19c760929578c0e758bec89f5ad8334c02fe9333c4e36b40e2e7ecfaef432a5976d25cfc01e2cfaa6 SHA512 395631c014e4c3d406f7cf712d766537f8aa86f3db337e0a8e9c0ee804c509076ff4f9192043ea8b1e183ebb983c059b1ee34ad77e01e03a17485c16e3b10c66
+EBUILD z3-4.12.3.ebuild 2739 BLAKE2B df802f0abb7a4ea61d836dd77ddd795d07194ebb9d8c18cc084f6ba907a08c276d9604046635d17e0a14bcb9ad7f46eab6708890d5685e0de253b1879ae0a74b SHA512 c547766b7ce2c450e5048b8687b0584c85f4078f2e1206a1e8ebb45ef40adf6a6dc5bf3cc9ab585baf46aa3593b7fe2e8dbe5d560cb5712a86a2cbf5f63d5ef4
MISC metadata.xml 1800 BLAKE2B 26b4fd829e8daf66cfb19f61afffe9535099260732b3856c400881e68dbc4c2ffe88ff57f3a23449a2259696f23969c6502d4f3432b9cafc2e89e99167c94b90 SHA512 92f05bb1617630c16801ae5ea4215436c4d5dde6890d1a9e90c81f8ce1cddf101b73e016d1ec67eb41ccb4b59753547e6d08ac6a70a5b2d3dc792dc9fba13166
diff --git a/sci-mathematics/z3/z3-4.12.3.ebuild b/sci-mathematics/z3/z3-4.12.3.ebuild
new file mode 100644
index 000000000000..c3662f566d02
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.12.3.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake-multilib java-pkg-opt-2 python-single-r1
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/$(ver_cut 1-2)"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )
+"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ # https://github.com/Z3Prover/z3/pull/7042
+ sed -e 's:importlib_resources:importlib.resources:' \
+ -i scripts/update_api.py || die
+
+ cmake_src_prepare
+ java-pkg-opt-2_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}