summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
commit3fd9d065ab109700e92fc1cea2a6519a39a5b007 (patch)
tree2666118c9404e846180636fbd2de92e3bd7870fd /sci-mathematics
parent11c791ab62dc711840a52676eef212362840fc17 (diff)
gentoo auto-resync : 09:08:2022 - 02:15:09
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin16682 -> 16676 bytes
-rw-r--r--sci-mathematics/stp/Manifest2
-rw-r--r--sci-mathematics/stp/stp-2.3.3-r2.ebuild103
3 files changed, 104 insertions, 1 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 65dfbd464d9b..88110b83f339 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/stp/Manifest b/sci-mathematics/stp/Manifest
index 725f20c6f849..37f687826087 100644
--- a/sci-mathematics/stp/Manifest
+++ b/sci-mathematics/stp/Manifest
@@ -3,5 +3,5 @@ AUX stp-stp.py-library_path.patch 372 BLAKE2B 1e36f48d2c403cdea156157826a1b3c3e4
DIST stp-2.3.3.tar.gz 2577550 BLAKE2B 9ebedf3cb8e6b50d037cfacbc14826bd4e6505d29a53b1fcc6580749f0637fe5f96619c166babdb3a52b18fb6337e49c02f5693e233effe84d0131d0e7402381 SHA512 a0b1bf419d8230e40ce0aee90d9c8c9d814aca300831c24b3576c75623362942abf20673c419f9f0ea1e0505bfae000dc65fdd818179f5759879b0b255f1b99a
DIST stp-2.3.3_OutputCheck.tar.gz 12002 BLAKE2B f8fafba8f7957f3d0ee480b9e1e8c8923c373cf134512d6329adf84a96f3177ad07d00eae4dc6dd8d4b09ca82dfc8b425602f1926e3f88ccb2556b4b7121e5b9 SHA512 36012ae2b2aee1ff3f36ba1678a4bcbfeb590e01c2042ca35eb2f49b6a890b767c1809d1415e7b03f2118204361f834ad9caf70319b59fd14b2c140bf858d16e
DIST stp-2.3.3_gtest.tar.gz 469100 BLAKE2B 386444657d3f23e54f01dac8e0ac36da4d97c3eebcc8cf79bfc754c474a5ed64765a0ad389fef358667e468469c47d02a407e13e6882d426a4defb0102e4a758 SHA512 2fc79fe9c8a4e0487e7e76db9508fd2207df0cfe3940a51aeac32e4440afab9e265bfe553b1cd66086cd5a574d8bf99dbb9e1d9c4a70fafd7b31f38825914aa1
-EBUILD stp-2.3.3-r1.ebuild 2226 BLAKE2B 75dcdf8ac6b409bbfa046c9f89d1577be646f0246de3bf716b91559954be4ae8e80c1466a7f12021336c318c9e06c13b58fd6ff1b9bffacb005e5c4a18c9a03a SHA512 a92f8a0834c4e479050bf2b52efbcf75914b855f99d6b8217952ffe172a90e2abf7a08cfd879c15350eddb6d996051d30ef43a6a336aa1d2b8539761f462a703
+EBUILD stp-2.3.3-r2.ebuild 2488 BLAKE2B 123f264236f77e4d4bc6cc3464bd20c52037d7ec890b0f09a8eedc5d0a8004b56c9d0e291612d9c4cb8b23cdab44da0cd5018f996498a697bb0a80a1afeb687c SHA512 438e9aa6900d038d9b1cb54d25b53be292b06bb569ea2390641d4bef9dda5c213e1bc903d3a387047ad7477b9a4574840b9c18304b65052a19f56585ee6d45d5
MISC metadata.xml 1110 BLAKE2B e13b9420b7f730e6b9e2571e3f4e8a48cf7f54b16fa767fce48099549071c4c819e16a5da25b6779c77a5a7a7f21c3ec61eeb2719867f874a1c4fa21b84e32f2 SHA512 aa3ddfd8d3bf4647f230f0ca55b6f70f9f82f2ae63fe21edad637397fb1bd2779241a2e439a48bed59bd1de11ef3b4e275731c6a90873ec5d86bb5897bf2a9f0
diff --git a/sci-mathematics/stp/stp-2.3.3-r2.ebuild b/sci-mathematics/stp/stp-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..e59e4388c2c3
--- /dev/null
+++ b/sci-mathematics/stp/stp-2.3.3-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+OC_H=119fe41a83bc455a24a11ecc9b78e7b13fcfcc45
+GT_H=2ad076167a676e3ed62f90b754b30fac5caa1f88
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit flag-o-matic python-single-r1 cmake
+
+DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
+HOMEPAGE="https://stp.github.io/"
+SRC_URI="https://github.com/stp/stp/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? (
+ https://github.com/stp/OutputCheck/archive/${OC_H}.tar.gz -> ${P}_OutputCheck.tar.gz
+ https://github.com/stp/googletest/archive/${GT_H}.tar.gz -> ${P}_gtest.tar.gz
+ )"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cryptominisat debug +python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=
+ sci-mathematics/minisat:=
+ sys-libs/zlib:=
+ cryptominisat? (
+ dev-db/sqlite:3
+ dev-libs/icu:=
+ sci-mathematics/cryptominisat:=
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/lit )"
+
+PATCHES=(
+ "${FILESDIR}"/stp-CMakeLists.txt-fix_cflags.patch
+ "${FILESDIR}"/stp-stp.py-library_path.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ if use test ; then
+ local i
+ for i in OutputCheck gtest ; do
+ tar xf "${DISTDIR}"/${P}_${i}.tar.gz --strip-components=1 \
+ -C "${S}"/utils/${i} || die "failed to unpack ${i}"
+ done
+ fi
+}
+
+src_prepare() {
+ # Replace static lib with get_libdir
+ sed -i "s/set(LIBDIR lib/set(LIBDIR $(get_libdir)/" CMakeLists.txt || die
+
+ # Remove problematic test
+ rm "${S}"/tests/query-files/misc-tests/no-query.cvc || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # -Werror=odr warnings, bug #863263
+ filter-lto
+
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=(
+ -DNOCRYPTOMINISAT=$(usex cryptominisat 'OFF' 'ON') # double negation
+ -DENABLE_PYTHON_INTERFACE=$(usex python)
+ -DENABLE_ASSERTIONS=$(usex test)
+ -DENABLE_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # Because Python files for tests (in BUILD_DIR) and those installed on the
+ # system differ, and are generated upon install, we have to wait for CMake
+ # to install them into the temporary image.
+ use python && python_optimize "${D}/$(python_get_sitedir)"/stp
+
+ mv "${D}"/usr/man "${D}"/usr/share/man || die
+ dodoc -r papers
+}