summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-17 03:03:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-17 03:03:09 +0000
commit3455c0a5153ae27d7c6c16ecd35fa3dec33f3dda (patch)
treeb29c1fa32b8be70c36e7f8bf53ab5fca875037f9 /sci-mathematics
parentb0735771a80a647a2ea5a03a87d5873d175bd744 (diff)
gentoo auto-resync : 17:11:2024 - 03:03:09
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19327 -> 19656 bytes
-rw-r--r--sci-mathematics/clipper2/Manifest3
-rw-r--r--sci-mathematics/clipper2/clipper2-1.4.0.ebuild37
-rw-r--r--sci-mathematics/clipper2/metadata.xml15
-rw-r--r--sci-mathematics/manifold/Manifest3
-rw-r--r--sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild68
-rw-r--r--sci-mathematics/manifold/metadata.xml15
7 files changed, 141 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 9833acfa1795..e553be480c35 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/clipper2/Manifest b/sci-mathematics/clipper2/Manifest
new file mode 100644
index 000000000000..31147c26cf6d
--- /dev/null
+++ b/sci-mathematics/clipper2/Manifest
@@ -0,0 +1,3 @@
+DIST Clipper2_1.4.0.tar.gz 600352 BLAKE2B 0ba268ba691fde4aef456d8f6ef1810a8c13b77c5bb932296b11b5f0d96dfe70f2d617d7ba013f85817dbc01a800d0ab1fba566e4ab56efde6541c00f3d7f359 SHA512 91036e81244f3615095d7cd8522f9c4a32ea66f802e3d190393eb8939e1a706b69c69c3a5b7c6522235c075dd6ecd45f21bffb47448ba72191ddcf05e9e93128
+EBUILD clipper2-1.4.0.ebuild 767 BLAKE2B 073c039e51f65a0519fb7274100d756f9335e03f63ceec0391bf7398b82b5a026d83aa0bb40625486d56f8c908439a1a4d8105a21e37d33ebf44eb5df7105b6a SHA512 be701925856a8fed72343c5658c2be46142a2bebbedafba14dd901ac3879c6915626a2c5628519b4628f3a94ac63fc0a22ca00d72df621e36594961f0bb60c22
+MISC metadata.xml 487 BLAKE2B 0914f10e0aae0ed231b6a07da3291775df85d15dc34d2d53b529bd5f568ba56dec27bf579174f8a059ed33ae1242f668e3ba66339e455954a92bf97f4f1a3b74 SHA512 465860959c93d04cfdd01569495f33925c728cf31bbb44fa2d281f8fcca69ceb08d5bc8b3f4b207dd5dcbc1541c82b4efd67ae23167fcc4b2aead77ca2c04ab7
diff --git a/sci-mathematics/clipper2/clipper2-1.4.0.ebuild b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
new file mode 100644
index 000000000000..ab2d3bf1ad9c
--- /dev/null
+++ b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="Clipper2"
+MY_P=${MY_PN}_${PV}
+
+inherit cmake
+
+DESCRIPTION="Polygon Clipping and Offsetting"
+HOMEPAGE="https://www.angusj.com/clipper2/Docs/Overview.htm"
+SRC_URI="https://github.com/AngusJohnson/Clipper2/archive/refs/tags/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}/CPP"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLIPPER2_UTILS="no"
+ -DCLIPPER2_EXAMPLES="no"
+ -DCLIPPER2_TESTS="$(usex test)"
+ -DCLIPPER2_USINGZ="no" # manifold src/third_party/CMakeLists.txt
+
+ -DUSE_EXTERNAL_GTEST="yes"
+ )
+ cmake_src_configure
+}
diff --git a/sci-mathematics/clipper2/metadata.xml b/sci-mathematics/clipper2/metadata.xml
new file mode 100644
index 000000000000..fda0c60d4c9e
--- /dev/null
+++ b/sci-mathematics/clipper2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>negril.nx+gentoo@gmail.com</email>
+ <name>Paul Zander</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AngusJohnson/Clipper2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/manifold/Manifest b/sci-mathematics/manifold/Manifest
new file mode 100644
index 000000000000..14d1445cd7f1
--- /dev/null
+++ b/sci-mathematics/manifold/Manifest
@@ -0,0 +1,3 @@
+DIST manifold-3.0.0_pre20241115.tar.gz 29143605 BLAKE2B 84c3e4c98a9279187660f31e4010097de431472412f2591943c99195edad9f700115df4b362d968b95e3ee136c699eecf2dc9845001019f71e9cf7b0cbca4d0e SHA512 bae671d190d8fbfc0ee12989a73a38d7d0ddf0e0081db8f56a446c09998e24f43828d70731f97d6948599f31ef6734f86183debc09f4cec07983af317ce0dba8
+EBUILD manifold-3.0.0_pre20241115.ebuild 1387 BLAKE2B f822a6bfb3f185238933ec6155531fd583415173a787f0fbd7520138640e9398eb802d267084eebb0cc7006ee61d38e5558a3c197d34c31fd8ae89c8eadc6f21 SHA512 5f20b574f3deee938922ec6bb692a889ad010b06f168cbcca157ae0b0e0001288eac2a74b5e0b3f9e615c875816cc27f29611242cf569486c91d05d261106aae
+MISC metadata.xml 482 BLAKE2B a1ed362e614bdc51ee074bdc98f70484d0131cd2618e5d0c59292cc8916f62bee96510b811f96916dcf1685bab2ea5eb88ede1ee99304b35644d6f96089b69cf SHA512 b4f7d4e3a3905f6b6c9895cabb971829c1e6cf7635f0a3158233a987a1dc37e931a7652ff27a0ddc72fd83d28a8834f939cec4045a9f276841a7346cbd4bf136
diff --git a/sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild b/sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild
new file mode 100644
index 000000000000..3e6c99c118e9
--- /dev/null
+++ b/sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=e7e0780114881dcf6e5ad934323f2595966865f9
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-single-r1
+
+DESCRIPTION="Geometry library for topological robustness"
+HOMEPAGE="https://github.com/elalish/manifold"
+SRC_URI="https://github.com/elalish/manifold/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ sci-mathematics/clipper2
+ python? ( ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-python/nanobind-2.1.0[${PYTHON_USEDEP}]
+ ')
+ )
+ test? ( dev-cpp/gtest )
+ ${RDEPEND}
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed \
+ -e "/list(APPEND MANIFOLD_FLAGS/s/^/# DONOTSET /" \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANIFOLD_CROSS_SECTION="yes"
+ -DMANIFOLD_DEBUG="$(usex debug)"
+ -DMANIFOLD_DOWNLOADS="no"
+ -DMANIFOLD_EXPORT="no"
+ -DMANIFOLD_JSBIND="no"
+ -DMANIFOLD_PAR="no"
+ -DMANIFOLD_PYBIND="$(usex python)"
+ -DMANIFOLD_TEST="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}/test/manifold_test" || die
+}
diff --git a/sci-mathematics/manifold/metadata.xml b/sci-mathematics/manifold/metadata.xml
new file mode 100644
index 000000000000..7a2cd57d4d26
--- /dev/null
+++ b/sci-mathematics/manifold/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>negril.nx+gentoo@gmail.com</email>
+ <name>Paul Zander</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">elalish/manifold</remote-id>
+ </upstream>
+</pkgmetadata>