summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-17 02:02:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-17 02:02:20 +0000
commit2f50f3ca1d346a1f74054f124adb11136068b2b1 (patch)
tree10b9920e8655629b9153b171f314ed189fce6578 /sci-mathematics
parente07c6f9648d478943b5ecd6f1c42cc91cae0f547 (diff)
gentoo auto-resync : 17:12:2024 - 02:02:19
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19676 -> 19674 bytes
-rw-r--r--sci-mathematics/gmp-ecm/Manifest2
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild65
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index a0f2641a23b4..0ae5daee5bc1 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/gmp-ecm/Manifest b/sci-mathematics/gmp-ecm/Manifest
index 816489661240..035fff077e54 100644
--- a/sci-mathematics/gmp-ecm/Manifest
+++ b/sci-mathematics/gmp-ecm/Manifest
@@ -1,3 +1,5 @@
DIST ecm-7.0.5.tar.gz 1159568 BLAKE2B 7fb8d78a6bc8423c9890b9d6e334f8c4317b68cde7d712c5306775c6f07eacb3cbbbd11d651bbbdd687a87692f4920170557b51f9498881a6c5018a2ce0b1b7f SHA512 f5a482a231339304683adc3334c9b86f21a0d9b42ea871418d4c01005057d560cd418eddfcc1c7be7f8c249960b2ee612a1454ccc5d8e41319b06c6f42e6662e
+DIST gmp-ecm-7.0.6.tar.bz2 609323 BLAKE2B 30255322bd8e8d49393044bcc55fd05905cb5b6b374c5f2ea59fa9b02864b22fc2b6f14fda2271a4148a2ec361fd524551cafd136bbbdf025137ce101c776def SHA512 7ad262e78c59d33218e1d783ffa79114c04fe4ddac57e4059577aecebbfe3af975c2e1ba6049452c1c96488660ed79fcb546237966489fc2edc03bf7710495c0
EBUILD gmp-ecm-7.0.5-r1.ebuild 1583 BLAKE2B a26660813145878658cfe888f320dfde424a3f112d558c4d2b6a29ad69d0cb7f126cf871b5145b9cb4e9c4ab972ad31ee54cc063177220b11ce91d643a37b310 SHA512 8dd5647f4a25fbd5f3d79c11925fc3b6ce56d54e0f4d76b5e8033cf4c6aa73799798b36bbab38c2363f154f5c34891e3870e1bab39b1bf7c523afaec2a0e95ea
+EBUILD gmp-ecm-7.0.6.ebuild 1649 BLAKE2B 6891fb0bfbb1c64f43d3bffeb8e1931e94d8b92a667a9d6d9eb7b9bbe4b39499372662149ca9fad9613cecdf6ffd3211c5ca61b761007b6b932fc26566e8e194 SHA512 f610819af09d78029762645f20a0db8873fb39d0f70a0e4f98e03196e3479a73d4d5991341fc8c93ccc16ac76de9bfaddba7a35f1d8da4594a8fdd884d9626db
MISC metadata.xml 643 BLAKE2B 90da8b09f30dd8bd8d4df3dcc388663e52d57ea7b2974becede9ed0c592eaacb33958d202cee33988b79364e058ef84676e995b9d8467beb1f7d89ad8b177136 SHA512 e2f0d6f286440543ed15531183671b30f0044c38685e58617d004286b596ba1b898c470dc39e2ebe95db10c83be9430f1a010539ba2b0231883fe6bf4b0b97a8
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild
new file mode 100644
index 000000000000..b8b236d35862
--- /dev/null
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs autotools
+
+MY_PN="ecm"
+MY_P="${MY_PN}-git-${PV}"
+DESCRIPTION="Elliptic Curve Method for Integer Factorization"
+HOMEPAGE="https://gitlab.inria.fr/zimmerma/ecm"
+SRC_URI="https://gitlab.inria.fr/zimmerma/ecm/-/archive/git-${PV}/${MY_PN}-git-${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv ~x86 ~ppc-macos ~x64-macos"
+IUSE="+custom-tune openmp cpu_flags_x86_sse2"
+
+DEPEND="dev-libs/gmp:="
+RDEPEND="${DEPEND}"
+
+# xsltproc is used to produce the manppage in combination with the
+# appropriate stylesheet
+BDEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_compile() {
+ default
+ if use custom-tune; then
+ # One "emake" was needed to build the library. Now we can find
+ # the best set of parameters, and then run "emake" one more time
+ # to rebuild the library with the custom parameters. See the
+ # project's README or INSTALL-ecm. The build targets don't depend
+ # on ecm-params.h, so we need to "make clean" to force a rebuild.
+ emake ecm-params && emake clean && emake
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable openmp) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable custom-tune asm-redc)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}