summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
commit145b1805c3986974378af5c60767504ecc9ed280 (patch)
tree28dbd5be73a5af5dd20d4ea81d293394d975c9e0 /sci-mathematics
parent627302fc2f41a621644260ffa3f50e06ea5edd60 (diff)
gentoo auto-resync : 10:12:2023 - 23:14:40
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin18985 -> 18990 bytes
-rw-r--r--sci-mathematics/proverif/Manifest2
-rw-r--r--sci-mathematics/proverif/proverif-2.05.ebuild66
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 78dacafd9345..2fc6749e1981 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/proverif/Manifest b/sci-mathematics/proverif/Manifest
index 58872446201a..aee10192a859 100644
--- a/sci-mathematics/proverif/Manifest
+++ b/sci-mathematics/proverif/Manifest
@@ -1,5 +1,7 @@
AUX 50proverif-gentoo.el 650 BLAKE2B d31acd5c6aeeb2b938b0a475c896f0345149abc500bc98e889a89b2b241b8e59890544b64997eb7f029fe048de3fc696a2290bf1a707d9898b166458065f4d22 SHA512 44e6058ffc609a6475b21350148d677dfc0cd8846b7441541ed33b9f10bc789c4f1177ad517e684cc19f9e1ac34066a023cb003197be8c376f3c3cf99e7ff937
DIST proverif-v2.04.tar.bz2 61001112 BLAKE2B 03364d315bfa3d6cc8dfb68819be6b92301f554cf7ae4db0c4b9d8190a7d7576b79295dd536bf1356e12679028c100e6040d8c4e4299cf137c15114caf0216d2 SHA512 dbfafa62f4df72044b05563e10219b034ad49dd972598bf72eba616f2a88ff1cb85c3ee7bb9235050d0f35dbde750bffddbc93897b9ca2101dc6d153d3ea5575
+DIST proverif2.05.tar.gz 980879 BLAKE2B 738531d34249f1837a93c6897d7249e326213940cc9a8fc378a25912a4de4c122a6ce536a429f17c1ef7fae5dd5e1673cdf439d7bad2dd0f44826b33363dbc8a SHA512 e20d6dc40b0e4957590b9ce019ef654361f3514f53e0a5c3240a40d296ff2a50093630982b7a230c2277eadf4ed22ba1b6d09b48764c2ad3ec0e102033d1c486
EBUILD proverif-2.04-r1.ebuild 1215 BLAKE2B 96842c9a3971326e7dbe1d49060a0bd6f1449375b0a4054153ad23922978084711b78f4a595cc578b2a6015ea7e6a0da128917e36f3d784cdcf07adba7d03475 SHA512 bb68fb16e894a32ad8d1071b63fcd98b2697e2cc2745dd843dc66f7c3cfe45d00a1f6c393d0a86c576fc97f430a465e26c68b9029fdfcf644132667a2a9d15ca
+EBUILD proverif-2.05.ebuild 1174 BLAKE2B 7e95f21b988e317904788248ca5168906340cccdac9a0f9770fca259dcdd8309aea203a34afaeb2db4dc29ecf44fe087df8ddaef552c3faa22a07e78bdfa0bef SHA512 eebed22d18d52f3337ab4ca8cbcf23fc67591a68bd5e61e5455e5c1b5bd4452a5eb395f50ebc2194f7068d263f69a759c183209601ca2e08b8371ae6c948d247
EBUILD proverif-9999.ebuild 1215 BLAKE2B 96842c9a3971326e7dbe1d49060a0bd6f1449375b0a4054153ad23922978084711b78f4a595cc578b2a6015ea7e6a0da128917e36f3d784cdcf07adba7d03475 SHA512 bb68fb16e894a32ad8d1071b63fcd98b2697e2cc2745dd843dc66f7c3cfe45d00a1f6c393d0a86c576fc97f430a465e26c68b9029fdfcf644132667a2a9d15ca
MISC metadata.xml 1638 BLAKE2B 61f7bbf62117942baa127c9cabb9f15ea797b8ea8b313ed720a15a6d96dba1e78e8ad9921739a277175eb008b8c697bdd4b424f472e984d9a01ee63e75ced6f2 SHA512 9bbd77f4247eb5c210e0f1424100541b16235701dc048c2a7ca1485fcdbcbf5a5ab598c8f5a11e234c77f74560e2312f4496af598f07cb504561f60acc2558f9
diff --git a/sci-mathematics/proverif/proverif-2.05.ebuild b/sci-mathematics/proverif/proverif-2.05.ebuild
new file mode 100644
index 000000000000..3a6c80ee509e
--- /dev/null
+++ b/sci-mathematics/proverif/proverif-2.05.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo elisp-common findlib
+
+DESCRIPTION="Cryptographic protocol verifier in the formal model"
+HOMEPAGE="https://bblanche.gitlabpages.inria.fr/proverif/
+ https://gitlab.inria.fr/bblanche/proverif/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.inria.fr/bblanche/${PN}.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://bblanche.gitlabpages.inria.fr/proverif/${PN}${PV}.tar.gz"
+ S="${WORKDIR}/${PN}${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="emacs"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ emacs? ( >=app-editors/emacs-25:* )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES README )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edob sh ./build -nointeract
+
+ if use emacs ; then
+ cd "${S}/emacs" || die
+
+ elisp-compile *.el
+ fi
+}
+
+src_test() {
+ edob sh ./test
+}
+
+src_install() {
+ findlib_src_preinst
+
+ exeinto /usr/bin
+ doexe proverif
+ doexe proveriftotex
+
+ if use emacs ; then
+ elisp-install "${PN}" "${S}/emacs"/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ einstalldocs
+}