summaryrefslogtreecommitdiff
path: root/sci-mathematics/yafu/yafu-1.34.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-mathematics/yafu/yafu-1.34.3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-mathematics/yafu/yafu-1.34.3.ebuild')
-rw-r--r--sci-mathematics/yafu/yafu-1.34.3.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sci-mathematics/yafu/yafu-1.34.3.ebuild b/sci-mathematics/yafu/yafu-1.34.3.ebuild
deleted file mode 100644
index e48b2e4b2059..000000000000
--- a/sci-mathematics/yafu/yafu-1.34.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-MY_PV="$(ver_cut 1-2)"
-DESCRIPTION="Yet another factoring utility"
-HOMEPAGE="https://sourceforge.net/projects/yafu/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PV}/${PN}-${MY_PV}-src.zip"
-
-SLOT="0"
-LICENSE="public-domain"
-KEYWORDS="~amd64 ~x86"
-IUSE="+sieve"
-
-DEPEND="
- dev-libs/gmp:0=
- sci-mathematics/gmp-ecm
- sieve? (
- sci-mathematics/ggnfs
- sci-mathematics/msieve
- )"
-RDEPEND="${DEPEND}"
-BDEPEND="app-arch/unzip"
-
-PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
-
-src_prepare() {
- default
- sed -i \
- -e 's:../gmp/include:gmp:' \
- -e 's:../gmp-ecm/include:gmp-ecm:' \
- -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' \
- -e 's:CFLAGS = -g:#CFLAGS = -g:' \
- -e '/$(LIBS)$/s:$(CC):$(CC) $(LDFLAGS):g' Makefile || die
- sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die
-
- # proper ggnfs default path
- sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die
-}
-
-src_configure() {
- append-cflags -fcommon
- default
-}
-
-src_compile() {
- local VAR
- use sieve && VAR="NFS=1"
- use amd64 && emake $VAR x86_64
- use x86 && emake $VAR x86
-}
-
-src_install() {
- dobin "${S}"/yafu
- dodoc docfile.txt README yafu.ini
-}