summaryrefslogtreecommitdiff
path: root/sci-mathematics/vampire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 20:51:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 20:51:24 +0100
commitfceabcd48faf4c890719a14ac4ed93b6b7993364 (patch)
tree509e41dc22637aa99b763e5fc14944d8e235c304 /sci-mathematics/vampire
parent674b648c65d37f018cecade7f66ab3162ed94a8e (diff)
gentoo auto-resync : 23:07:2022 - 20:51:24
Diffstat (limited to 'sci-mathematics/vampire')
-rw-r--r--sci-mathematics/vampire/Manifest4
-rw-r--r--sci-mathematics/vampire/vampire-4.6.1-r1.ebuild (renamed from sci-mathematics/vampire/vampire-4.6.1.ebuild)4
-rw-r--r--sci-mathematics/vampire/vampire-4.7.ebuild57
3 files changed, 62 insertions, 3 deletions
diff --git a/sci-mathematics/vampire/Manifest b/sci-mathematics/vampire/Manifest
index a15cc4e1c5b1..2b29ee9ef592 100644
--- a/sci-mathematics/vampire/Manifest
+++ b/sci-mathematics/vampire/Manifest
@@ -1,3 +1,5 @@
DIST vampire-4.6.1.tar.gz 1511760 BLAKE2B 52ede8ac009379b15bc57b2ffe45965cbaf772f0e90bc619d859b85b77ce81eadbdd7ddae7c5e0e9cc69564a07f0abefa17109f7192e6afe634a5a929817fe92 SHA512 7ffeee64e9e4666344c0f9155c7e980920666813388416062cee89e43003fef5a8a54b8656cc42d2fa58b6fb3b87ef7f2c671bfc6787075df4058dcc3a1d46e1
-EBUILD vampire-4.6.1.ebuild 1172 BLAKE2B 7dd2f6e829b0b0d827898f9e8fad4bb7b0419200a5a464d4cfd1494e930d4d89c99e1cfc331e2ef71d20fc7525483cd72d390466b8c6e611c5713b66fcdd5e15 SHA512 628f41b3193f6892e3e012aca9d337975e45320e7cd9921c95263ede37518fab08bf9a83c537cd7571247a1a1135af569c4be41158f488c041c629d9416e637f
+DIST vampire-4.7.tar.gz 1462358 BLAKE2B 10fdf4076bbcd7113da575d19890634a5142dd6917c028eb7ae0e94405df9e6915fc6127956d39b6f9f97242958b0fa04fa9e835853f09cec381786862009ef5 SHA512 978169a9b4d561dce1d55aa9a61a8b302657ff758036309d9c5f58a5d9271b874ac020d110fbb2a16d34f2ccdd10a497eb469829c91d58530dba5e1cd8978d78
+EBUILD vampire-4.6.1-r1.ebuild 1178 BLAKE2B 3c228c11fbf949144a453b9bef1545c149c52db79ee54b2ca1c42e8d8365e0da89b6f6c6ef3cac6b6180ba75b44fb0d1df7a2df7d5f20b4727192260a8c2fbc7 SHA512 a38bfddff1a2a69b65e927ff6d7cf68edf8ba5cfe621a6565317d925bf96d5620decd781c7ec23b1f88954043a793a2ea31176e7df9802b39cfdd93d187f787f
+EBUILD vampire-4.7.ebuild 1266 BLAKE2B 1355a5f6734f3e812c9f47d0ab044ebd5164c4ae6983be34ae33b0aed102306cc50062e2cc7b9d1921b03f939328e46356f3571875a51c83f5842dcc0e34f770 SHA512 69277d39e0e8a77cff1f3c72a23997367981bba9622abbe5308fc5bf6f5712c2a8b4c4ba26bca9b2045f5fe90942af18d9e26a15839fc74a0e3c58f9b2298a55
MISC metadata.xml 1020 BLAKE2B 6e798243e207d09fac240c73cda8918b300706a19d53918b3ce78e847146ad3676a39d9be8e020b678c20d7fe02da0eab57519ea2c5841eeeea0b8a680045928 SHA512 dc82a586070c97db278ef17a24384436548b2a968d18ead7d148f654bab4ad846e685ac2ae2f7db8048b25115b673bcf8223fa2813b370f9d6b6ac01dcf9040e
diff --git a/sci-mathematics/vampire/vampire-4.6.1.ebuild b/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
index 6c99ffab7e31..2f7ceabc3b2c 100644
--- a/sci-mathematics/vampire/vampire-4.6.1.ebuild
+++ b/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ RESTRICT="!debug? ( test )"
RDEPEND="
z3? (
dev-libs/gmp:=
- sci-mathematics/z3:=
+ <sci-mathematics/z3-4.10:=
)
"
DEPEND="${RDEPEND}"
diff --git a/sci-mathematics/vampire/vampire-4.7.ebuild b/sci-mathematics/vampire/vampire-4.7.ebuild
new file mode 100644
index 000000000000..bd33eda2b980
--- /dev/null
+++ b/sci-mathematics/vampire/vampire-4.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=2d02e4655e1b08d1ca9ee7c0aade40f59f046460 # "bump to 4.7"
+
+inherit cmake
+
+DESCRIPTION="The Vampire Prover, theorem prover for first-order logic"
+HOMEPAGE="https://vprover.github.io"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vprover/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/vprover/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="debug +z3"
+# debug mode needs to be enabled for tests
+# https://github.com/vprover/vampire/blob/8197e1d2d86a0b276b5fcb6c02d8122f66b7277e/CMakeLists.txt#L38
+RESTRICT="!debug? ( test )"
+
+RDEPEND="
+ z3? (
+ dev-libs/gmp:=
+ <sci-mathematics/z3-4.10:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=( -DZ3_DIR=$(usex z3 "/usr/$(get_libdir)/cmake/z3/" "") )
+ cmake_src_configure
+}
+
+src_install() {
+ local bin_name=$(find "${BUILD_DIR}"/bin/ -type f -name "${PN}*")
+ dobin "${bin_name}"
+ dosym $(basename "${bin_name}") /usr/bin/${PN}
+
+ einstalldocs
+}