summaryrefslogtreecommitdiff
path: root/sci-mathematics/vampire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sci-mathematics/vampire
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sci-mathematics/vampire')
-rw-r--r--sci-mathematics/vampire/Manifest3
-rw-r--r--sci-mathematics/vampire/metadata.xml25
-rw-r--r--sci-mathematics/vampire/vampire-4.6.1.ebuild53
3 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/vampire/Manifest b/sci-mathematics/vampire/Manifest
new file mode 100644
index 000000000000..4d3c9fa18d67
--- /dev/null
+++ b/sci-mathematics/vampire/Manifest
@@ -0,0 +1,3 @@
+DIST vampire-4.6.1.tar.gz 1511760 BLAKE2B 52ede8ac009379b15bc57b2ffe45965cbaf772f0e90bc619d859b85b77ce81eadbdd7ddae7c5e0e9cc69564a07f0abefa17109f7192e6afe634a5a929817fe92 SHA512 7ffeee64e9e4666344c0f9155c7e980920666813388416062cee89e43003fef5a8a54b8656cc42d2fa58b6fb3b87ef7f2c671bfc6787075df4058dcc3a1d46e1
+EBUILD vampire-4.6.1.ebuild 1172 BLAKE2B 7dd2f6e829b0b0d827898f9e8fad4bb7b0419200a5a464d4cfd1494e930d4d89c99e1cfc331e2ef71d20fc7525483cd72d390466b8c6e611c5713b66fcdd5e15 SHA512 628f41b3193f6892e3e012aca9d337975e45320e7cd9921c95263ede37518fab08bf9a83c537cd7571247a1a1135af569c4be41158f488c041c629d9416e637f
+MISC metadata.xml 993 BLAKE2B ac21215fc29f278d2678c39b250e1be3b765f0ed6896445de16e47d79467ca8b40a3f5b06d7b03bf206b82301ba6e26cd35767c82f10910b47adb447410f728d SHA512 f274deb71f13832f5809017e993c58c691e28efb6e30d413d0b5af496feb4c97e638dd56df4fc9f615dd02137dd287228c9b4150326145553c83bd39f7112334
diff --git a/sci-mathematics/vampire/metadata.xml b/sci-mathematics/vampire/metadata.xml
new file mode 100644
index 000000000000..4785a01c9b05
--- /dev/null
+++ b/sci-mathematics/vampire/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Vampire is a theorem prover, that is, a system able to prove theorems —
+ although now it can do much more! Its main focus is in proving theorems in
+ first-order logic but it can also prove non-theorems and build finite
+ models, as well as reasoning in combinations of theories, such as
+ arithmetic, arrays, and datatypes, and with higher-order logic.
+ The development of Vampire began in 1994 and has survived a number of
+ rewritings.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/vprover/vampire/issues/</bugs-to>
+ <remote-id type="github">vprover/vampire</remote-id>
+ </upstream>
+ <use>
+ <flag name="z3">Enable support for <pkg>sci-mathematics/z3</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-mathematics/vampire/vampire-4.6.1.ebuild b/sci-mathematics/vampire/vampire-4.6.1.ebuild
new file mode 100644
index 000000000000..6c99ffab7e31
--- /dev/null
+++ b/sci-mathematics/vampire/vampire-4.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The Vampire Prover, theorem prover for first-order logic"
+HOMEPAGE="https://vprover.github.io"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vprover/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/vprover/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="debug +z3"
+# debug mode needs to be enabled for tests
+# https://github.com/vprover/vampire/blob/8197e1d2d86a0b276b5fcb6c02d8122f66b7277e/CMakeLists.txt#L38
+RESTRICT="!debug? ( test )"
+
+RDEPEND="
+ z3? (
+ dev-libs/gmp:=
+ sci-mathematics/z3:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=( -DZ3_DIR=$(usex z3 "/usr/$(get_libdir)/cmake/z3/" "") )
+ cmake_src_configure
+}
+
+src_install() {
+ local bin_name=$(find "${BUILD_DIR}"/bin/ -type f -name "${PN}*")
+ dobin "${bin_name}"
+ dosym $(basename "${bin_name}") /usr/bin/${PN}
+
+ einstalldocs
+}