summaryrefslogtreecommitdiff
path: root/sci-mathematics/stp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-mathematics/stp/files
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-mathematics/stp/files')
-rw-r--r--sci-mathematics/stp/files/stp-CMakeLists.txt-fix_cflags.patch21
-rw-r--r--sci-mathematics/stp/files/stp-stp.py-library_path.patch15
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/stp/files/stp-CMakeLists.txt-fix_cflags.patch b/sci-mathematics/stp/files/stp-CMakeLists.txt-fix_cflags.patch
new file mode 100644
index 000000000000..93817e209376
--- /dev/null
+++ b/sci-mathematics/stp/files/stp-CMakeLists.txt-fix_cflags.patch
@@ -0,0 +1,21 @@
+index f6224a6..8c7c45e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -203,17 +203,9 @@ if (NOT MSVC)
+ add_compile_options( -g)
+ add_compile_options( -pthread )
+
+- add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-O2>")
+-
+- add_compile_options("$<$<CONFIG:RELEASE>:-O2>")
+ add_compile_options("$<$<CONFIG:RELEASE>:-g0>")
+
+ add_compile_options("$<$<CONFIG:DEBUG>:-O0>")
+-
+- if(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
+- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -O2")
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -O2")
+- endif()
+ else()
+ # see https://msdn.microsoft.com/en-us/library/fwkeyyhe.aspx for details
+ # /ZI = include debug info
diff --git a/sci-mathematics/stp/files/stp-stp.py-library_path.patch b/sci-mathematics/stp/files/stp-stp.py-library_path.patch
new file mode 100644
index 000000000000..60b54aa2c1da
--- /dev/null
+++ b/sci-mathematics/stp/files/stp-stp.py-library_path.patch
@@ -0,0 +1,15 @@
+index 61aef6d..16633e8 100644
+--- a/bindings/python/stp/stp.py.in
++++ b/bindings/python/stp/stp.py.in
+@@ -42,7 +42,10 @@ Py3 = sys.version_info >= (3, 0, 0)
+ if Py3:
+ long = int
+
+-from library_path import PATHS
++try:
++ from .library_path import PATHS
++except ImportError:
++ from library_path import PATHS
+
+ for path in PATHS:
+ if not os.path.exists(path):