summaryrefslogtreecommitdiff
path: root/sci-mathematics/spin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /sci-mathematics/spin
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/Manifest3
-rw-r--r--sci-mathematics/spin/files/spin-6.5.2-nesting_limit.patch55
-rw-r--r--sci-mathematics/spin/spin-6.5.2-r1.ebuild (renamed from sci-mathematics/spin/spin-6.5.2.ebuild)3
3 files changed, 59 insertions, 2 deletions
diff --git a/sci-mathematics/spin/Manifest b/sci-mathematics/spin/Manifest
index f55709e26d98..0aa27ce2cfe8 100644
--- a/sci-mathematics/spin/Manifest
+++ b/sci-mathematics/spin/Manifest
@@ -1,4 +1,5 @@
AUX spin-6.5.2-makefile.patch 320 BLAKE2B d88604300a9a1c7f16339e9c9c0ba96f79e3a0d08f041eba6c623d8e1d62d4a247f0ad6e06e83816a011ba072bfb7bd6afe39df796cfb1b80ad514e6cab33e76 SHA512 89166f068ab54c99c55029c7d936db663335e99c6e884b9885fe0478bb211bc186d32302ce933bd8e597bb78c72f2a0d016c8e661095a58761d437b89914c573
+AUX spin-6.5.2-nesting_limit.patch 1755 BLAKE2B 8c7b54262492dfc399bfbd90383a801375f4a6c6d7604f2f17841285b3ffb2ef32db67a02bdf4bee3b71633b436e057d4e0d6594c1a545ee7278c578546fb563 SHA512 dd92d130c61698d44c88e13ff8b744f3412dd5940e37c0c5e971889644e5482fcac1b0483e8dae0b6197749828a8dbdf74a5402fc2e8fb7dd88876199e02832a
DIST spin-6.5.2.tar.gz 6084903 BLAKE2B a075043c55609de5860c3a428d356a9618a4062667e06d92797e1fb87cb4c805ac90ac580c7d9dfac1d5be1dda4c7f9c9f72927826b921c23710a858adb3eb4d SHA512 ff1d378076995fa5a8b66dd31d19d8bad6296b968183180251d267c926c20775edda927a31f466199e01231f6233c3a5166fd51ec44b02d570070e857d8ba7f9
-EBUILD spin-6.5.2.ebuild 1055 BLAKE2B 577a87309cad0970b307d592f69a83c187e81ec74e409aa007321a88c57a0740641739a0bc3676241766697d723aa227000ddb86b5cd3a8e7699dd0e43cf0f95 SHA512 0e55d1c692d58e9f9a35ee529d550fab597438215921c0252146541e18f8cfa186943ce656be5a46d043466408746a3ebdd921ecb6f88ebf8ad77272b28ec919
+EBUILD spin-6.5.2-r1.ebuild 1102 BLAKE2B b71ca487a6d3c75d9522d2f3c9cfee41b5de4fa721cd8466bd408b36332e445b8aa23b6038c8751d90a3a681a2697d7c3467d023b30e193eeb2a85c5f9051f86 SHA512 462f90050a0fda2451e8e4f1bd1486270a8082b8491dc221921ca7b3d7f37ba7c165992cc2ad30663aadca4838b8546e1003646d57bfbb66d33e5cb59d434f1e
MISC metadata.xml 327 BLAKE2B 1b6a2bbece4fff801301d1bc5b86ebea4fe32096f1fb76d24831bd299608d73116261733e1318cf76532a336c467b394655157145ba565e256626ca66bf191be SHA512 5baaef50807b13c5a3e63d394a0df2b75ecb7973d1467d918329b55536ff6280da086311ee56bcff9fc156f377f077916d572f3cf8a1756d959b4bdb70b55ae8
diff --git a/sci-mathematics/spin/files/spin-6.5.2-nesting_limit.patch b/sci-mathematics/spin/files/spin-6.5.2-nesting_limit.patch
new file mode 100644
index 000000000000..c73152e8485c
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-6.5.2-nesting_limit.patch
@@ -0,0 +1,55 @@
+Backported upstream changes to address CVE-2021-46168.
+
+From 62cf91c944ea457c218528e9021443a0cbe05758 Mon Sep 17 00:00:00 2001
+From: nimble-code <gerard.holzmann@gmail.com>
+Date: Sun, 2 Jan 2022 11:26:40 -0800
+Subject: [PATCH] fix
+
+--- a/sched.c
++++ b/sched.c
+@@ -18,7 +18,7 @@ extern int lineno, nr_errs, dumptab, xspin, jumpsteps, columns;
+ extern int u_sync, Elcnt, interactive, TstOnly, cutoff;
+ extern short has_enabled, has_priority, has_code, replay;
+ extern int limited_vis, product, nclaims, old_priority_rules;
+-extern int old_scope_rules, scope_seq[128], scope_level, has_stdin;
++extern int old_scope_rules, scope_seq[256], scope_level, has_stdin;
+
+ extern int pc_highest(Lextok *n);
+ extern void putpostlude(void);
+--- a/spinlex.c
++++ b/spinlex.c
+@@ -51,7 +51,7 @@ extern int implied_semis, ltl_mode, in_seq, par_cnt;
+
+ short has_stack = 0;
+ int lineno = 1;
+-int scope_seq[128], scope_level = 0;
++int scope_seq[256], scope_level = 0;
+ char CurScope[MAXSCOPESZ];
+ char yytext[2048];
+ FILE *yyin, *yyout;
+From 9ecb1af6d174532f3a77acae3a1d424fe7345a3e Mon Sep 17 00:00:00 2001
+From: nimble-code <gerard.holzmann@gmail.com>
+Date: Sat, 15 Jan 2022 10:39:38 -0800
+Subject: [PATCH] nesting limit
+
+--- a/spinlex.c
++++ b/spinlex.c
+@@ -1704,8 +1704,16 @@ lex(void)
+ case '|': c = follow('|', OR, '|'); break;
+ case ';': c = SEMI; break;
+ case '.': c = follow('.', DOTDOT, '.'); break;
+- case '{': scope_seq[scope_level++]++; set_cur_scope(); break;
+- case '}': scope_level--; set_cur_scope(); break;
++ case '{':
++ assert(scope_level < sizeof(scope_seq)-1);
++ scope_seq[scope_level++]++;
++ set_cur_scope();
++ break;
++ case '}':
++ assert(scope_level > 0);
++ scope_level--;
++ set_cur_scope();
++ break;
+ default : break;
+ }
+ ValToken(0, c)
diff --git a/sci-mathematics/spin/spin-6.5.2.ebuild b/sci-mathematics/spin/spin-6.5.2-r1.ebuild
index 5e4110e9abeb..0e1f17681a7c 100644
--- a/sci-mathematics/spin/spin-6.5.2.ebuild
+++ b/sci-mathematics/spin/spin-6.5.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,7 @@ BDEPEND="virtual/yacc"
PATCHES=(
"${FILESDIR}"/${PN}-6.5.2-makefile.patch
+ "${FILESDIR}"/${PN}-6.5.2-nesting_limit.patch
)
S="${WORKDIR}"/${MY_P}/Src