summaryrefslogtreecommitdiff
path: root/sci-mathematics/slepc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /sci-mathematics/slepc
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'sci-mathematics/slepc')
-rw-r--r--sci-mathematics/slepc/Manifest3
-rw-r--r--sci-mathematics/slepc/metadata.xml15
-rw-r--r--sci-mathematics/slepc/slepc-3.11.1.ebuild75
3 files changed, 93 insertions, 0 deletions
diff --git a/sci-mathematics/slepc/Manifest b/sci-mathematics/slepc/Manifest
new file mode 100644
index 000000000000..414735747532
--- /dev/null
+++ b/sci-mathematics/slepc/Manifest
@@ -0,0 +1,3 @@
+DIST slepc-3.11.1.tar.gz 4700643 BLAKE2B a624050aad0128d7ef53f27f72484e078e62d8edf9298995dda71a9e8d804dddc7e433542eccf95b2d896be80e8795b1664375e68a4c02c18c56d78d490bffb7 SHA512 a941c2a955953ed2344de7f7d9eaaed79504c3559e27920c633bc09cfb192f883b26fd4aa5dc3bd9909a2fc045f3a34e514feca0e074ca36bc3166aa9c059235
+EBUILD slepc-3.11.1.ebuild 1661 BLAKE2B 6844c1e110d47bf7620e5a1712bbd265d6d0a40f65e8961ec3818c0eeb5b56c95b35bf4b76fdeab1a144a4561f549e4be1ad8a4cb27fcd623add77fd3e33af97 SHA512 e827d09af4082f3b6e6a96ae1880042a292f7cc1d44729c2efc77cfac91a554dde8f19ea8210dbc5d532e9f09786ec87d6a92ad379e18326181eee35e6f33d2d
+MISC metadata.xml 451 BLAKE2B 5268292011dffcbc322504b29332ae20a4e775238e201ffe793e1ebfb8d8c13a836ca1f8eba44b38bc63ba7b21a3634a03df9990e8b801def0152316d1539960 SHA512 7bf6d4cdedaa48f96e9b1d3e237b795f7cbfd840cece0c0181c9efa05ec833477191e8d12cf2b7737a921b85fb5af055d5868e1173415fc70802eb515959c9d5
diff --git a/sci-mathematics/slepc/metadata.xml b/sci-mathematics/slepc/metadata.xml
new file mode 100644
index 000000000000..046ec6c8f405
--- /dev/null
+++ b/sci-mathematics/slepc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <use>
+ <flag name="complex-scalars">Make scalars complex</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-mathematics/slepc/slepc-3.11.1.ebuild b/sci-mathematics/slepc/slepc-3.11.1.ebuild
new file mode 100644
index 000000000000..52212cabfd52
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.11.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="http://slepc.upv.es/"
+SRC_URI="http://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_prepare() {
+ default
+
+ sed -i -e 's%/usr/bin/env python%/usr/bin/env python2%' configure || die
+}
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ unset SLEPC_DIR
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-arpack-flags="$(usex mpi "-lparpack,-larpack" "-larpack")"
+
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}